What's new

Please help me avoid wasted time! (Services issue)

klepp0906

Member
Member
Ugh! I should have learned my lesson by now. Always keep a list of disabled services as you disable them! I spent a dramatic amount of time referencing 2-3 resources for each service I disabled and have had no issues up until now.

I disabled a few in a row without restarting and managed to forget which they were.

This has caused two issues which I need help resolving. If I can't/don't - the end result will be me having to reset them all to default, go through them one by one again - AND STILL not know which was the one(s) that caused my problem(s) which will risk the same thing happening again.

Without further adieu

1) I set an account picture to my Microsoft.net account for windows 8.1x64 (the one that pops up when you turn on your PC and have to enter your password right after the lock screen but before windows) and after a restart, it disappears and goes back to the default grey square with a white outline of an avatar)

2) all my installed programs disappeared on the start screen! It's literally blank. I didn't have much due to it being a fairly new install but they all disappeared including PC settings and metro store (the two metro apps I had left). I checked if the apps still worked (mumble for example because it also disappeared) and they did, but if you go under program data/start menu/programs etc, all the folders with the app shortcuts in them are gone!

I tried to reinstall mumble; and it reinstalled fine, but still NO folder w shortcut being placed in the start menu therefore nothing being put on the start/apps screen.

What on earth could be doing this service wise?

I know it's a lot to read guys - sorry!
 

My Computer

System One

  • OS
    Windows 8.1 Enterprise x64
    Computer type
    PC/Desktop
    CPU
    Intel i7 4790K
    Motherboard
    Gigabyte Z87X - OC Force
    Memory
    Corsair Dominator Platinum 2133 (32GB)
    Graphics Card(s)
    EVGA GTX TITAN SC x4
    Monitor(s) Displays
    Dell U2713H x3
    Screen Resolution
    4680x2560
    Hard Drives
    Samsung 840 EVO x2 (512GB)
    Seagate Barracuda x2 (4TB)
    PSU
    EVGA NEX1500 Supernova x2
    Case
    Corsair Obsidian 900D
    Cooling
    EK Supremacy & XSPC RX360
    Keyboard
    Razer Deathstalker Ultimate
    Mouse
    Razer Naga Epic
    Internet Speed
    AT&T Uverse 45Mbp/s
    Browser
    Chromium x64

broe23

Retired from the grind
VIP Member
Pro User
I rarely disable services. The great thing about Windows 8.x.x. Is that it will now decide which services need to be running or go into a standby mode if not needed.

The one that I do turn off is the BlueTooth service on those units that do not have Bluetooth adapters. Indexing is an iffy, due to it is used by File History when backing up.
 

My Computer

System One

  • OS
    Linux Mint 17.2
    Computer type
    Laptop
    System Manufacturer/Model
    Toshiba Satellite C850D-st3nx1
    CPU
    AMD E1-1200 APU with Radeon (tm) HD Graphics 1.40 GHZ
    Memory
    12GB
    Graphics Card(s)
    AMD Radeon™ HD 7310 Graphics
    Sound Card
    Realtek HD
    Monitor(s) Displays
    LCD
    Screen Resolution
    1366 x 768
    Hard Drives
    Crucial M500 240GB SSD
    Mouse
    Logitech M525
    Internet Speed
    45/6 - ATT U-Verse
    Browser
    Google Chrome
    Antivirus
    None needed. It is Linux.
    Other Info
    Arris NVG589 Gateway; Router - Cisco RV320; Switch - Netgear GS108 8-Port Switch & Trendnet TEG-S50g 5-Port Switch; Access Points - Engenius ECB350, Trendnet TEW-638APB; NAS - Lenovo ix2-4; Printer - Brother HL-2280DW; Air Print Server - Lantronix XPrintServer

    A/V UPS - Tripp-Lite Smart 1500LCD 1500 Va/900 W.

topgundcp

Well-Known Member
VIP Member
Guru

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox

oneeyed

New Member
Pro User
I might be wrong but I think Disabling / Shutting down a service is logged by Windows. Control Panel > System and Security > Administrative Tools > Event Viewer (You might need to run this as administrator to be able to see everything logged)
This should help you remember which services you changed/disabled last.
 

My Computer

System One

  • OS
    Windows 8.1 (x64)
    Computer type
    PC/Desktop

klepp0906

Member
Member
I didn't in the past, but it certainly cut down my boot time dramatically and I figured if in gonna do that I might as well do it to it's best/extreme.

The account pic I think may be a result of my backup PC somehow linking as having no pic as opposed to taking the pic that was on my PC. Could be wrong though.

Regardless installed programs not showing up is an issue and has me stumped.

I know someone with thorough knowledge of services will pop on eventually: their are only so many it could be. As you said many don't run unless triggered anyhow so id imagine it's one of those which starts automatically.

Appears the information provided on the sites I used were/was limited or happened to leave that part out :p

Thanks for the reply!
 

My Computer

System One

  • OS
    Windows 8.1 Enterprise x64
    Computer type
    PC/Desktop
    CPU
    Intel i7 4790K
    Motherboard
    Gigabyte Z87X - OC Force
    Memory
    Corsair Dominator Platinum 2133 (32GB)
    Graphics Card(s)
    EVGA GTX TITAN SC x4
    Monitor(s) Displays
    Dell U2713H x3
    Screen Resolution
    4680x2560
    Hard Drives
    Samsung 840 EVO x2 (512GB)
    Seagate Barracuda x2 (4TB)
    PSU
    EVGA NEX1500 Supernova x2
    Case
    Corsair Obsidian 900D
    Cooling
    EK Supremacy & XSPC RX360
    Keyboard
    Razer Deathstalker Ultimate
    Mouse
    Razer Naga Epic
    Internet Speed
    AT&T Uverse 45Mbp/s
    Browser
    Chromium x64

TechnoMage

Active Member
Power User
I'm going to +1, the post to use the info on the "Black Viper's" web site.

I went through that one service by one service thing way back in the early XP days. If I remember correctly (that was actually a long time ago now) doing a System Restore fixed my mess-ups, and there were many.

After I found the information about Services on the Black Viper's site, I determined what Services I wanted to either Shut Down all together or change to "Manual"..... I wrote those services into a batch file so I could just run it on any PC and in a few seconds have the job done, without any mistakes. On XP I was shutting down up to 24 Services and on Windows 8.1 that count goes up to almost 40.

I'll gladly share that batch file structure with anyone who needs it. I won't post it here.

Good Luck

:cool:
 

My Computer

System One

  • OS
    Win-8.1/Pro/64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home Made
    CPU
    AMD 8 Core
    Motherboard
    Gigabyte, Ultra Durable, GA-970A-DSP3
    Memory
    Crucial, 8GB
    Graphics Card(s)
    AMD Radeon HD 5450 (2 GB)
    Sound Card
    On Board
    Monitor(s) Displays
    24" LG
    Hard Drives
    Sandisk, SSD 120GB, 8TB Seagate backup drive
    PSU
    Antec Earthwatts, 650
    Case
    Pac-Man Case
    Keyboard
    HP Professional
    Mouse
    GearHead Wireless
    Internet Speed
    5 Meg
    Browser
    Firefox
    Other Info
    Using Classic Shell on Win-8.1 /pro/64

TechnoMage

Active Member
Power User
Addendum, to my last post:

Speeding up your boot process can also be accomplished by doing this fairly simple procedure.

(I didn't dream this up.....I found it on the WWW, and it does seem to work. I use it on all my own PC's, from XP to 8.1)

Shorten the Boot Time in XP, Vista & Windows 7 & 8, 8.1

Go to the start button, choose run, then type msconfig and press Ok.
On the system configuration window, choose the "Boot.INI" tab.

Check “No Gui Boot”, then lower the timeout to a more manageable time.
I choose 3 seconds instead of 30. (windows won’t accept a lower number than 3)

Next choose advanced options.
This is where you can choose how many processors you have.
Most modern PC's are duo core (2 processors) with some quad core (4 processors)
or even six core....So select the number of cores you actually have then choose OK.
The Windows default is only 1 core.

Now choose apply and OK, reboot and you should see a marked decrease in boot time,
And an Increase in Run-Time efficiency.


There are even more tweaks to speed up a PC, but every time I post them, I get flamed by some
self proclaimed 'Expert' who says they can't work. Sorry about that.

Cheers Mates!

:cool:
 

My Computer

System One

  • OS
    Win-8.1/Pro/64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home Made
    CPU
    AMD 8 Core
    Motherboard
    Gigabyte, Ultra Durable, GA-970A-DSP3
    Memory
    Crucial, 8GB
    Graphics Card(s)
    AMD Radeon HD 5450 (2 GB)
    Sound Card
    On Board
    Monitor(s) Displays
    24" LG
    Hard Drives
    Sandisk, SSD 120GB, 8TB Seagate backup drive
    PSU
    Antec Earthwatts, 650
    Case
    Pac-Man Case
    Keyboard
    HP Professional
    Mouse
    GearHead Wireless
    Internet Speed
    5 Meg
    Browser
    Firefox
    Other Info
    Using Classic Shell on Win-8.1 /pro/64

CountMike

Well-Known Member
VIP Member
Guru
Addendum, to my last post:

Speeding up your boot process can also be accomplished by doing this fairly simple procedure.

(I didn't dream this up.....I found it on the WWW, and it does seem to work. I use it on all my own PC's, from XP to 8.1)

Shorten the Boot Time in XP, Vista & Windows 7 & 8, 8.1

Go to the start button, choose run, then type msconfig and press Ok.
On the system configuration window, choose the "Boot.INI" tab.

Check “No Gui Boot”, then lower the timeout to a more manageable time.
I choose 3 seconds instead of 30. (windows won’t accept a lower number than 3)

Next choose advanced options.
This is where you can choose how many processors you have.
Most modern PC's are duo core (2 processors) with some quad core (4 processors)
or even six core....So select the number of cores you actually have then choose OK.
The Windows default is only 1 core.

Now choose apply and OK, reboot and you should see a marked decrease in boot time,
And an Increase in Run-Time efficiency.


There are even more tweaks to speed up a PC, but every time I post them, I get flamed by some
self proclaimed 'Expert' who says they can't work. Sorry about that.

Cheers Mates!

:cool:
Just a small addendum to "So select the number of cores you actually have then choose OK"
Set the number of cores to maximum you can see there, some processors count hyperthreads as actual Cores so if it's not set to maximum, you might be missing on that feature. At same place you can find "Maximum memory", uncheck that if you do not need to restrict memory usage.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home made
    CPU
    AMD Ryzen7 2700x
    Motherboard
    Asus Prime x470 Pro
    Memory
    16GB Kingston 3600
    Graphics Card(s)
    Asus strix 570 OC 4gb
    Hard Drives
    Samsung 960 evo 250GB
    Silicon Power V70 240GB SSD
    WD 1 TB Blue
    WD 2 TB Blue
    Bunch of backup HDDs.
    PSU
    Sharkoon, Silent Storm 660W
    Case
    Raidmax
    Cooling
    CCM Nepton 140xl
    Internet Speed
    40/2 Mbps
    Browser
    Firefox
    Antivirus
    WD

LMiller7

Active Member
Pro User
Regarding the "Number of processors" option in msconfig.

This setting and other of the boot options have been widely misrepresented on the Internet, going all the way back to the early days of XP. The level of knowledge displayed on these "tweaking" sites is usually very low. In many cases the article is simply a copy of one found elsewhere. You know it is a copy because it uses the same phrases, the same misspelled words. Few of these authors have any idea of what real testing means, let alone how to do it, let alone have actually done it. The extent of testing is usually "It feels faster". This kind of testing is highly subjective and much prone to the placebo effect. Real testing is far more complex than most people imagine.

The advanced boot options are contained in the boot configuration file (name and location depends on the OS). They are all optional parameters. If present the defined values will override the default values. The msconfig utility proves a simple way to set the more commonly used options.

In the case of the "Number of Processors" option the default behavior is to use all available processors. For the large majority of cases this will be appropriate. But for testing purposes it may be desirable to limit this value. For example, a software developer may wish to restrict the number of cores to test how an application works with fewer cores than on the development system. Similarly for the "Maximum Memory" option.

When the msconfig dialog is closed with the "OK" button the dialog code examines the state of the checkbox. If set, the appropriate option is set in the configuration file, otherwise it is removed. The default number of cores is displayed as "1". But unless the checkbox is checked this value never leaves the dialog and the boot process never sees it. It simply use whatever the system has.

I don't have any inside knowledge of how the msconfig dialog works. But I am a programmer (amateur) and know how these things are normally done.

The "Number of Processors" option is relatively harmless. Not so the "Maximum Memory" option. Many people will set this, reboot, and all seems well. Months later the memory is upgraded, but the boot options remain the same. Needless to say this has been long forgotten. The result is that the upgrade appears to do nothing. This often results in hours of troubleshooting, days of back and forth discussion on a forum. I am sure in many cases the issue is never resolved.

I hope this clears up some of the confusion.
 

My Computer

System One

  • OS
    Windows 7
    Computer type
    PC/Desktop

CountMike

Well-Known Member
VIP Member
Guru
Number of processor cores setting I experienced few times myself with Wun7 and Win8, When any of them were clean installed both of them showed one core working. First noticed with Win 7 when I was troubleshooting low speed I was experiencing and used SpeedFan to monitor and it shoved only one core. Later on checked with other monitoring programs and all showed only one core running. I checked Advanced boot options in Msconfig for another matter and found setting for cores to be one. It first I thought it was for boot time only but after setting at two cores (had a two core Athlon II at the time) all test programs showed both cores being used. Same thing happened with Win8 but at that time had a 4 core processor and with same symptoms except that Win8 (at that time it was RC version) was happier running on one core than 7 was. I never tried with the box unchecked till later on and than it was the same when one or all cores were set. It might be different with other platforms or BIOSs but this was in my case. Mind you, the performance of windows itself was not affected much but that of some programs was very pronounced.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home made
    CPU
    AMD Ryzen7 2700x
    Motherboard
    Asus Prime x470 Pro
    Memory
    16GB Kingston 3600
    Graphics Card(s)
    Asus strix 570 OC 4gb
    Hard Drives
    Samsung 960 evo 250GB
    Silicon Power V70 240GB SSD
    WD 1 TB Blue
    WD 2 TB Blue
    Bunch of backup HDDs.
    PSU
    Sharkoon, Silent Storm 660W
    Case
    Raidmax
    Cooling
    CCM Nepton 140xl
    Internet Speed
    40/2 Mbps
    Browser
    Firefox
    Antivirus
    WD

LMiller7

Active Member
Pro User
I accept that there may be unusual cases where an explicit setting is necessary. My issue is with it being done as a matter of routine when no problems are evident.

I meant to add that these are called boot options but their effects remain throughout the session, not just during the boot process. This is often misunderstood.
 

My Computer

System One

  • OS
    Windows 7
    Computer type
    PC/Desktop

CountMike

Well-Known Member
VIP Member
Guru
I accept that there may be unusual cases where an explicit setting is necessary. My issue is with it being done as a matter of routine when no problems are evident.

I meant to add that these are called boot options but their effects remain throughout the session, not just during the boot process. This is often misunderstood.
It seems to affect AMD platform mostly. It may have something to do with processor drivers as each core has it's own driver in control panel's Device manager. It could be happening because windows do not recognize them right during installation so I usually check those settings at first inspection after clean install. Can't hurt anyway.As soon as I have time I'll check what will happen if I change those settings.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home made
    CPU
    AMD Ryzen7 2700x
    Motherboard
    Asus Prime x470 Pro
    Memory
    16GB Kingston 3600
    Graphics Card(s)
    Asus strix 570 OC 4gb
    Hard Drives
    Samsung 960 evo 250GB
    Silicon Power V70 240GB SSD
    WD 1 TB Blue
    WD 2 TB Blue
    Bunch of backup HDDs.
    PSU
    Sharkoon, Silent Storm 660W
    Case
    Raidmax
    Cooling
    CCM Nepton 140xl
    Internet Speed
    40/2 Mbps
    Browser
    Firefox
    Antivirus
    WD

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top