Plantronics Gamecom USB Headset, No sound from Mic


New Member
I've been using the below headset for over a year.

This weekend, when I went out of town, I unplugged them to pack them up and use when I got to my desto, but when I plugged it back in, my mic wouldn't work. And now that I'm back home, it's still not working.

Despite checking in recording tab under sound options and made sure it was the default device, uninstalling and reinstalling the drivers, making sure the mute button on the headset isn't on, ran Windows update and restarted multiple times from all of my attempts, it's still no bueno. What has me even more confused is that when I'm on Teamspeak or Mumble, my game buddies can see me light up when I use my push to talk but they can't hear me. I can hear them however so it's just the mic that I'm having an issue with.

Here is a screen shot of my devices until the recording tab under the sound option. After I reinstalled the drivers from Plantronics, I see a Line device (which looks like it should go to a game console which I don't have) and an SPDIF Interface device which I've also never seen before. I don't remember seeing the Stereo Mix device either to be honest.

I have all devices showing in case that becomes a question next. I even work in ITS and this one has got me stumped. Something like this should be relatively easy. I've always just been able to switch back and forth between default devices for switching headset or on board speakers. :)


Thank you so much in advance for your feedback. I've been creeping on these forums all day and decided to join. There seem to be some super knowledgeable people around here. :)

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    System Manufacturer/Model