• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Permissions Problem Despite Full Control Settings


stlsailor

New Member
Posts
12
#1
I am running two machines, both with Windows 8. Both my wife and I are set up as users on Desktop A (mine), and Desktop B (hers) as administrators with Windows Live accounts.

Desktop A has a folder called people. I have set it up to give her full control on both the Sharing tab and the Security tab. Yet if she is on computer B and tries to save a simple Notepad document into that directory it tells her she does not have permission. I tried to do the same in my account from Laptop C and got the same message.

The real problem is that I have a database in that folder she cannot access since I converted both computers to Windows 8 (all worked fine on Windows 7). But if I can get the sharing problem worked out, I expect that will take care of itself.

What does Windows 8 need besides the Sharing and Security tabs set up to allow her full control?
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop
#2
Did you add the check marks for full control after adding the "Everyone" share to the Security tab of the C:? >Users folder like the link below is showing?

Is this the only file that you don't have the "write" privilege's on?

HDD sharing - Windows 7 Help Forums
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

stlsailor

New Member
Posts
12
#3
Did you add the check marks for full control after adding the "Everyone" share to the Security tab of the C:? >Users folder like the link below is showing?
I didn't set up the C:?>Users folder as shared. Only the People subfolder. In that subfolder the checkboxes are checked for full control to my wife, but not Everyone. That was true on both the Sharing and Security tabs. {Actually I relocated the Users folder to D:\ when I set up Windows to keep my OS and data separate.}


Is this the only file that you don't have the "write" privilege's on?
Not sure I understand the question, but I'll try. I set up full control for my wife on the People folder, then tried to write a new Notepad file into it from her machine. When I set up the access privileges I told it to extend to subfolders of People. (I specifically also set full control for her on the database file that is the ultimate goal to access.) For right now, that's all, though once I get this worked out there are other folders for which I need to set up permissions.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop
#4
I think maybe a bit confused on how this works, you must first enable sharing through the sharing tab of the C:> Users folder otherwise no folders will be sharable further down the hierarchy. You can't really share a single folder without this. Although this should have been enabled by default sometimes it gets turned off, the user folder needs to look like the picture below.

This will share all of the User folders, Documents, Music, etc. with everyone in the workgroup, you would then select the "stop sharing" option to un-share other user folders as required. This is basically how you need to approach the sharing options in Windows.

Also, adding a user name to the share with list' doesn't work for individual user sharing unless the User account is located on the same machine which is hardly ever the case.



Now for drive access on a different machine which was created under a different user name you would need to access the Security tab of the C:>User folder then Add > Everyone to the "share with" list per the HDD sharing link I posted earlier.

Although it's best not to make adjustments to the Security tab unless it's required.
 

Attachments

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

Wullail

Active Member
Pro User
Posts
467
#5
Wouldn't using a Homegroup and sharing / updating files that way be simpler?
 

My Computer

System One

  • OS
    Windows 8 Pro
    Computer type
    PC/Desktop
    Memory
    6 GB
    Screen Resolution
    1280 x 1024
    Hard Drives
    12 TB in 6 disks
    PSU
    TX650
    Keyboard
    G15
    Mouse
    Intellimouse 3.0
    Internet Speed
    100 Mbits
    Browser
    Chrome
    Antivirus
    Trend Micro
#6
Wouldn't using a Homegroup and sharing / updating files that way be simpler?
Even with a Homegroup set up the correct permissions for the User folder are still required.

If the Users folder isn't shared then none of the other personal user folders will be sharable. That is the problem the Op is having for now. We can get to the Homegroup after the correct permissions are set up for the Users folder.
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

stlsailor

New Member
Posts
12
#7
Sorry for the delay in responding. I had to be away unexpectedly for a bit. After setting permissions in the user folder, my wife on Desktop B can now create a new text file and save it in the appropriate folder on Desktop A. That's the good news. It's odd I've never needed to do it before, but I appreciate knowing it.

Unfortunately it didn't solve my Microsoft Access problem as I'd hoped it would (but that probably now ought to go to a different forum unless anyone here has an idea). When she opens the Access database on Computer A, it gives her a message that says This file is in a location outside your local network…open this file only if you trust the location, then will only open it read-only. I thought I had set the path as a trusted location, so I'll have to check that when I have time. Not sure beyond that what may be causing the problem.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop

stlsailor

New Member
Posts
12
#8
As far as using a Homegroup, when I tried it back in Windows 7 I found restrictions I didn't want (couldn't share just any folder, and I was keeping data elsewhere), and lack of protection I did want. I would have used Homegroups as an alternative if they could have co-existed with real file sharing, but they couldn't then. I'd be surprised if they could now.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop
#9
So the original problem is solved with the C: Users folder being shared that's good.

Real file sharing I'm sure refers to a standard workgroup?

Yes a Homegroup and a Workgroup can co-exist on the same network.

In fact that is the safest way to set up a home network because the machines on the Homegroup have hidden file shares from anyone else connecting to the local network and also the machines in the local workgroup can't access the library's on the Homegroup machines unless they are expressly shared with them though the Homegroup sharing options.

I'm not sure what you mean about the Microsoft access or do you mean access to certain folders on a network drive that is connected to another machine?
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

stlsailor

New Member
Posts
12
#10
Real file sharing I'm sure refers to a standard workgroup?

Yes a Homegroup and a Workgroup can co-exist on the same network.[

In fact that is the safest way to set up a home network because the machines on the Homegroup have hidden file shares from anyone else connecting to the local network and also the machines in the local workgroup can't access the library's on the Homegroup machines unless they are expressly shared with them though the Homegroup sharing options.
I said it very inartfully, but yes. I had the impression they could not co-exist. Given they can, I may take a second look at homegroups.

I'm not sure what you mean about the Microsoft access or do you mean access to certain folders on a network drive that is connected to another machine?
The database physically resides on computer A. When my wife opens it from computer B, a message box tells her that this file is in a location outside your local network…open this file only if you trust the location. When she tried to open it, it will only let her open it read-only.

It's not clear why the message said computer A was outside the local workgroup. But I ran Access on computer B, and added the location on computer A as a trusted location, thinking that would fix the problem. It didn't. That's when I suspected a permissions problem, which did exist, as verified by trying to save a text file to the directory, and this thread solved. Still, the Access problem persists.

If you have a thought, I'll be out of pocket for a bit, so any delay in response doesn't mean I'm disinterested or unappreciative.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop
#11
It sounds like maybe this machine might not have the correct workgroup name or there may be a secondary router or a router/modem involved that isn't configured correctly.
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps