What's new

PC won't go to sleep on the timer

My PC won't sleep now, on the timer setting. If I put it to sleep manually when I go to bed, it's fine ( I have a cool hot key for that now - when I hit Ctrl-alt-0 ) , but if I just leave it and let the timer try, it won't. I have the settings set to turn off monitor at 10 minutes and sleep at 20 minutes. Here's a powercfg screen that I ran today, with no apparent results, at Admin level.

Sleep problem 7-19-17.gif

One possible complicating factor may be the Idrive backup. I have it set to run backups while I sleep, then it ends and the PC SHOULD go to sleep 20 minutes later, but I came in the last 2 mornings since setting that up and it was awake. BUT it hasnt been going to sleep on the timer anyway.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Asus
    CPU
    FX-8310
    Memory
    DDR3 16GB
    Graphics Card(s)
    Radeon R7 240 2GB

MilesAhead

Eclectician
VIP Member
Pro User
Is it on a network? Sometimes sleep settings are thrown off or the PC wakes by itself if the network card/interface is set to "wake on lan." Check in Device Manager for the network interface and open them up and look at Properties. See if it has a setting to the effect "allow this device to wake" the machine when there is network activity.
 

My Computer

System One

  • OS
    Windows 8.0 x64
    Computer type
    Laptop
    System Manufacturer/Model
    Toshiba Satelite C55D-A Laptop
    CPU
    AMD EI 1200
    Memory
    4 gb DDR3
    Graphics Card(s)
    Raedon 340 MB dedicated Ram
    Monitor(s) Displays
    Built in
    Screen Resolution
    1366 x 768
    Hard Drives
    640 GB (spinner) Sata II
    Keyboard
    Built in
    Mouse
    Touch pad
Is it on a network? Sometimes sleep settings are thrown off or the PC wakes by itself if the network card/interface is set to "wake on lan." Check in Device Manager for the network interface and open them up and look at Properties. See if it has a setting to the effect "allow this device to wake" the machine when there is network activity.

I was thinking the same thing, and made sure that it was unchecked in the wifi network driver, so it cant wake the PC. And per those powercfg checks, nothing is, right?
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Asus
    CPU
    FX-8310
    Memory
    DDR3 16GB
    Graphics Card(s)
    Radeon R7 240 2GB
Still haven't gotten to the bottom of this. Ran all kinds of powercfg tests. Even ran powercfg - energy , which generated a long fancy report that I'm not sure helped. It's in html so it won't let me upload it here, for some reason.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Asus
    CPU
    FX-8310
    Memory
    DDR3 16GB
    Graphics Card(s)
    Radeon R7 240 2GB
Sleep problem 7-31-17 keeping pc awake.jpg

I also have an energy report file but the uploader here isn't seeing it, for some reason.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Asus
    CPU
    FX-8310
    Memory
    DDR3 16GB
    Graphics Card(s)
    Radeon R7 240 2GB
This is interesting. Because no one has replied here, I've been digging around, and found Fixing Windows 8.1 Sleep Issues and Hibernation Problems which mentioned Windows system Log. So I poked around and found this:

Windows error events 8-2-17.jpg

Not sure if that could be what's keeping it from going automatically into sleep mode, or even how to fix it.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Asus
    CPU
    FX-8310
    Memory
    DDR3 16GB
    Graphics Card(s)
    Radeon R7 240 2GB
Is it on a network? Sometimes sleep settings are thrown off or the PC wakes by itself if the network card/interface is set to "wake on lan." Check in Device Manager for the network interface and open them up and look at Properties. See if it has a setting to the effect "allow this device to wake" the machine when there is network activity.

Ok, I just checked, and "wake on magic packet" and "wake on pattern match" are enabled. I don't even know what they are, but are they preventing auto sleep? ...I disabled them on both wifi drivers but it didn't help.

One other possibility: I forget how, now, but I created a command using Ctrl-Alt-0, which immediately puts the PC into sleep, and IT works. I wonder if I could attach it to a timer?...wait... It's:

C:\Windows\System32\rundll32.exe powrprof.dll,SetSuspendState 0,1,0
I made an icon of it too, so when I click the icon, or use Ctrl-Alt-0, it sleeps.
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Asus
    CPU
    FX-8310
    Memory
    DDR3 16GB
    Graphics Card(s)
    Radeon R7 240 2GB
Interesting thing. For some time after I do a Windows update, it will go to sleep automatically. Then it stops again. The time period is usually less than 1 day. Ideas?
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Asus
    CPU
    FX-8310
    Memory
    DDR3 16GB
    Graphics Card(s)
    Radeon R7 240 2GB
Top