• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Paged Pool memory constantly increasing


zbug

New Member
Posts
4
#1
Hi Everyone.

I've been searching as much as i could here and there on the internet without any luck so i'm giving it a chance here if someone has an idea how to troubleshoot/investigate this.

I'm Running Windows 8.1 Update 1 Enterprise.
custom built machine :

I7 4770K
32gb ram
Samsung evo pro 256gb ssd
2x gtx 770 sli

the installation was done around end of january, i don't have much running on that computer but games (i have another system for work)

The issue i have is the Paged Pool memory after system is up is at roughly 250mb but keep increasing around 1-2mb per sec and never stops, after roughly 1h uptime, i'm already at 2gb.(after 1day uptime yesterday, i was at 56gb). The non-paged pool is however never an issue and sits between 150mb and 250mb (i would say normal values)

i've read about disabling NDU, disabling killer networks application (my network driver) and many other things but so far still no luck.

i'm willing to run any kind of software or give any traces, my main issue right now is how to find what is causing this. i believe there is a memory leak somewhere but i have no idea/clues how to trace it down.

Many thanks for your time and help.

cheers

BuG
 

My Computer

System One

  • OS
    Windows 8.1 Enterprise

Brink

Administrator
Administrator
mvp
Posts
23,229
#2
Hello BuG,

With 32 GB of RAM installed, it's not unusual for your page file to get just as large.

If you like, you could use step 11 in the tutorial below to specify a minimum and maximum page file size for your C: drive to prevent it from getting larger on it's own. If you get a low memory or out of memory error afterwards while running Windows, then it means that you will need to increase the size of the page file until you stop getting the error.

If you have plenty of hard drive space, then it is recommended to leave the page file to be system managed though.

Virtual Memory Paging File - Change

Hope this helps, :)
Shawn
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS Maximus X Code Z370
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    250GB Samsung 960 EVO M.2,
    256GB OCZ Vector,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    300 Mb/s Download and 30 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB6190 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

Saltgrass

New Member
Pro User
Posts
1,121
#3
Have you gone through to see what is running on your system? I have a basic system and it is using 160 MB of Paged Pool memory. When I open one app it goes up by 2 MB. Of course, just closing the app does not bring it down since the app does not really close.

I am not really that familiar with this stuff, but I have a system with 2 GTX 680s if you want me to check it to see if the video configuration is involved.

I am assuming you are looking at the Paged Pool in Task Manger?

I am looking at Process Explorer, and it has the ability to look at the Paged Pool for the individual processes if you add the column for it.
 

My Computer

System One

  • OS
    Windows 8.1 x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home Grown
    CPU
    i7 3770K
    Motherboard
    ASUS P8Z77 -v Pro, Z87-Expert
    Memory
    16 G
    Graphics Card(s)
    EVGA GTX 680 Classified (2)
    Hard Drives
    Kingston SSD 240 GB

LMiller7

Active Member
Pro User
Posts
704
#4
A paged pool of 56 GB is very high and likely indicates a memory leak. Limiting the pagefile will eventually cause a crash when the commit limit is reached.

This is not likely caused by an application but more likely by a driver problem, possibly malware. Unfortunately I can't help much with that.
 

My Computer

System One

  • OS
    Windows 7
    Computer type
    PC/Desktop

Saltgrass

New Member
Pro User
Posts
1,121
#5
It looks like Task Manager also has the ability to add a column for Paged Pooled memory. That should give a good indication of what is using it.
 

My Computer

System One

  • OS
    Windows 8.1 x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home Grown
    CPU
    i7 3770K
    Motherboard
    ASUS P8Z77 -v Pro, Z87-Expert
    Memory
    16 G
    Graphics Card(s)
    EVGA GTX 680 Classified (2)
    Hard Drives
    Kingston SSD 240 GB

zbug

New Member
Posts
4
#6
Hi,

I totally agree with the previous post about a memory leak. virus/maware side was fully checked just in case and the system is clean and safe. i've checked every drivers i could think of for their latest version and they should be up to date.

When i check under the Task Manager and even if i add the paged pool memory, all together is FAR from adding up. as i said, if i live it running, the size is increasing by roughly 1mb to 2mb per sec even without doing anything. (i'm currently on my work computer with a lot of applications running and paged file went from ~250mb to ~350mb after 6hours, which looks totally normal to me) And yes, i tried to force the size of a paged pool, and instead, the system eats up all physical memory until it pops up about not having enough virtual memory etc, which is normal.

i tried running driver viewer (viewer.exe) but it seems like it is not super happy when you have 1 or 2 non whql driver and was causing loop bsod at startup.

Any suggestions to investigate a memory leak in the drivers or what software/app to track it is welcome, i don't have any problems to run anything that could help me figure it out as it is driving me quite crazy (and my ssd isn't liking much this kind of file access)

thanks
 

My Computer

System One

  • OS
    Windows 8.1 Enterprise

Brink

Administrator
Administrator
mvp
Posts
23,229
#7

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS Maximus X Code Z370
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    250GB Samsung 960 EVO M.2,
    256GB OCZ Vector,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    300 Mb/s Download and 30 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB6190 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

zbug

New Member
Posts
4
#8
Hi,

Resource monitor/task manager do not show anything special as said before, adding up all the memory used by apps/components seem normal.

i've ran poolmon :

imgur: the simple image sharer

what is this CMNb that seem to be eating up all the memory and is constantly increasing ? i can't find any real information through google searching.
 

My Computer

System One

  • OS
    Windows 8.1 Enterprise

Brink

Administrator
Administrator
mvp
Posts
23,229
#9

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS Maximus X Code Z370
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    250GB Samsung 960 EVO M.2,
    256GB OCZ Vector,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    300 Mb/s Download and 30 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB6190 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

Saltgrass

New Member
Pro User
Posts
1,121
#10
OK, Brink, I have to ask.

My research seems to point to the quote. Does that lead you to the Intel Proset Monitoring Service? This was the one showing in the 8.1 Dbg pooltag.txt. I did see a mention of .Net configuration, but hard to tell if was even referring to this OS.

CMNb - nt!cm - Configuration Manager Name Tag
I can't seem to find poolmon.exe in the Debugging tools and the ADK is a little large for me with Virtual Studio. So I just used the WPRUI.exe.
 

My Computer

System One

  • OS
    Windows 8.1 x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home Grown
    CPU
    i7 3770K
    Motherboard
    ASUS P8Z77 -v Pro, Z87-Expert
    Memory
    16 G
    Graphics Card(s)
    EVGA GTX 680 Classified (2)
    Hard Drives
    Kingston SSD 240 GB

Brink

Administrator
Administrator
mvp
Posts
23,229
#11

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS Maximus X Code Z370
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    250GB Samsung 960 EVO M.2,
    256GB OCZ Vector,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    300 Mb/s Download and 30 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB6190 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

zbug

New Member
Posts
4
#12
Alright.

After 2 days of investigating 1 by 1 drivers then apps then services using poolmon. The damn culprit is this ******** Avira. tested on a VM frenshly installed, same behavior. so either this software is by default leaking like crazy or some others things in combination has that happen. Anyway, many many thanks for all the help/hints provided. im now sitting at 400mb+ while a ton of apps are opened/gaming and all that after a 15h of uptime which is much better.

cheers!
 

My Computer

System One

  • OS
    Windows 8.1 Enterprise

Brink

Administrator
Administrator
mvp
Posts
23,229
#13
Great news. Thank you for posting back with your findings. :)
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS Maximus X Code Z370
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    250GB Samsung 960 EVO M.2,
    256GB OCZ Vector,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    300 Mb/s Download and 30 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB6190 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone