• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Open with->Look for another app on this PC not working


apav

New Member
Posts
4
#1
Hey all,

I'm having an issue with selecting a default program to run a certain file. I installed 7zip, and associated all relevant file types to it in 7zip settings. However it still isn't being associated in Windows (when I click on it it asks me to select a program to open it). However when click More Options, then Look for another app on this PC, nothing happens. Well, something does. No file explorer window comes up like it should (to let me select the program) and the current window where I double clicked the file gets stuck. I can't move the window, and when I click on it Windows plays the "ding" (warning?) sound.

I tried to change the file association in the control panel, but I didn't see .zip or .7z anywhere. Just to test though, I clicked on a random file type, then more options, then Look for another app on this PC, and again nothing happens and the Control Panel window gets frozen.

7zip works, I'm able to right click the file and the 7zip context menu entries are there, but the inner perfectionist in me will not let this go, and I'd like to be able to double click any zip files like I always have.

Any help? Thanks!
 

My Computer

System One

  • OS
    Windows 8.1

jds63

New Member
Pro User
N.Y.

Posts
2,214
#2
Any other programs you tried with default program worked ? Try uninstalling it and then reinstalling it, 7zip.

For the heck of it, why don't you try a SFC SCANDISK. at Admim command prompt type sfc /scannow

Also use DISM same command prompt type dism /online /cleanup-image /restorehealth
 

My Computer

System One

  • OS
    Windows 10 Pro 64bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    CyberPowerPC Gamer Xtreme 1502 (GX1502)
    CPU
    Intel Core i7 5820K 3.30 GHZ 64 bit 6-Core Processor
    Motherboard
    Gigabyte GA-X99-UD3
    Memory
    G.Skill 16GB Quad Channel DDR4-2400MHZ
    Graphics Card(s)
    EVGA GeForce GTX 970 SSC ACX 2.0+ DDR5 4GB
    Sound Card
    Creative Sound Blaster ZxR 5.1
    Monitor(s) Displays
    ASUS PA24Q 24" Pro Art IPS LCD/LED Backlit 1920x1200
    Screen Resolution
    1920x1200 16:10
    Hard Drives
    SAMSUNG 850 EVO 250GB SATA 6Gb/s 2.5" Internal SSD,
    Crucial MX100 512GB SATA 6Gb/s 2.5" Internal SSD,
    WD WD10EZEX-00RKKA0 1TB SATA 6Gb/s 3.5 Internal HDD
    PSU
    EVGA SuperNOVA 750 G2 750W 80 Plus Gold Full Modular
    Case
    AZZA Cosmas Black Gaming Case
    Cooling
    Cool Master Hyper 212 Evo Dual 120mm, ( 2) Noctua PWM 120mm Case Fans (1) Gelid PWM 120mm Blue LED
    Keyboard
    Logitech K800 Illumiated Wireless Keyboard
    Mouse
    Logitech M570 Wireless Trackball
    Internet Speed
    84mbps /94mbps
    Browser
    Mozilla Firefox 41.0.1 / Microsoft Edge/ IE 11
    Antivirus
    Norton Security 2015
    Other Info
    Pioneer BDR-209DBK 16x Blu-Ray Burner, LG 24x Dual Layer DVD Burner,
    StarTech Front Bay 22-in-1 USB 2.0 Internal Multi Media Memory Card Reader,Logitech Z906 5.1 Speaker system

apav

New Member
Posts
4
#3
Any other programs you tried with default program worked ? Try uninstalling it and then reinstalling it, 7zip.

For the heck of it, why don't you try a SFC SCANDISK. at Admim command prompt type sfc /scannow

Also use DISM same command prompt type dism /online /cleanup-image /restorehealth
Thanks for the reply. Like I said I tried to associate a random file type in the Control Panel, and the same thing happened when I went to select "Look for an app on this PC." A file explorer window should come up to let me browse to the program I want to use, but no window opens up, and the current window that file was in freezes. I haven't encountered another file type that needs to be associated with a program, but if I do I'm sure the same thing will happen.


Edit: Just thought I'd mention this too, since they are all probably connected. I'm also experiencing some weird issues I've never experienced before, and I just installed Windows 8. Stuff like the volume mixer not opening (I can't adjust volume by clicking on it, I have to go into the realtek program or a keyboard shortcut. even pressing adjust system volume in the control panel does nothing), or sometimes the start button stops working (left or right clicking it does nothing, have to restart explorer.exe to fix) or if I right click the network and click troubleshoot problem nothing happens (I have to open network and sharing center, click troubleshoot problems, then I have to run each different option as administrator or nothing will happen, again), and Internet Explorer not opening unless I run as administrator. Needless to say I've tried to fix every problem this far, this one about the file associations being the most recent issue. None have been fixed.

I really think it's my hardware. Over the course of 2 years I've had to reinstall Windows 7 5 times, 2 of which were because of a bad secondary HDD which was replaced, the other 3 being OS related issues. I literally just upgraded to Windows 8 to hopefully escape that (hoping it was my Windows 7 install disc or something), but it seems I'm having problems already :( I'm using an mSATA SSD as my OS drive and a new HDD as my secondary. SFC /scannow just passed, chkdsk reported no errors, and I've tested my drives recently extensively and they all look healthy. However, I keep having OS problems no matter how many times I reinstall 7 or even upgrade to 8, so I'm finally at the conclusion that the issue might be my mainboard or some deep irreparable hardware issue.

Edit again: Just completed dism /online /cleanup-image /restorehealth. It said that it was successful and the component store corruption was repaired. Not sure what that means and if it actually fixed something.
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1

apav

New Member
Posts
4
#4
I don't believe it. I solved every problem I listed by disabling "Sync your settings on this PC" in OneDrive's settings. I was looking in the Microsoft Forums for a solution for the unresponsive start button and charms bar issue. Restarting explorer.exe was a temporary fix, since the issue always came back. Then I saw a post that apparently turning OneDrive Sync fixed it for them, so I decided to give it a try. Then I just randomly clicked on volume control to see if it was working, and it did. File explorer now opens when you browse to find a program to open a file, right clicking the network icon and troubleshooting now works without running as administrator, IE now opens without running as administrator, and a few various buttons that weren't doing anything before in the control panel now work.


Of course there are some people posting that disabling OneDrive didn't fix it for them, but since every other problem was fixed by doing this, I'll be hopeful that I'll be issue free from now on.


Still though, who would've thought that disabling One Drive could fix all of these seemingly unrelated issues. Oh and I forgot to mention that the Xbox video app was playing sound when I watched a trailer, but there was no video. Now there is! I don't even understand how One Drive has any effect on these things but I'm too happy to care. :D
 

My Computer

System One

  • OS
    Windows 8.1

jds63

New Member
Pro User
N.Y.

Posts
2,214
#5
Good to know it is fixed, not familiar with using OneDrive, never used it.

SFC still worth a try, won't harm anything. Sorry i saw u used it, nevermind!
 

My Computer

System One

  • OS
    Windows 10 Pro 64bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    CyberPowerPC Gamer Xtreme 1502 (GX1502)
    CPU
    Intel Core i7 5820K 3.30 GHZ 64 bit 6-Core Processor
    Motherboard
    Gigabyte GA-X99-UD3
    Memory
    G.Skill 16GB Quad Channel DDR4-2400MHZ
    Graphics Card(s)
    EVGA GeForce GTX 970 SSC ACX 2.0+ DDR5 4GB
    Sound Card
    Creative Sound Blaster ZxR 5.1
    Monitor(s) Displays
    ASUS PA24Q 24" Pro Art IPS LCD/LED Backlit 1920x1200
    Screen Resolution
    1920x1200 16:10
    Hard Drives
    SAMSUNG 850 EVO 250GB SATA 6Gb/s 2.5" Internal SSD,
    Crucial MX100 512GB SATA 6Gb/s 2.5" Internal SSD,
    WD WD10EZEX-00RKKA0 1TB SATA 6Gb/s 3.5 Internal HDD
    PSU
    EVGA SuperNOVA 750 G2 750W 80 Plus Gold Full Modular
    Case
    AZZA Cosmas Black Gaming Case
    Cooling
    Cool Master Hyper 212 Evo Dual 120mm, ( 2) Noctua PWM 120mm Case Fans (1) Gelid PWM 120mm Blue LED
    Keyboard
    Logitech K800 Illumiated Wireless Keyboard
    Mouse
    Logitech M570 Wireless Trackball
    Internet Speed
    84mbps /94mbps
    Browser
    Mozilla Firefox 41.0.1 / Microsoft Edge/ IE 11
    Antivirus
    Norton Security 2015
    Other Info
    Pioneer BDR-209DBK 16x Blu-Ray Burner, LG 24x Dual Layer DVD Burner,
    StarTech Front Bay 22-in-1 USB 2.0 Internal Multi Media Memory Card Reader,Logitech Z906 5.1 Speaker system

apav

New Member
Posts
4
#6
Good to know it is fixed, not familiar with using OneDrive, never used it.

SFC still worth a try, won't harm anything. Sorry i saw u used it, nevermind!
I could care less since I wasn't planning on using it anyway. And SFC reported no issues on my mSATA SSD boot drive, will try it on my secondary HDD.

Thanks for the help!
 

My Computer

System One

  • OS
    Windows 8.1

jds63

New Member
Pro User
N.Y.

Posts
2,214
#7
Good to know it is fixed, not familiar with using OneDrive, never used it.

SFC still worth a try, won't harm anything. Sorry i saw u used it, nevermind!
I could care less since I wasn't planning on using it anyway. And SFC reported no issues on my mSATA SSD boot drive, will try it on my secondary HDD.

Thanks for the help!
Yeah me either, i use Microsoft Office Pro Plus 2013 do not have a use for it too. Most Welcome, anytime !
 

My Computer

System One

  • OS
    Windows 10 Pro 64bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    CyberPowerPC Gamer Xtreme 1502 (GX1502)
    CPU
    Intel Core i7 5820K 3.30 GHZ 64 bit 6-Core Processor
    Motherboard
    Gigabyte GA-X99-UD3
    Memory
    G.Skill 16GB Quad Channel DDR4-2400MHZ
    Graphics Card(s)
    EVGA GeForce GTX 970 SSC ACX 2.0+ DDR5 4GB
    Sound Card
    Creative Sound Blaster ZxR 5.1
    Monitor(s) Displays
    ASUS PA24Q 24" Pro Art IPS LCD/LED Backlit 1920x1200
    Screen Resolution
    1920x1200 16:10
    Hard Drives
    SAMSUNG 850 EVO 250GB SATA 6Gb/s 2.5" Internal SSD,
    Crucial MX100 512GB SATA 6Gb/s 2.5" Internal SSD,
    WD WD10EZEX-00RKKA0 1TB SATA 6Gb/s 3.5 Internal HDD
    PSU
    EVGA SuperNOVA 750 G2 750W 80 Plus Gold Full Modular
    Case
    AZZA Cosmas Black Gaming Case
    Cooling
    Cool Master Hyper 212 Evo Dual 120mm, ( 2) Noctua PWM 120mm Case Fans (1) Gelid PWM 120mm Blue LED
    Keyboard
    Logitech K800 Illumiated Wireless Keyboard
    Mouse
    Logitech M570 Wireless Trackball
    Internet Speed
    84mbps /94mbps
    Browser
    Mozilla Firefox 41.0.1 / Microsoft Edge/ IE 11
    Antivirus
    Norton Security 2015
    Other Info
    Pioneer BDR-209DBK 16x Blu-Ray Burner, LG 24x Dual Layer DVD Burner,
    StarTech Front Bay 22-in-1 USB 2.0 Internal Multi Media Memory Card Reader,Logitech Z906 5.1 Speaker system

Users Who Are Viewing This Thread (Users: 0, Guests: 1)