• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Oct 17 -- who's got it (W8.1) - Public release only


alphanumeric

slightly off center
VIP Member
Guru
Gold Member
hi guys,

i read here that in order to get the update one has to return back to Windows 8.0 which i find ridiculous.

Am on Windows 8.1 Beta and am not going through the effort.

But on the MS site it says one can upgrade from Beta to Preview, so which is it.

thanks

Jeff
I saw that too. They say you can do it but don't tell you how. My guess is you have to do if from an actual ISO/DVD. Then you get prompted to enter a product code. Just a guess though.
 

My Computer

System One

  • OS
    Windows 10 Education 64 Bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Asus
    CPU
    AMD Phenom II X4 980 Black Edition Deneb 3.7GHz
    Motherboard
    ASUS M4N68T-M V2 µATX Motherboard
    Memory
    8GB 4GBx2 Kingston PC10600 DDR3 1333 Memory
    Graphics Card(s)
    NVIDIA Geforce GT640 2 Gig DDR3 PCIe
    Sound Card
    VIA VT1708s High Definition Audio 8-channel Onboard
    Monitor(s) Displays
    22" LG E2242 1080p and 2 19" I-INC AG191D
    Screen Resolution
    1280x1024 - 1920x1080 - 1280x1024
    Hard Drives
    Crucial MX100 256 GB SSD and 500 GB WD Blue SATA
    PSU
    Thermaltake TR 620
    Case
    Power Up Black ATX Mid-Tower Case
    Cooling
    Stock heatsink fan
    Keyboard
    Logitech Wireless K350 Wave
    Mouse
    Logitech M570 Trackball and T650 TouchPad
    Internet Speed
    80 Mbps Down 30 Mbps Up
    Browser
    Internet Explorer 11
    Antivirus
    Windows Defender
    Other Info
    HP DVD1040e Lightscribe - External USB2

jeffrys

Power User
Power User
BELGIUM

Posts
503
well, prefer a download and install instead of working with an ISO.

I cannot get the update in the STORE.....i Always get redirected to the Belgian site......

Jeff
 

My Computer

System One

  • OS
    WINDOWS 8.1 x64
    Computer type
    PC/Desktop
    CPU
    INTEL CORE I--3770K LGA1155
    Motherboard
    ASUS P8Z77-V
    Memory
    KINGSTON 2400 MHZ KHX24C11K4 16GB
    Graphics Card(s)
    INTEL HD GRAFICS 4000
    Monitor(s) Displays
    Philip BDL3245€ 32 inch
    Screen Resolution
    1920 x 1080
    Hard Drives
    2 SAMSUNG 840 PRO RAID 0 ON BOARD 2 x 128 GB
    Keyboard
    LOGITEC MX™ 5500
    Mouse
    LOGITEC MX 5500
    Internet Speed
    120 Mbps

jimbo45

New Member
VIP Member
Guru
Hafnarfjörður IS

Posts
4,373
well, prefer a download and install instead of working with an ISO.

I cannot get the update in the STORE.....i Always get redirected to the Belgian site......

Jeff
Hi there
Should be available - try going via GOOGLE on W8.1 update and then logging on to US store or UK one - or even AUS.

I got my download though via TechNet - US site - I prefer an ISO though.

Try this though first

Why can't I find the update in the Store? - Microsoft Windows Help

Cheers
jimbo
 

My Computer

System One

  • OS
    Linux Centos 7, W8.1, W7, W2K3 Server W10
    Computer type
    PC/Desktop
    Monitor(s) Displays
    1 X LG 40 inch TV
    Hard Drives
    SSD's * 3 (Samsung 840 series) 250 GB
    2 X 3 TB sata
    5 X 1 TB sata
    Internet Speed
    0.12 GB/s (120Mb/s)

BFG

Betta Fish
Member
USA

Posts
79
I let it update overnight. seemed to have gone smooth. now checking out the new stuff.

I see it changed my desktop background. probably because i was on the default theme and not something custom.

Also noticed 2 new items in windows features turned on and not sure what they are: work folders and smb 1.0 support
 

My Computer

System One

  • OS
    Windows 8
    System Manufacturer/Model
    HP DV7-4269WM
    CPU
    i5-480M
    Memory
    4GB
    Graphics Card(s)
    ATI Mobility Radeon HD 6370
    Sound Card
    Beats Audio
    Monitor(s) Displays
    17.3"
    Screen Resolution
    1600x900
    Hard Drives
    750GB (5400RPM)
    Internet Speed
    1500

azasadny

Moved to ten*****s.com
VIP Member
Guru
Yep, I'm using the Enterprise version and that particular version will not see the update in the Windows store, so I'll have to download the ISO and try to upgrade using that process. I'll do that this weekend...
 

My Computer

System One

  • OS
    Win 10 Pro 64bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built Intel i7-3770k-based system
    CPU
    Intel i7-3770k, Overclocked to 4.6GHz (46x100) with Corsair H110i GT cooler
    Motherboard
    ASRock Z77 OC Formula 2.30 BIOS
    Memory
    32GB DDR3 2133 Corsair Vengeance Pro
    Graphics Card(s)
    GeForce GTX 980ti SC ACS 6GB DDR5 by EVGA
    Sound Card
    Creative Sound Blaster X-Fi Titanium HD, Corsair SP2500 speakers and subwoofer
    Monitor(s) Displays
    LG 27EA33 [Monitor] (27.2"vis) HDMI
    Screen Resolution
    1920x1080
    Hard Drives
    Samsung SSD 850 EVO 250GB (system drive)
    WD 6TB Red NAS hard drives x 2 in Storage Spaces (redundancy)
    PSU
    Corsair 750ax fully modular power supply with sleeved cables
    Case
    Corsair Air 540 with 7 x 140mm fans on front, rear and top panels
    Cooling
    Corsair H110i GT liquid cooled CPU with 4 x 140" Corsair SP "push-pull" and 3 x 140mm fans
    Keyboard
    Thermaltake Poseidon Z illuminated keyboard
    Mouse
    Corsair M65 wired
    Internet Speed
    85MBps DSL
    Browser
    Chrome and Edge
    Antivirus
    Windows Defender, MalwareBytes Pro and CCleaner Pro
    Other Info
    Client of Windows Server 2012 R2 10 PC's, laptops and smartphones on the WLAN.

    1GBps Ethernet ports

jeffrys

Power User
Power User
BELGIUM

Posts
503
"You might need the latest updates from Windows UpdateAlthough the Windows 8.1 update is downloaded and installed from the Store, your PC needs another update, KB 2871389, before Windows 8.1 becomes available to you in the Store.
If you’re using Windows Update to get automatic updates, KB 2871389 will be downloaded and installed automatically.
If you’ve turned off automatic updates, or if your PC is so new that automatic updates haven't been downloaded yet, or if you’d rather not wait for Windows Update to do this automatically, you can go to Windows Update and install KB 2871389 manually.
[h=3]To install the update you need[/h]
  • Open Windows Update by swiping in from the right edge of the screen (or, if you're using a mouse, pointing to the lower-right corner of the screen and moving the mouse pointer up), tapping or clicking Settings, tapping or clicking Change PC settings, and then tapping or clicking Update and recovery.
  • Tap or click Check now, and then wait while Windows looks for the latest updates for your PC.
  • If updates are found, tap or click View details.
  • In the list of available updates, select KB 2871389, and any other updates you want to install, and then tap or click Install.



"

ok JImbo, did that and after check, get the message that there are new updates, but a sec later that there are none.....and that i am set for AUTOMATIC UPDATES.

So i am still stuck here.

Well i have until late january 2014.....

but thanks


Jeff
 

My Computer

System One

  • OS
    WINDOWS 8.1 x64
    Computer type
    PC/Desktop
    CPU
    INTEL CORE I--3770K LGA1155
    Motherboard
    ASUS P8Z77-V
    Memory
    KINGSTON 2400 MHZ KHX24C11K4 16GB
    Graphics Card(s)
    INTEL HD GRAFICS 4000
    Monitor(s) Displays
    Philip BDL3245€ 32 inch
    Screen Resolution
    1920 x 1080
    Hard Drives
    2 SAMSUNG 840 PRO RAID 0 ON BOARD 2 x 128 GB
    Keyboard
    LOGITEC MX™ 5500
    Mouse
    LOGITEC MX 5500
    Internet Speed
    120 Mbps

hdmi

Member
Member
Posts
46
It didn't give me the option to create iso. Might be iso files will not be available for the upgrade. TechNet and MSDN have the Enterprise and VL.

If it doesn't appear for regular folk, the 8.1 rtm plus the 3 G.A. rollup updates are the same thing.

Or, if you are quick you can grab the installation files downloaded fromm the store before they disappear, they look like this:

View attachment 29449

Inside the $windows~bt directory are these fellas

View attachment 29450

Can make an iso from that easily. EDIT - not so easily after all. Even if you manage that - it will only accept 8.1 keys - not 8.0 keys. You might be able to put the install.esd in the sources folder of 8.1RTM iso. Haven't tried it yet. Not something the average user will want to endure.
Thanks for letting me know *after* they disappeared. :doh:
 

My Computer

System One

  • OS
    8.1 x64
    Computer type
    Laptop
    System Manufacturer/Model
    Asus R510L
    CPU
    i7 4510U
    Memory
    8GB DDR3
    Graphics Card(s)
    GeForce 820M
    Sound Card
    Eastern Electric MiniMax DAC Supreme; Emotiva UMC-200; Astell & Kern AK240
    Monitor(s) Displays
    LG 42LH5000
    Screen Resolution
    1920x1080
    Hard Drives
    1TB internal; 45TB external
    PSU
    Li-ion
    Keyboard
    Logitech K800
    Mouse
    Logitech G400
    Internet Speed
    20Mbit/s up, 200Mbit/s down
    Browser
    IE 11

jeffrys

Power User
Power User
BELGIUM

Posts
503
HDMI,

if only i could copy your files......

Jeff
 

My Computer

System One

  • OS
    WINDOWS 8.1 x64
    Computer type
    PC/Desktop
    CPU
    INTEL CORE I--3770K LGA1155
    Motherboard
    ASUS P8Z77-V
    Memory
    KINGSTON 2400 MHZ KHX24C11K4 16GB
    Graphics Card(s)
    INTEL HD GRAFICS 4000
    Monitor(s) Displays
    Philip BDL3245€ 32 inch
    Screen Resolution
    1920 x 1080
    Hard Drives
    2 SAMSUNG 840 PRO RAID 0 ON BOARD 2 x 128 GB
    Keyboard
    LOGITEC MX™ 5500
    Mouse
    LOGITEC MX 5500
    Internet Speed
    120 Mbps

jeffrys

Power User
Power User
BELGIUM

Posts
503
hi,

apparently my mails yesterday to MS - US pulled a trigger. Today i can do what everybody else could, but:

- strange install.....nothing to see in task manager no computer activity what so ever, and when i wanted to post here that once again it is not working a screen pops up to sign in on the MS account. Install finished ok.

- strange install 2....i am asked to put in the computer password and i put in the MS password. Finally i see my fault, put in the local password and could go on.

BUT after 2 x restart i am asked again for the MS password, but this is NOT accepted. I give up after 5 or more retrys go to the 2d computer which for the moment stands next to mine. Go to my MS account, and guess what i can put in my password.

Weird i retry instantly on my own computer.....again, but .....again no result.

Changed the password on the other pc and put the new in right after that on my pc and yes it works. Very strange here but not normal.

At least i had not to go back to Windows 8.0, which i was not going to do anyway.

Jeff
 

My Computer

System One

  • OS
    WINDOWS 8.1 x64
    Computer type
    PC/Desktop
    CPU
    INTEL CORE I--3770K LGA1155
    Motherboard
    ASUS P8Z77-V
    Memory
    KINGSTON 2400 MHZ KHX24C11K4 16GB
    Graphics Card(s)
    INTEL HD GRAFICS 4000
    Monitor(s) Displays
    Philip BDL3245€ 32 inch
    Screen Resolution
    1920 x 1080
    Hard Drives
    2 SAMSUNG 840 PRO RAID 0 ON BOARD 2 x 128 GB
    Keyboard
    LOGITEC MX™ 5500
    Mouse
    LOGITEC MX 5500
    Internet Speed
    120 Mbps

mikiep

New Member
Member
Posts
158
I updated 8.1 preview to 8.1 - before it showed in the store - maybe 20 minutes for the install. Fast full speed download, but I did it fairly early morn 17th.
Lenovo laptop was originally win7 with $40 upgrade to win8... to 8.1 preview. Then I downloaded the 8.1 upgrade iso and burn it because I cant yet find ...the make System Repair disk option anywhere.

Update from Windows 8.1 Preview to Windows 8.1
Update from Windows 8.1 Preview to Windows 8.1 - Microsoft Windows Help

Everything, . works. Had to set path for Temp Internet Files was only small glitch.
 

My Computer

System One

  • OS
    win8.1
    Computer type
    Laptop
    System Manufacturer/Model
    lenovo

jeffrys

Power User
Power User
BELGIUM

Posts
503
Strange, Mikiep,

i got the message that 21 programs where compatible, but when looking in Programs & Features"....there are none....

So in fact download & install took some 15 minutes, solving problem with the password also 15 minutes and now resetting/installing everything again.....well some 2 hours.

My god.....

Forget to tell, i was not asked to put in my serial number, but this will maeby be asked in a few weeks. If so, why not now....


Jeff
 

My Computer

System One

  • OS
    WINDOWS 8.1 x64
    Computer type
    PC/Desktop
    CPU
    INTEL CORE I--3770K LGA1155
    Motherboard
    ASUS P8Z77-V
    Memory
    KINGSTON 2400 MHZ KHX24C11K4 16GB
    Graphics Card(s)
    INTEL HD GRAFICS 4000
    Monitor(s) Displays
    Philip BDL3245€ 32 inch
    Screen Resolution
    1920 x 1080
    Hard Drives
    2 SAMSUNG 840 PRO RAID 0 ON BOARD 2 x 128 GB
    Keyboard
    LOGITEC MX™ 5500
    Mouse
    LOGITEC MX 5500
    Internet Speed
    120 Mbps

HippsieGypsie

It's Gururrrrrr8!
Lilymoor, IL

Posts
13,547
My option to upgrade was there for me on Thursday morning the 17th via the Windows update. After reading threads here for a few days on how upgrade went for others via the Store and seeing that there will probably be no official MS ISO released, I decided to give it chance and a go yesterday. All went astronomically well! I was quite surprised.

Going from 8Pro x64 (fresh install) to 8.1 with a 54Mbps connection. Using MS account to sign into an older Acer PC. (Never had a problem with 8 while using it these past months) Backed up everything important and hit the upgrade option in the Store at 12:30pm. The upgrade install progress meter appeared stating "Downloading". Was able to use the PC during 100% of this whole first phase.

2:00pm: The download meter was at 50% and data download was complete. The meter bar changed to "Getting update ready". This was 50-52% of the meter.
2:005pm: The meter bar changed to "Checking compatibility". 52-60%
2:10pm: "Applying changes". 60-70%
2:17pm: "Gathering information". 70-86%
2:27pm: "Preparing to restart". 86-100%
2:31pm: Restart.
2:32pm: Actual upgrading/install screen appears. Cannot use PC at this point. "Setting Up". 0-75% (just like Windows Update screen)
2:46pm: Restart
2:47pm: "Getting Devices Ready". 75-100%. Screen starts to phase in and out of differnt colors.
2:52pm: "Getting Ready".
2:57pm: "Applying PC Settings".
3:03pm: Restart
3:04pm: "Setting Up A Few More Things".
3:14pm: "Getting Ready".
3:15pm: License terms appear. Pressed "Agree".
3:15pm: Asked for "Express Settings" or "Custom". I chose/used Express.
3:16pm: Asked for code for "Trusted PC" via SMS. Entered received code.
3:18pm: "Installing Store Apps". (I'm assuming these are new ones)
3:22pm: "Getting Apps Ready".
3:24pm: "Taking Care Of A Few Things".
3:25pm: "Let's Start". A few seconds later my Start Screen appeared just as I left it in 8 with the same titled columns with no tiles moved or changed, however there were a few more new Bing apps added at the end of the screen.

All system settings (except DVD and thumb drive defaults > no biggie), Favorites, and all of my desktop programs and Modern apps are there. I noticed in Programs and Features that "Microsoft Mouse and Keyboard Center, Office Pro 2013, Skydrive may have been reinstalled for it shows the new date > Not sure. Had a little trouble with IE11 and some addons that weren't meeting safety features. Java being one. Bing Bar, above all things, was another. I consider these minor things that are easily fixed. There were 7 system updates that were installed during the install process. 5 were saved. One was installed shortly after installation completed. I have mine set to automatic.

1-1/2 hours to download. 1-1/2 hours to install. 1 hour cannot use the PC. 3 hours total from starting download to Start Screen. Approximately another half hour fiddling which one would do anyway with a fresh install. I consider it the same timing as fresh install if one has to download the ISO to do so.

All in all a good experience. I'll run it for a few days, make sure I have it tweaked, add any apps/programs I may want, and then mirror it for any emergency reinstall.
 

My Computer

System One

  • OS
    8.1 Pro X64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Acer T690
    CPU
    Intel Pentium D Dual Core
    Motherboard
    Acer/Intel E946GZ
    Memory
    2GB (max upgrade)
    Graphics Card(s)
    Intel Graphics Media Accelerator 3000 - PCI Express x16
    Sound Card
    Integrated RealTek ALC888 high-definition audio with 7.1 channel audio support
    Monitor(s) Displays
    Acer AL1917W A LCD
    Screen Resolution
    1440 X 900
    Hard Drives
    350 GB Seagate Barracuda 7200.10
    Thumb drives
    PSU
    Standard 250 watt
    Case
    Desktop 7.2" (183mm) W x 17.5" (445mm) L x 14.5"
    Cooling
    Dual case fans + CPU fan
    Keyboard
    Acer Windows PS/2
    Mouse
    Wireless Microsoft Arc
    Internet Speed
    54mbp/s
    Browser
    IE11
    Antivirus
    Defender
    Other Info
    Office Pro 2013 / Nokia Lumia 1520 Windows Phone 8.1DP GDR1

Users Who Are Viewing This Thread (Users: 0, Guests: 1)