What's new

Solved No USB device is getting detected

op00iuy

Member
Member
Hello everyone,
No USB device seems to be getting detected on my machine when I plug in a flash drive or an external hdd I get the distinctive sound from my speakers that an USB device is plugged in but nothing is showing up in "My Computer". I went through the event logs and found that Windows is failing to load the USB device (check image in attachment logs.jpeg). What is causing this problem ? I am stuck right now. Recently I installed iTunes, so I though it might be causing this problem but I uninstalled it even then the problem persists. I don't want to format my machine just because of this small problem. Is this a driver conflict ? How do I find out why windows is all of a sudden failing to load the USB devices ? I have uploaded a copy of the saved logs detailing this failure(logs.zip). Thanks.
 

Attachments

  • logs.jpg
    logs.jpg
    244 KB · Views: 96
  • logs.zip
    2.7 KB · Views: 21

My Computer

System One

  • OS
    Windows 8.1
    CPU
    Intel i7

kingtez

Member
Member
Go into device Manager and uninstall all the USB controllers! Reboot the computer and see if this helps.
 

My Computer

System One

  • OS
    Windows 8
    Name
    Terry Lewis
    Computer type
    Laptop
    System Manufacturer/Model
    Acer 5750
    CPU
    i3
    Motherboard
    Acer
    Memory
    4GB
    Graphics Card(s)
    Intel 3000
    Sound Card
    Realtek HD Audio
    Monitor(s) Displays
    HD
    Screen Resolution
    1366x768
    Hard Drives
    750GB
    Occupation
    Computer Support
    Browser
    Firefox
    Antivirus
    Avast
    Country Flag
    UK
    State/Region Flag
    uk england

topgundcp

Well-Known Member
VIP Member
Guru
In order to get help, you need to fill out your system specs so that we'll know what kind of PC/Laptop you have.
In the mean time, open my computer and click on computer tab->System Properties->Device manager and look under USB controllers. If you see a yellow exclamation mark in front of the USB port where you attach your device, then there's a problem.

Few things you can try:
  1. Update the BIOS to the latest for your MB.
  2. Update the chipset drivers for your MB (USB drivers also get installed for built in USB's)
  3. Update the firmware for the USB devices built in with your MB.
 

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Name
    Dino
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox
    Country Flag
    USA
    State/Region Flag
    us california

op00iuy

Member
Member
In order to get help, you need to fill out your system specs so that we'll know what kind of PC/Laptop you have.
In the mean time, open my computer and click on computer tab->System Properties->Device manager and look under USB controllers. If you see a yellow exclamation mark in front of the USB port where you attach your device, then there's a problem.

Few things you can try:
  1. Update the BIOS to the latest for your MB.
  2. Update the chipset drivers for your MB (USB drivers also get installed for built in USB's)
  3. Update the firmware for the USB devices built in with your MB.

Yes there is an exclamation mark just as you. Please check the image. I have to USB devices connected so there are two exclamation marks here. What does this error mean ? And how do i update the firmware for the USB devices built in with my MB ? Can you please explain that in detail i am kind of a novice ?
Error.jpg
 

My Computer

System One

  • OS
    Windows 8.1
    CPU
    Intel i7

topgundcp

Well-Known Member
VIP Member
Guru
You still have not filled out your system specs and without knowing who's the manufacturer of your mother board but by looking at the screen shot, step 3 above may not apply to your MB so all you need is to update your BIOS if it's outdated and update the Intel chipset drivers to the latest which will also update the built-in USB drivers (both USB 2.0 & USB 3.0).

Here's the link for the latest Intel Chipset drivers version 9.​4.0.1026: https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=20775

For some motherboard such as MSI Z77 Mpower. In addition to the USB 2.0 ports, it has 2 Intel USB 3.0 ports and 4 USB 3.0 ports from Renesas to give a total of 6 USB 3.0 ports then you have to update both Intel Chipset drivers and the driver/firmware from Renesas.
 

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Name
    Dino
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox
    Country Flag
    USA
    State/Region Flag
    us california

Pylon

New Member
So I work at a school that has Windows 8 on our new Lenovo laptops (Helixes, T430s, X230). Regardless of the model, the ports detect USB thumb drives for a certain amount of time. Eventually they stop working and will not start working unless you do a fresh install of Windows. We suspect that the problem is due to Kaspersky 10 Endpoint Security.
 

My Computer

System One

  • OS
    Windows 8, Windows 7, Windows XP

op00iuy

Member
Member
So I work at a school that has Windows 8 on our new Lenovo laptops (Helixes, T430s, X230). Regardless of the model, the ports detect USB thumb drives for a certain amount of time. Eventually they stop working and will not start working unless you do a fresh install of Windows. We suspect that the problem is due to Kaspersky 10 Endpoint Security.

I solved the problem. The problem was happening due to iTunes. My advise to those using iTunes is that only install the Apple Mobile device driver and completely uninstall everything relating to iTunes. Use iFunBox(google it) to access your data from your iPad when connected to the computer.
 

My Computer

System One

  • OS
    Windows 8.1
    CPU
    Intel i7

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top