• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

No sound after upgrading to Windows 8 Pro


rocklock

New Member
Posts
2
#1
I upgraded to Windows 8 Pro two days back and I am coming across this problem.

When the W8 Pro started for the first time, there was sound. I didn't have to install any driver for it. But the very next day when I started my laptop, there was no sound and at the right hand side of the taskbar there is a Speaker icon with a red cross over it which says "No Audio Output device is installed".

I tried a System restore that didn't solve the problem. Downloaded R270 driver for Windows 8 from Realtek. Funny thing is that when the installation got completed and it asked for a reboot, sound came afterwards. But that too was till the time when I did not switch off the system. Next day, no sound as usual.

I tried different "Fix it" from Microsoft but they didn't do anything.

I ain't sure if I should do the "Troubleshoot compatibility" installation of the sound driver.

Please help guys.
P.S. This Laptop came with Windows Vista, then I upgraded to Windows 7 and now this Windows 8 Pro.
 

Attachments

My Computer

System One

  • OS
    Windows 8 Pro
    System Manufacturer/Model
    Acer Aspire 5520
    CPU
    AMD Turion(tm) 64 X2 Mobile Technology TL-58 @ 1.9Ghz, 2x512 KB L2 Cache
    Motherboard
    ATI M690G chipset
    Memory
    2GB
USA

Posts
118
#2

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom build
    CPU
    AMD Phenom II X 4 965 BE
    Motherboard
    Gigabyte GA-MA790X-DS4
    Memory
    G-Skill 8 GB PC 8500
    Graphics Card(s)
    AMD XFX HD Radeon 6790D
    Sound Card
    Realtek HD onboard
    Monitor(s) Displays
    2l Samsung SyncMaster S20B300
    Screen Resolution
    1600 X 900
    Hard Drives
    Seagate Barracuda 320 GB w/OS
    Seagate Barracuda 1 TB data storage
    PSU
    Ultra X4 750 watt fully modular
    Case
    Thermaltake OverSeer RX 1 fulltower
    Cooling
    Cooler Master Hyper212 120mm
    Keyboard
    Logitech G510
    Mouse
    Razor DeathAdder 3.5

rocklock

New Member
Posts
2
#3
I installed the latest driver(6.0.1.5449) from the link in the Compatibility mode but still there is no sound.

In the device manager, I could not find the Sound option but when I chose the "View Hidden Devices", there was a Sound device.
 

Attachments

My Computer

System One

  • OS
    Windows 8 Pro
    System Manufacturer/Model
    Acer Aspire 5520
    CPU
    AMD Turion(tm) 64 X2 Mobile Technology TL-58 @ 1.9Ghz, 2x512 KB L2 Cache
    Motherboard
    ATI M690G chipset
    Memory
    2GB

Users Who Are Viewing This Thread (Users: 0, Guests: 1)