• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved no iplayer or flash video in IE10


Posts
5
#1
I have Win8 64 bit pro with IE 10 as an OEM installataion on a new Lenovo G580 laptop. BBC sites with video don't work - the error message is along the lines of 'you need flash player to play this video, download it here' If I follow the links, it takes me to Adobe and links to install the 64 bit latest version. WHen I download the file and run it, I then get the error message ' the latest version is already installed, KB2796096'. I've looked at that KB article and it's no help.

I've uninstalled Flash Player using Adobe's uninstaller and tried re-installing it - same error message.

Any ideas?
 

My Computer

System One

  • OS
    Win 8 Pro 64 bit
    System Manufacturer/Model Number
    Lenovo G580 laptop
    CPU
    Intel core i5 3210
    Memory
    6GB

topgundcp

Well-Known Member
VIP Member
Guru
San Jose - California

Posts
2,847
#2
Why don't you uninstall KB2796096 first:
Control Panel->Windows Update->View Update History->Installed Update
High lite KB2796096 then click Uninstall a program.

Then run Adobe's uninstaller just to make sure.

Make sure IE10 is not running. Install Flash player downloaded from Adobe. I believe the latest for IE10 is Version 11.3.378.5
 

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox
Posts
5
#3
Many thanks! I did as you suggest - uninstalled KB2796096, ran the Adobe uninstaller, but then tried IE again - and it worked. Bizarrely, no need to install Flash Player. I'm not complaining though as it now works perfectly on iPlayer, YouTube, etc. Thanks again.
 

My Computer

System One

  • OS
    Win 8 Pro 64 bit
    System Manufacturer/Model Number
    Lenovo G580 laptop
    CPU
    Intel core i5 3210
    Memory
    6GB

topgundcp

Well-Known Member
VIP Member
Guru
San Jose - California

Posts
2,847
#4
The Flash Player plug-in is an Activex with extension .OCX and was installed with KB2796096. I guess the one you have in your Laptop was corrupted so when you uninstalled KB2796096, it was re-installed by Windows Update.
 

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox