• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Networking shared folders from W8.1 to Linux Mint


KiwiTim

New Member
Posts
7
#1
Hi,

I have two Windows 8.1 pcs on a home network. I also have Linux Mint 13 on a laptop. I have installed samba and have attempted to share folders from the Windows 8.1 machines to the laptop. All machines have the same workgroup name and are on the same subnet.

I am not very literate concerning networking, so please keep responses simple.

I can see all the windows machines from my LM laptop when I click 'Network folder' from the linux equivalent of Windows Explorer (nemo).

When I click on a specific windows machines from nemo, a dialog box opens asking for Username, Domain and Password. Now I'm not sure which username and password this is asking for.

Using my username on Linux Mint (tim) in the Username box, the workgroup name in the Domain box, and the Windows 8.1 password in the Password box, I'm able to access shared folders on one Windows 8.1 machine.

However, I cannot gain access to the other machine. My password gets rejected every time. Both Windows 8.1 machines are logged in with the same Microsoft account, so the password on both machines is the same.

Both Windows 8.1 machines have sharing enabled and are members of the same windows homegroup. Both Windows machines have no problem accessing shared folders on each other, and can access the shared folders on the LM laptop.

The only problem is I cannot gain access to one of the Windows 8.1 machines from the Laptop.

Both Windows 8.1 machines have Bitdefender Internet Security, both configured the same. I have tried turning off the firewall completely on both the laptop and the unfriendly windows 8.1 machine, but still I cannot connect.

Could someone please confirm if I am using the password dialog box correctly. Is the username supposed to be the LM username, and the password supposed to be the windows password.

Since this worked for me on one of the machines, I would expect it to have worked for both.

I am asking for help on a Linux Mint forum as well as here.

Perhaps there is some special permissions I need to set on W8.1.

Thanks,
Tim
New Zealand
 

My Computer

System One

  • OS
    Windows 8 Pro 32bit
    System Manufacturer/Model Number
    HP Pavilion DV8000 CT
    CPU
    Turion ML-40 2.2 Ghz Single Core
    Motherboard
    HP
    Memory
    2GB DDR400
    Graphics Card(s)
    ATI Radeon Xpress 200M

broe23

Retired from the grind
VIP Member
Pro User
Central IL

Posts
3,468
#2
You need to use the workgroup name "WORKGROUP" to get SMB/CFS to work. Most likely it is the Firewall for Bitdefender that may be causing the problem. Try disabling Bitdefender and see if it works. Personally I have found Xubuntu works better then Linux Mint did.
 

My Computer

System One

  • OS
    Linux Mint 17.2
    Computer type
    Laptop
    System Manufacturer/Model Number
    Toshiba Satellite C850D-st3nx1
    CPU
    AMD E1-1200 APU with Radeon (tm) HD Graphics 1.40 GHZ
    Memory
    12GB
    Graphics Card(s)
    AMD Radeon™ HD 7310 Graphics
    Sound Card
    Realtek HD
    Monitor(s) Displays
    LCD
    Screen Resolution
    1366 x 768
    Hard Drives
    Crucial M500 240GB SSD
    Mouse
    Logitech M525
    Internet Speed
    45/6 - ATT U-Verse
    Browser
    Google Chrome
    Antivirus
    None needed. It is Linux.
    Other Info
    Arris NVG589 Gateway; Router - Cisco RV320; Switch - Netgear GS108 8-Port Switch & Trendnet TEG-S50g 5-Port Switch; Access Points - Engenius ECB350, Trendnet TEW-638APB; NAS - Lenovo ix2-4; Printer - Brother HL-2280DW; Air Print Server - Lantronix XPrintServer

    A/V UPS - Tripp-Lite Smart 1500LCD 1500 Va/900 W.

KiwiTim

New Member
Posts
7
#3
Hi thanks for the response. I disabled the firewall on both Linux Mint and W8.1, but the problem persisted. My workgroup isn't WORKGROUP it's TURK and that works fine with one of the windows machines. Since I'm getting access from LM to one W8.1 machine, then I think the issue must be with Windows, not LM, otherwise I'd have no access to either windows machines.
 

My Computer

System One

  • OS
    Windows 8 Pro 32bit
    System Manufacturer/Model Number
    HP Pavilion DV8000 CT
    CPU
    Turion ML-40 2.2 Ghz Single Core
    Motherboard
    HP
    Memory
    2GB DDR400
    Graphics Card(s)
    ATI Radeon Xpress 200M

broe23

Retired from the grind
VIP Member
Pro User
Central IL

Posts
3,468
#4
First thing you need to do is set the workgroup name on both machines back to "WORKGROUP". As for logging into the Windows machine from the Linux Mint. You use the username that is on the Windows computer. For the Linux Mint. It is the Linux Mint username.

There is an issue with Samba, that Windows has regarding Workgroup naming. We have found that just leaving it as "WORKGROUP". Resolves a lot of those problems.
 

My Computer

System One

  • OS
    Linux Mint 17.2
    Computer type
    Laptop
    System Manufacturer/Model Number
    Toshiba Satellite C850D-st3nx1
    CPU
    AMD E1-1200 APU with Radeon (tm) HD Graphics 1.40 GHZ
    Memory
    12GB
    Graphics Card(s)
    AMD Radeon™ HD 7310 Graphics
    Sound Card
    Realtek HD
    Monitor(s) Displays
    LCD
    Screen Resolution
    1366 x 768
    Hard Drives
    Crucial M500 240GB SSD
    Mouse
    Logitech M525
    Internet Speed
    45/6 - ATT U-Verse
    Browser
    Google Chrome
    Antivirus
    None needed. It is Linux.
    Other Info
    Arris NVG589 Gateway; Router - Cisco RV320; Switch - Netgear GS108 8-Port Switch & Trendnet TEG-S50g 5-Port Switch; Access Points - Engenius ECB350, Trendnet TEW-638APB; NAS - Lenovo ix2-4; Printer - Brother HL-2280DW; Air Print Server - Lantronix XPrintServer

    A/V UPS - Tripp-Lite Smart 1500LCD 1500 Va/900 W.
#5
Hi,

I have two Windows 8.1 pcs on a home network. I also have Linux Mint 13 on a laptop. I have installed samba and have attempted to share folders from the Windows 8.1 machines to the laptop. All machines have the same workgroup name and are on the same subnet.

I am not very literate concerning networking, so please keep responses simple.

I can see all the windows machines from my LM laptop when I click 'Network folder' from the linux equivalent of Windows Explorer (nemo).

When I click on a specific windows machines from nemo, a dialog box opens asking for Username, Domain and Password. Now I'm not sure which username and password this is asking for.

Using my username on Linux Mint (tim) in the Username box, the workgroup name in the Domain box, and the Windows 8.1 password in the Password box, I'm able to access shared folders on one Windows 8.1 machine.

However, I cannot gain access to the other machine. My password gets rejected every time. Both Windows 8.1 machines are logged in with the same Microsoft account, so the password on both machines is the same.

Both Windows 8.1 machines have sharing enabled and are members of the same windows homegroup. Both Windows machines have no problem accessing shared folders on each other, and can access the shared folders on the LM laptop.

The only problem is I cannot gain access to one of the Windows 8.1 machines from the Laptop.

Both Windows 8.1 machines have Bitdefender Internet Security, both configured the same. I have tried turning off the firewall completely on both the laptop and the unfriendly windows 8.1 machine, but still I cannot connect.

Could someone please confirm if I am using the password dialog box correctly. Is the username supposed to be the LM username, and the password supposed to be the windows password.

Since this worked for me on one of the machines, I would expect it to have worked for both.

I am asking for help on a Linux Mint forum as well as here.

Perhaps there is some special permissions I need to set on W8.1.

Thanks,
Tim
New Zealand
Having a Homegroup set up isn't really going to help with access when there are other operating systems involved.

I'm surprised you can access one of those Homegroup machines without adding permissions to the Library folders which is usually required in order to add access to a Homegroup machine from a Workgroup machine. The Workgroup name should make no difference in my opinion as long as they are using the same name.

If you are interested in learning which settings will allow access to the Library's on the Windows 8 machine let me know.
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

KiwiTim

New Member
Posts
7
#6
Well, it's all working now. I had named the W8.1 PC PETE, but the username was actually Peter. I had been trying to log in with username = pete, which of course, did not work.

I used username = peter, workgroup = TURK , password = windowspassword

This worked perfectly. I can now access all shared folders. My silly mistake by confusing the PC name with the username!

Thanks Chev65 and Bro23 for your advice.

Tim
 

My Computer

System One

  • OS
    Windows 8 Pro 32bit
    System Manufacturer/Model Number
    HP Pavilion DV8000 CT
    CPU
    Turion ML-40 2.2 Ghz Single Core
    Motherboard
    HP
    Memory
    2GB DDR400
    Graphics Card(s)
    ATI Radeon Xpress 200M