Network Location - Set to Private or Public in Windows 8

How to Set Network Location to be Public or Private in Windows 8 and 8.1
The first time you connect to a network, you'll be asked if you want to turn on sharing between PCs and connect to network devices such as printers. Your answer automatically sets the appropriate Windows Firewall and security settings for the type of network (private or public) that you connected to. You can turn sharing on or off anytime.

This tutorial will show you how to set your network to be connected to a public or private type of location for if you would like to turn sharing and connect to devices on or off in Windows 8, Windows RT, Windows 8.1, and Windows RT 8.1.

You must be signed in as an administrator to be able to do the steps in this tutorial.

Private network - Choose Yes, turn on sharing and connect to devices below for home or small office (work) networks, or when you know and trust the people and devices on the network. This setting allows your PC to connect to devices on the network, such as printers. Computers on a private network can belong to a homegroup.

Public network - Choose No, don't turn on sharing or connect to devices below for networks in public places (such as coffee shops or airports), or when you don't know or trust the people and devices on the network. This location is designed to keep your computer from being visible to other computers around you and to help protect your computer from any malicious software from the Internet. HomeGroup is not available on public networks, and network discovery is turned off.

Unidentified network - See: Unidentified Networks - Set as Private or Public - Windows 7 Forums


  • Turning on sharing prepares your PC for sharing files and devices on a network.
  • The network sharing setting is only available for Wi-Fi, Ethernet, VPN (non-domain), and dial-up (non-domain) connections. It's unavailable for domain networks. On VPN or dial-up connections, you must connect to the network first, then press and hold or right-click the network name to change the network sharing setting.
  • Turning on sharing changes your firewall settings to allow some communication, which can be a security risk. If you know you won't need to share files or printers, the safest choice is No, don't share or connect to devices.
  • Choosing No, don't turn on sharing or connect to devices blocks the following apps and services from working: PlayTo, file sharing, network discovery, and automatic setup of network devices.

EXAMPLE: Private or Public Network in "Network and Sharing Center"
NOTE: The Network and Sharing Center can let you see if your network is public or private. To open the "Network and Sharing Center", you could open the Control Panel (icons view) and click/tap on the Network and Sharing Center icon.

Private.jpg

Public.jpg






OPTION ONE

Set Network to be Private or Public in Windows 8 Networks




1. Do step 2 or 3 below for how you would like to open the Networks flyout.

2. On the desktop, click/tap on the Network system icon in the taskbar notification area, and go to step 4 below. (see screenshot below)


Taskbar-Network_Icon.jpg


3. Open the Charms bar, and click/tap on Settings.
NOTE: You could also press the Windows + I keys to open the Settings flyout.


A) In the Settings flyout, click/tap on the Network icon, and go to step 4 below. (see screenshots below)
NOTE: The Network icon will have the name of your network under it. The example below is for either an ethernet or wireless network.

Settings.jpgWireless-1.jpg


4. In the Networks flyout, right click or press and hold on your network connection (ex: "Network 3" or "Brink-Router"), and click/tap on Turn sharing on or off. (see screenshots below)

Network.jpgWireless-2.jpg



5. Do step 6 or 7 below for what you would like to do. (see screenshots below)

Change.jpg



6. To Set Network Location to be Public in Windows 8

A) Click/tap on No, don't turn on sharing or connect to devices, and go to step 8 below. (see screenshots below step 5)


7. To Set Network Location to be Private in Windows 8

A) Click/tap on Yes, turn on sharing and connect to devices, and go to step 8 below. (see screenshots below step 5)



8. If prompted by UAC, then click/tap on Yes.






OPTION TWO

Set Network to be Private or Public in Windows 8.1 Networks


NOTE: PCs with an ethernet network connection will be set as a private network by default, and doesn't appear to be able to be changed using this option.

1. Open PC settings, and click/tap on Network on the left side. (see screenshot below)

8.1_Networks-1.jpg


2. Click/tap on Connections on the left side of "Network", and click/tap on the network (ex: Brink-Router 2) on the right side that you want to set as public or private. (see screenshot below)

8.1_Networks-2.jpg


3. Under Find devices and content, do step 4 or 5 below for what you would like to do. (see screenshot below)

Note   Note
The Find devices and content option will not be available for PC with an ethernet network connection.

You will need to have your UAC settings set to the default or lower level to have the Find devices and content option available for other types of network connections. The Find devices and content option will not be available if you have your UAC settings set to the top "Always Notify" level. Close and reopen PC settings afterwards if you needed to change your UAC settings.

UAC.jpg





8.1_Networks-3.jpg


4. To Set Network Location to be Public in Windows 8.1

A) Move the slider to the left to turn it off, and go to step 6 below. (see screenshot below step 3)


5. To Set Network Location to be Private in Windows 8.1

A) Move the slider to the right to turn it on, and go to step 6 below. (see screenshot below step 3)


6. When finished, you can close PC settings if you like.






OPTION THREE

Set Network to be Private or Public in Windows 8 and 8.1 in Registry



1. Press the :winkey: + R keys to open the Run dialog, type regedit, and press Enter.

2. If prompted by UAC, then click/tap on Yes.

3. In Registry Editor, navigate to the location below. (see screenshot below)

Code:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles

change-network_location_reg-1.jpg



4. Double click/tap on the Profiles key in the left pane to expand it. Click/tap on each long GUID number subkey, and look at it's ProfileName string value in the right pane to see if it has the current network name (ex: Network) until found. (see screenshots below)

change-network_location_reg-2.jpg

Network_Name.jpg



5. When you find the correct ProfileName for your network name, double click/tap on the Category DWORD value in the same right pane to modify it. (see screenshot below)

change-network_location_reg-3.jpg



6. Type in a new Data value number for the network location you want, and click/tap on OK. (see screenshot below)

Network Location

Data Value

Public

0

Private

1

Domain

2

change-network_location_reg-4.jpg



7. When finished, you can now close Registry Editor if you like.

8. Sometimes you may need to sign out and in of your user account to apply the new network location.






OPTION FOUR

Set Network to be Private or Public in Local Security Policy



NOTE: This option will override the other options above.

1. Open the Local Security Policy (secpol.msc).

2. In the left pane, click/tap on Network List Manager Policies. (see screenshot below)

Network_Location_secpol-1.png



3. In the right pane of Network List Manager Policies, double click/tap on your network name (ex: Network). (see screenshot above)

4. Click/tap on the Network Location tab, and do step 5, 6, or 7 below for what you would like to set. (see screenshot below)

Network_Location_secpol-2.png



5. To Set Network Location to be Public

A) Under Location type, select (dot) Public. (see screenshot below step 4)

B) Under User permissions, select (dot) User cannot change location.

C) Click/tap on OK, and go to step 8 below.



6. To Set Network Location to be Private

A) Under Location type, select (dot) Private. (see screenshot below step 4)

B) Under User permissions, select (dot) User cannot change location.

C) Click/tap on OK, and go to step 8 below.



7. To Allow Network Location to be changed by user
NOTE: This is the default setting, and will allow you to be able to use OPTION ONE, OPTION TWO, or OPTION THREE above.

A) Under Location type, select (dot) Not configured. (see screenshot below step 4)

B) Under User permissions, select (dot) Not configured.

C) Click/tap on OK, and go to step 8 below.



8. When finished, you can close Local Security Policy if you like.



That's it,
Shawn


 

Attachments

  • Network7.png
    Network7.png
    13.8 KB · Views: 466
Last edited by a moderator:
Hi Brink i have a strange issue i was cleaning my computer today and when i came back and plugged it in all the sudden my network was at public unidentified network, i managed to get it back to the private network, by unplugging my cable and plugging it back in, but it has done this other times as well and i can't for the like of me figure out why it is doing this. any help appreciated as its a rather strange issue and i hate having to get behind my router or pc and unplug and re-plug in to fix this at times.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Myself
    CPU
    Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
    Motherboard
    MSI Z77A-G45
    Memory
    8 gigs
    Graphics Card(s)
    PNY GeForce GTX 660 Ti
    Sound Card
    onboard
    Monitor(s) Displays
    Samsung Sync Master s27B550
    Screen Resolution
    1080p
    Hard Drives
    1 TB internal driver and one 1TB external drive.
    PSU
    Antec NeoECO 620 watt
    Case
    custom case
    Cooling
    Fans
    Keyboard
    steelseries apex
    Mouse
    stellseris sensel
    Internet Speed
    Unknowen
    Browser
    Google chrome
    Antivirus
    Norton 360 from comcast
Hey Tony,

It seems to be a glitch when initially detecting the network. As you found out, unplugging it and plugging it back in is normally the easiest way for it to hopefully redetect it properly.
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    64 GB (4x16GB) G.SKILL TridentZ RGB DDR4 3600 MHz (F4-3600C18D-32GTZR)
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 990 PRO M.2,
    4TB Samsung 990 PRO PRO M.2,
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Galaxy S23 Plus phone
Help! Find Devices and content keeps turning itself off!

I have an ongoing problem that is driving me crazy. Just about every time I go to try to access files on one computer from another on my home network, I get an error message saying it's unavailable. I go and check the network settings and sure enough, the Network type is set to Public and the Find Devices and Content switch is turned off. I turn it back on and everything works fine until next time I try to use the network. I have tried setting the value in the registry mentioned in this article, but nothing seems to keep the setting from reverting back to Public. Any suggestions?
 
Last edited by a moderator:

My Computer

System One

  • OS
    Windows 8.1 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home-built
    CPU
    Intel Core i7-2600K
    Memory
    12GB
    Graphics Card(s)
    Nvidia GeForce GTX 660
Hello Kpix,

Is this for a wireless or ethernet network?

Are you able to set it using OPTION FOUR instead?
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    64 GB (4x16GB) G.SKILL TridentZ RGB DDR4 3600 MHz (F4-3600C18D-32GTZR)
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 990 PRO M.2,
    4TB Samsung 990 PRO PRO M.2,
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Galaxy S23 Plus phone
I'm pretty sure I've tried option 4 before but I'll give it another try. This happens for both wireless and wired ethernet connections.

Thanks
 

My Computer

System One

  • OS
    Windows 8.1 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home-built
    CPU
    Intel Core i7-2600K
    Memory
    12GB
    Graphics Card(s)
    Nvidia GeForce GTX 660

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    64 GB (4x16GB) G.SKILL TridentZ RGB DDR4 3600 MHz (F4-3600C18D-32GTZR)
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 990 PRO M.2,
    4TB Samsung 990 PRO PRO M.2,
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Galaxy S23 Plus phone
If you don't have the "Find content and devices" slider, you can get it back by removing the following registry key: HKCU\Software\Microsoft\Windows NT\CurrentVersion\Network\NwCategoryWizard

I had this issue for months, searched throughout the whole internet unable to find a solution. Today, at my umpteenth attempt to find a solution, I found this page: https://technet.microsoft.com/en-us/library/gg252535(v=ws.10).aspx. It actually is a solution on how to remove network location dialog when connecting to a network, but you can use it in reverse to solve this problem. I specifically registered to post this solution because I know a lot of people have this problem, and so far, I didn't find any straightforward solutions. Now I finally have one!
 

My Computer

System One

  • OS
    Windows 8.1
Hi,
I'm having a kind of strange problem here. I'm trying to connect to a Homgroup but windows keep saying it's only possible in a private network. Well, I'm in a private network, as Win itself recognizes my network as private. I can't imagine what's going on...

as you may see in this screenshot:
Untitled.jpg

Any ideas?
 

My Computer

System One

  • OS
    Windows 8.1

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    64 GB (4x16GB) G.SKILL TridentZ RGB DDR4 3600 MHz (F4-3600C18D-32GTZR)
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 990 PRO M.2,
    4TB Samsung 990 PRO PRO M.2,
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Galaxy S23 Plus phone
Thanks for the quik awnser. Unfortunately this didn't work. I still get the same message. There is something conflicting internal information on Windows, as I supose. Homegroup is not "seeing" the private status of my network.

Again a screenshot:

Untitled2.jpg
 

My Computer

System One

  • OS
    Windows 8.1
You might see if toggling your network to public, apply, and to private may reset it to work properly.

It would hurt to do the same on the other PCs as well.
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    64 GB (4x16GB) G.SKILL TridentZ RGB DDR4 3600 MHz (F4-3600C18D-32GTZR)
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 990 PRO M.2,
    4TB Samsung 990 PRO PRO M.2,
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Galaxy S23 Plus phone
I had already tried it, but now I made it simultaneously on all computers. First made all to public, restarted all computers, changed to private, restarted again (all) ans finally started the homegroup from the "problem maker". Now it's working. Thanks for the hints!
 

My Computer

System One

  • OS
    Windows 8.1
Great news. It was most likely one of the other PCs causing it. :party:
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    64 GB (4x16GB) G.SKILL TridentZ RGB DDR4 3600 MHz (F4-3600C18D-32GTZR)
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 990 PRO M.2,
    4TB Samsung 990 PRO PRO M.2,
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Galaxy S23 Plus phone
late to the party on this topic so excuse the late and hopefully not dumb question here, I'm totally lost on this subject, my laptop runs Windows 8.1 my network setting is set to PUBLIC is this bad? this laptop is only used at home.
 

My Computer

System One

  • OS
    windows 8.1
Back
Top