• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Need to force full shutdown of Windows 8 instead of hibern


patagriff

Member
Member
Tacoma, WA

Posts
33
#1
I have a dual boot Windows 8/Ubuntu 12.10 system. Windows 8 is on a seperate partition, but occassionally when I'm running Ubuntu, I need to mount this partition to get a file. But Windows 8 hibernates the partition on shutdown, so I am unable to mount it.

I need to know how to make this hibernation stop, and force a full shutdown when I exit Windows, so this hibernation file is not associated with this partition.
 

My Computer

System One

  • OS
    Windows 8 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Acer Aspire 5515
    CPU
    AMD 2650e
    Memory
    3 Gig
    Graphics Card(s)
    ATI Radeon Xpress 1200
    Screen Resolution
    1280X800
    Hard Drives
    160 gig
    Mouse
    logiitech wireless
    Internet Speed
    1.5 mb
    Browser
    Chrome (latest BETA)
    Antivirus
    Avaste Free Antivirus

MrShowdown

Well-Known Member
Power User
Jakarta, Indonesia

Posts
1,048
#2

My Computer

System One

  • OS
    Windows 10 Pro x64
    Computer type
    Laptop
    System Manufacturer/Model
    Lenovo Y520
    CPU
    Intel Core i5 7300HQ
    Motherboard
    OEM Lenovo
    Memory
    4GB DDR4-2400
    Graphics Card(s)
    NVIDIA GeForce GTX 1050
    Sound Card
    Realtek HD
    Monitor(s) Displays
    1 (2)
    Screen Resolution
    1920x1080
    Hard Drives
    Seagate 1TB 5400 RPM
    Keyboard
    OEM Lenovo
    Mouse
    Logitech G502 Proteus Core
    Internet Speed
    100 Mbps
    Browser
    Google Chrome
    Other Info
    PC:

    AMD Athlon X4 760K
    8GB DDR3-1866
    AMD Radeon RX 460
    Seagate 500 GB 7200 RPM

patagriff

Member
Member
Tacoma, WA

Posts
33
#3
I truly appreciate your prompt and knowledgeable attention to my problem.:thumbsup:
 

My Computer

System One

  • OS
    Windows 8 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Acer Aspire 5515
    CPU
    AMD 2650e
    Memory
    3 Gig
    Graphics Card(s)
    ATI Radeon Xpress 1200
    Screen Resolution
    1280X800
    Hard Drives
    160 gig
    Mouse
    logiitech wireless
    Internet Speed
    1.5 mb
    Browser
    Chrome (latest BETA)
    Antivirus
    Avaste Free Antivirus

MrShowdown

Well-Known Member
Power User
Jakarta, Indonesia

Posts
1,048
#4
You are welcome!
 

My Computer

System One

  • OS
    Windows 10 Pro x64
    Computer type
    Laptop
    System Manufacturer/Model
    Lenovo Y520
    CPU
    Intel Core i5 7300HQ
    Motherboard
    OEM Lenovo
    Memory
    4GB DDR4-2400
    Graphics Card(s)
    NVIDIA GeForce GTX 1050
    Sound Card
    Realtek HD
    Monitor(s) Displays
    1 (2)
    Screen Resolution
    1920x1080
    Hard Drives
    Seagate 1TB 5400 RPM
    Keyboard
    OEM Lenovo
    Mouse
    Logitech G502 Proteus Core
    Internet Speed
    100 Mbps
    Browser
    Google Chrome
    Other Info
    PC:

    AMD Athlon X4 760K
    8GB DDR3-1866
    AMD Radeon RX 460
    Seagate 500 GB 7200 RPM

patagriff

Member
Member
Tacoma, WA

Posts
33
#5
Fellas. I have a shared data partition for files I need to access from Windows 8 and Ubuntu 12.10 in a dual-boot arrangement. The way Windows 8 is setup on initial installation, signing out and selecting shutdown does not actually power down the computer...it hibernates it. So, when I turn the computer back on and boot Ubuntu, I am unable to mount the shared partition because it has a hibernate file in the boot file that tells Ubuntu the partition is still mounted. I can remove this file in terminal in Ubuntu, then mount, but it is ridiculous to go through this each time I boot Linux. I followed these procedures with success when I initially set up the shared partition: I went into control panel with administrator priveleges, selected power. I then selected change what the power button does. Changed from hibernate to shutdown in the need ed areas. Then I clicked on chenge the available settings, scrolled down and turned off the enable fast boot option which tells Windows 8 to hibernate instead of shutting down completely.

This proceedure worker perfectly for a week or so, but then for some reason, it reverted to a state in which Ubuntu cannot mount the shared partition because it's still mounted by Windows. I rechecked the afore outlined steps and the settings are as they should be. Either a Windows update has changes something or there is something I'm missing. I cannot even remove the hibernate flag from the boot loader in Unbuntu terminal as I could before.

I understand that if I add the full switch to the shutdown.exe command (shutdown /s /full /t 0) I can force windows to power down completely every time I shut it down. But I don't know how to edit this command. Can someone please teach me how to add this switch to the shutdown.exe command?
 

My Computer

System One

  • OS
    Windows 8 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Acer Aspire 5515
    CPU
    AMD 2650e
    Memory
    3 Gig
    Graphics Card(s)
    ATI Radeon Xpress 1200
    Screen Resolution
    1280X800
    Hard Drives
    160 gig
    Mouse
    logiitech wireless
    Internet Speed
    1.5 mb
    Browser
    Chrome (latest BETA)
    Antivirus
    Avaste Free Antivirus

MrShowdown

Well-Known Member
Power User
Jakarta, Indonesia

Posts
1,048
#6
Fellas. I have a shared data partition for files I need to access from Windows 8 and Ubuntu 12.10 in a dual-boot arrangement. The way Windows 8 is setup on initial installation, signing out and selecting shutdown does not actually power down the computer...it hibernates it. So, when I turn the computer back on and boot Ubuntu, I am unable to mount the shared partition because it has a hibernate file in the boot file that tells Ubuntu the partition is still mounted. I can remove this file in terminal in Ubuntu, then mount, but it is ridiculous to go through this each time I boot Linux. I followed these procedures with success when I initially set up the shared partition: I went into control panel with administrator priveleges, selected power. I then selected change what the power button does. Changed from hibernate to shutdown in the need ed areas. Then I clicked on chenge the available settings, scrolled down and turned off the enable fast boot option which tells Windows 8 to hibernate instead of shutting down completely.

This proceedure worker perfectly for a week or so, but then for some reason, it reverted to a state in which Ubuntu cannot mount the shared partition because it's still mounted by Windows. I rechecked the afore outlined steps and the settings are as they should be. Either a Windows update has changes something or there is something I'm missing. I cannot even remove the hibernate flag from the boot loader in Unbuntu terminal as I could before.

I understand that if I add the full switch to the shutdown.exe command (shutdown /s /full /t 0) I can force windows to power down completely every time I shut it down. But I don't know how to edit this command. Can someone please teach me how to add this switch to the shutdown.exe command?
No, you don't need to add a /full switch.
Actually, Default Shutdown (Hybrid) uses shutdown.exe /s /hybrid to initiate a hybrid shutdown. The Charms Bar button to shutdown will run it using /hybrid switch.

If you need to use Full Shutdown, you can use the old-fashioned shutdown.exe /s.
 

My Computer

System One

  • OS
    Windows 10 Pro x64
    Computer type
    Laptop
    System Manufacturer/Model
    Lenovo Y520
    CPU
    Intel Core i5 7300HQ
    Motherboard
    OEM Lenovo
    Memory
    4GB DDR4-2400
    Graphics Card(s)
    NVIDIA GeForce GTX 1050
    Sound Card
    Realtek HD
    Monitor(s) Displays
    1 (2)
    Screen Resolution
    1920x1080
    Hard Drives
    Seagate 1TB 5400 RPM
    Keyboard
    OEM Lenovo
    Mouse
    Logitech G502 Proteus Core
    Internet Speed
    100 Mbps
    Browser
    Google Chrome
    Other Info
    PC:

    AMD Athlon X4 760K
    8GB DDR3-1866
    AMD Radeon RX 460
    Seagate 500 GB 7200 RPM

Users Who Are Viewing This Thread (Users: 0, Guests: 1)