My printer Drivers wont install: MP Drivers?? please help

InferneX

New Member
Joined
Nov 29, 2012
Messages
1
Hey guys Its InferneX, I've recently changed one of my PC to Windows 8 and I'm already having a huge issue installing a printer I bought a new printer

Cannon Pixma MG3100 though whenever I try to install the drivers and all the other program from the disk I get this problem that shows?

rubbish.png

Now I've already restarted the PC and I still get the same problem.
I tried installing it without the printer on the PC, now also there's another thing I don't get, which is when i plug in the printer to the USB the computer does recognizes it.
Now please could someone help me solve this issue please thank you for your time.
 

My Computer

System One

  • OS
    Windows 8

averchat

New Member
Member
Joined
Nov 8, 2012
Messages
141
1 Unplug printer from USB port,
2 Uninstall all printer software
3 reboot PC
4 Reinstall printer software
5 Then plug in printer
 

My Computer

System One

  • OS
    Win 7 & Win 8
    Name
    Paul R Duncan
    System Manufacturer/Model
    Gigabyte Technology Co., Ltd.
    CPU
    AMD Athlon II X2 245
    Motherboard
    Gigabyte GA-MA785GM-US2H
    Memory
    4096 MB DDR2-SDRAM
    Graphics Card(s)
    On bord
    Country Flag
    Australia
    State/Region Flag
    au new south wales

Titch

New Member
Joined
Aug 24, 2013
Messages
1
I had the same problem and I switched off my wifi. This allowed me to reinstall the driver, then just switch your wifi back on.
 

My Computer

System One

  • OS
    windows 8

Garp242

New Member
Joined
Jan 20, 2018
Messages
1
I had serious problems trying to run set-up CD for New Pixma MP4250 on Windows 10. It could not load MP Drivers, so was unable to complete the set-up. Three days later, having contacted Canon, Microsoft (2 hours with a Remote Tech, who tried everything she knew) and pulling out most of my hair, I was ready to return the printer to the shop. Then I saw Titch's post and since I'd tried everything else, I thought "why not" ... I turned off WiFi, unplugged USB connection and inserted the Set-up CD ... Hey Presto !! The complete installation done in about 6 minutes .... Big WELL DONE to Titch !!
 

My Computer

System One

  • OS
    Windows 10

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top