• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved My Computer Can't detect my new graphics card


#1
I purchased a new GPU Sapphire Dual X R9 270X 2GB DDR5 OC WITH BOOST
My Graphics Card fan work fine but when I turn on my pc the monitor does not show anything.

I had another graphics card before but needed to replace it so I dont know if this is the trouble.

Anyone can help?

Thanks in advance:sarc:
 

My Computer

System One

  • OS
    Windows 8.1 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom Build
    CPU
    Intel Core i7-4770S 3.10 GHz SKT1150 8MB
    Motherboard
    ASRock Z87M Extreme 4 Micro ATX LGA1150
    Memory
    Corsair CMZ16GX3M2A1600C9 Vengeance 16GB (2x8GB) DDR3 1600 Mhz CL9
    Graphics Card(s)
    SAPPHIRE DUAL-X R9 270X 2GB GDDR5 OC WITH BOOST
    Sound Card
    Realtek High Definiton Audio
    Monitor(s) Displays
    LG 22M35A
    Screen Resolution
    1920 x 1080
    Hard Drives
    Kingston Technology 240GB SSDNOW V300 S
    Toshiba DT01ACA100 Hard Drive 1TB 3.5
    PSU
    Xilence Gaming Series 600W
    Case
    Thermaltake Commander G42 Window
    Keyboard
    Genesis Gaming
    Mouse
    Microsoft Windows 8 Mouse
    Internet Speed
    6 Mbps
    Browser
    Google Chrome
    Antivirus
    Eset Smart Security 7

CountMike

Well-Known Member
VIP Member
Guru
Belgrade , Serbia

Posts
4,664
#2
Do you have required power connections to it ?
Tried another PCIx slot ?
Monitor connected to the right place ?
Can't be problem because of another GPU for BOOT at least, in the OS later on maybe, if it's different than old one.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home made
    CPU
    AMD FX 6350Be @4.8GHz
    Motherboard
    Gigabyte GA-990XA-UD3
    Memory
    8GB Kingston 1866
    Graphics Card(s)
    MSI AMD R7 260 oc
    Hard Drives
    Silicon Power V70 240GB SSD
    Kingston V300 120GB SSD
    WD 750GB Green
    WD 500GB black
    Bunch of backup HDDs.
    PSU
    Sharkoon, Silent Storm 660W
    Case
    CM Dragon Tower
    Cooling
    CCM Nepton 140xl
    Internet Speed
    10/2 Mbps
    Browser
    Firefox
    Antivirus
    WD
#3
Do you have required power connections to it ?
Tried another PCIx slot ?
Monitor connected to the right place ?
Can't be problem because of another GPU for BOOT at least, in the OS later on maybe, if it's different than old one.
Yes I have the required power connections to it. I also tried another PCI slot. Also monitor to the right place. I am thinking that maybe the GPU is DOA because i ordered it through amazon.co.uk. I also know that this is not a problem with my motherboard as my old GPU works fine...
 

My Computer

System One

  • OS
    Windows 8.1 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom Build
    CPU
    Intel Core i7-4770S 3.10 GHz SKT1150 8MB
    Motherboard
    ASRock Z87M Extreme 4 Micro ATX LGA1150
    Memory
    Corsair CMZ16GX3M2A1600C9 Vengeance 16GB (2x8GB) DDR3 1600 Mhz CL9
    Graphics Card(s)
    SAPPHIRE DUAL-X R9 270X 2GB GDDR5 OC WITH BOOST
    Sound Card
    Realtek High Definiton Audio
    Monitor(s) Displays
    LG 22M35A
    Screen Resolution
    1920 x 1080
    Hard Drives
    Kingston Technology 240GB SSDNOW V300 S
    Toshiba DT01ACA100 Hard Drive 1TB 3.5
    PSU
    Xilence Gaming Series 600W
    Case
    Thermaltake Commander G42 Window
    Keyboard
    Genesis Gaming
    Mouse
    Microsoft Windows 8 Mouse
    Internet Speed
    6 Mbps
    Browser
    Google Chrome
    Antivirus
    Eset Smart Security 7

CountMike

Well-Known Member
VIP Member
Guru
Belgrade , Serbia

Posts
4,664
#4
Do you have required power connections to it ?
Tried another PCIx slot ?
Monitor connected to the right place ?
Can't be problem because of another GPU for BOOT at least, in the OS later on maybe, if it's different than old one.
Yes I have the required power connections to it. I also tried another PCI slot. Also monitor to the right place. I am thinking that maybe the GPU is DOA because i ordered it through amazon.co.uk. I also know that this is not a problem with my motherboard as my old GPU works fine...
Than it's DOA probably, any chance to try it on another PC ?
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home made
    CPU
    AMD FX 6350Be @4.8GHz
    Motherboard
    Gigabyte GA-990XA-UD3
    Memory
    8GB Kingston 1866
    Graphics Card(s)
    MSI AMD R7 260 oc
    Hard Drives
    Silicon Power V70 240GB SSD
    Kingston V300 120GB SSD
    WD 750GB Green
    WD 500GB black
    Bunch of backup HDDs.
    PSU
    Sharkoon, Silent Storm 660W
    Case
    CM Dragon Tower
    Cooling
    CCM Nepton 140xl
    Internet Speed
    10/2 Mbps
    Browser
    Firefox
    Antivirus
    WD
#5
No I dont have another desktop pc. I decided to return it to amazon and ask for a refund. Maybe I will purchace another GPU. I have to admit that I am kind of dissapontoided...
 

My Computer

System One

  • OS
    Windows 8.1 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom Build
    CPU
    Intel Core i7-4770S 3.10 GHz SKT1150 8MB
    Motherboard
    ASRock Z87M Extreme 4 Micro ATX LGA1150
    Memory
    Corsair CMZ16GX3M2A1600C9 Vengeance 16GB (2x8GB) DDR3 1600 Mhz CL9
    Graphics Card(s)
    SAPPHIRE DUAL-X R9 270X 2GB GDDR5 OC WITH BOOST
    Sound Card
    Realtek High Definiton Audio
    Monitor(s) Displays
    LG 22M35A
    Screen Resolution
    1920 x 1080
    Hard Drives
    Kingston Technology 240GB SSDNOW V300 S
    Toshiba DT01ACA100 Hard Drive 1TB 3.5
    PSU
    Xilence Gaming Series 600W
    Case
    Thermaltake Commander G42 Window
    Keyboard
    Genesis Gaming
    Mouse
    Microsoft Windows 8 Mouse
    Internet Speed
    6 Mbps
    Browser
    Google Chrome
    Antivirus
    Eset Smart Security 7

CountMike

Well-Known Member
VIP Member
Guru
Belgrade , Serbia

Posts
4,664
#6
No I dont have another desktop pc. I decided to return it to amazon and ask for a refund. Maybe I will purchace another GPU. I have to admit that I am kind of dissapontoided...
I believe you, it's a nice card. Bummer.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home made
    CPU
    AMD FX 6350Be @4.8GHz
    Motherboard
    Gigabyte GA-990XA-UD3
    Memory
    8GB Kingston 1866
    Graphics Card(s)
    MSI AMD R7 260 oc
    Hard Drives
    Silicon Power V70 240GB SSD
    Kingston V300 120GB SSD
    WD 750GB Green
    WD 500GB black
    Bunch of backup HDDs.
    PSU
    Sharkoon, Silent Storm 660W
    Case
    CM Dragon Tower
    Cooling
    CCM Nepton 140xl
    Internet Speed
    10/2 Mbps
    Browser
    Firefox
    Antivirus
    WD
#7
I alrealy packed it for return, informed amazon and i will post it tomorrow. Hope that they can refund me so i can purchase a new one.
 

My Computer

System One

  • OS
    Windows 8.1 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom Build
    CPU
    Intel Core i7-4770S 3.10 GHz SKT1150 8MB
    Motherboard
    ASRock Z87M Extreme 4 Micro ATX LGA1150
    Memory
    Corsair CMZ16GX3M2A1600C9 Vengeance 16GB (2x8GB) DDR3 1600 Mhz CL9
    Graphics Card(s)
    SAPPHIRE DUAL-X R9 270X 2GB GDDR5 OC WITH BOOST
    Sound Card
    Realtek High Definiton Audio
    Monitor(s) Displays
    LG 22M35A
    Screen Resolution
    1920 x 1080
    Hard Drives
    Kingston Technology 240GB SSDNOW V300 S
    Toshiba DT01ACA100 Hard Drive 1TB 3.5
    PSU
    Xilence Gaming Series 600W
    Case
    Thermaltake Commander G42 Window
    Keyboard
    Genesis Gaming
    Mouse
    Microsoft Windows 8 Mouse
    Internet Speed
    6 Mbps
    Browser
    Google Chrome
    Antivirus
    Eset Smart Security 7

brkkab123

New Member
Member
Melbourne,FL.

Posts
187
#8
Did you do a reset (optimized defaults, etc..) in the bios/uefi after putting in the new video card ? That's important, if the bios/uefi aren't set to detect the right video card, Windows won't either. Did you uninstall the old video card's driver's ? That's really important, especially if you went from nVidia based gpu to a AMD gpu. Did you install the current driver's for the new video card ? Not the driver's that are on the cd that came with it (they're alway's old driver's) ???
 

My Computer

System One

  • OS
    Windows 8.1 Pro w/Media Center x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    self built
    CPU
    AMD FX 8350
    Motherboard
    Asus Sabertooth 990fx r2.0
    Memory
    G-Skill Ripjaws-X DDR3 2400 16 gbs.
    Graphics Card(s)
    MSI N760 TF 2GD5OC
    Sound Card
    on-bord Realtek ALC 889/ALC 892
    Monitor(s) Displays
    ViewSonic VX2250wm-LED
    Screen Resolution
    1920 x 1080
    Hard Drives
    Samsung 840 Pro 256 gb. ssd. & Seagate Barracuda 7200.14 3.o tb.
    PSU
    Corsair HX-850 watt
    Case
    Corsair Carbide 500r White
    Cooling
    Corsair Hydro Series H-100, 3 120mm. & 1 200mm. case fan's
    Keyboard
    Logitech wired
    Mouse
    Logitech wired
    Internet Speed
    30 m.b.p.s.
    Browser
    IE 11 & Firefox 26
    Antivirus
    BitDefender Internet Security 2014
    Other Info
    Iomega Pro Series U.S.B. 2.0/eS.A.T.A. 2.0tb. h.d., Seagate Backup Plus U.S.B. 3.0 3.0tb. h.d., Hauppage WinTV HVR-1850 t.v. tuner, Logitech x530 5.1 speaker's, Logitech c615 webcam, Logitech h150 headset, M.S. Xbox 360 wired gamepad & Xbox 360 as W.M.C. extender

CountMike

Well-Known Member
VIP Member
Guru
Belgrade , Serbia

Posts
4,664
#9
Did you do a reset (optimized defaults, etc..) in the bios/uefi after putting in the new video card ? That's important, if the bios/uefi aren't set to detect the right video card, Windows won't either. Did you uninstall the old video card's driver's ? That's really important, especially if you went from nVidia based gpu to a AMD gpu. Did you install the current driver's for the new video card ? Not the driver's that are on the cd that came with it (they're alway's old driver's) ???
He's not getting anything on boot, nothing, black screen, can't do anything you suggest.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home made
    CPU
    AMD FX 6350Be @4.8GHz
    Motherboard
    Gigabyte GA-990XA-UD3
    Memory
    8GB Kingston 1866
    Graphics Card(s)
    MSI AMD R7 260 oc
    Hard Drives
    Silicon Power V70 240GB SSD
    Kingston V300 120GB SSD
    WD 750GB Green
    WD 500GB black
    Bunch of backup HDDs.
    PSU
    Sharkoon, Silent Storm 660W
    Case
    CM Dragon Tower
    Cooling
    CCM Nepton 140xl
    Internet Speed
    10/2 Mbps
    Browser
    Firefox
    Antivirus
    WD
#10
Did you do a reset (optimized defaults, etc..) in the bios/uefi after putting in the new video card ? That's important, if the bios/uefi aren't set to detect the right video card, Windows won't either. Did you uninstall the old video card's driver's ? That's really important, especially if you went from nVidia based gpu to a AMD gpu. Did you install the current driver's for the new video card ? Not the driver's that are on the cd that came with it (they're alway's old driver's) ???
Yes I ve done all that... but still nothing... the card wont sent any signal to the monitor...
 

My Computer

System One

  • OS
    Windows 8.1 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom Build
    CPU
    Intel Core i7-4770S 3.10 GHz SKT1150 8MB
    Motherboard
    ASRock Z87M Extreme 4 Micro ATX LGA1150
    Memory
    Corsair CMZ16GX3M2A1600C9 Vengeance 16GB (2x8GB) DDR3 1600 Mhz CL9
    Graphics Card(s)
    SAPPHIRE DUAL-X R9 270X 2GB GDDR5 OC WITH BOOST
    Sound Card
    Realtek High Definiton Audio
    Monitor(s) Displays
    LG 22M35A
    Screen Resolution
    1920 x 1080
    Hard Drives
    Kingston Technology 240GB SSDNOW V300 S
    Toshiba DT01ACA100 Hard Drive 1TB 3.5
    PSU
    Xilence Gaming Series 600W
    Case
    Thermaltake Commander G42 Window
    Keyboard
    Genesis Gaming
    Mouse
    Microsoft Windows 8 Mouse
    Internet Speed
    6 Mbps
    Browser
    Google Chrome
    Antivirus
    Eset Smart Security 7

brkkab123

New Member
Member
Melbourne,FL.

Posts
187
#11
Try a different cable from your monitor to the video card. The cable may have stopped working.
 

My Computer

System One

  • OS
    Windows 8.1 Pro w/Media Center x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    self built
    CPU
    AMD FX 8350
    Motherboard
    Asus Sabertooth 990fx r2.0
    Memory
    G-Skill Ripjaws-X DDR3 2400 16 gbs.
    Graphics Card(s)
    MSI N760 TF 2GD5OC
    Sound Card
    on-bord Realtek ALC 889/ALC 892
    Monitor(s) Displays
    ViewSonic VX2250wm-LED
    Screen Resolution
    1920 x 1080
    Hard Drives
    Samsung 840 Pro 256 gb. ssd. & Seagate Barracuda 7200.14 3.o tb.
    PSU
    Corsair HX-850 watt
    Case
    Corsair Carbide 500r White
    Cooling
    Corsair Hydro Series H-100, 3 120mm. & 1 200mm. case fan's
    Keyboard
    Logitech wired
    Mouse
    Logitech wired
    Internet Speed
    30 m.b.p.s.
    Browser
    IE 11 & Firefox 26
    Antivirus
    BitDefender Internet Security 2014
    Other Info
    Iomega Pro Series U.S.B. 2.0/eS.A.T.A. 2.0tb. h.d., Seagate Backup Plus U.S.B. 3.0 3.0tb. h.d., Hauppage WinTV HVR-1850 t.v. tuner, Logitech x530 5.1 speaker's, Logitech c615 webcam, Logitech h150 headset, M.S. Xbox 360 wired gamepad & Xbox 360 as W.M.C. extender
#12
Try a different cable from your monitor to the video card. The cable may have stopped working.
It's working fine with my old GPU...
 

My Computer

System One

  • OS
    Windows 8.1 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom Build
    CPU
    Intel Core i7-4770S 3.10 GHz SKT1150 8MB
    Motherboard
    ASRock Z87M Extreme 4 Micro ATX LGA1150
    Memory
    Corsair CMZ16GX3M2A1600C9 Vengeance 16GB (2x8GB) DDR3 1600 Mhz CL9
    Graphics Card(s)
    SAPPHIRE DUAL-X R9 270X 2GB GDDR5 OC WITH BOOST
    Sound Card
    Realtek High Definiton Audio
    Monitor(s) Displays
    LG 22M35A
    Screen Resolution
    1920 x 1080
    Hard Drives
    Kingston Technology 240GB SSDNOW V300 S
    Toshiba DT01ACA100 Hard Drive 1TB 3.5
    PSU
    Xilence Gaming Series 600W
    Case
    Thermaltake Commander G42 Window
    Keyboard
    Genesis Gaming
    Mouse
    Microsoft Windows 8 Mouse
    Internet Speed
    6 Mbps
    Browser
    Google Chrome
    Antivirus
    Eset Smart Security 7
#13
Guys can I ask you a question since I already have this thread.

What is your opinion about eVGA GeForce GTX 650 Superclocked 2GB DDR5? Is it a good GPU... I know that it's not the best but overall in contrast with its value... Thanks!
 

My Computer

System One

  • OS
    Windows 8.1 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom Build
    CPU
    Intel Core i7-4770S 3.10 GHz SKT1150 8MB
    Motherboard
    ASRock Z87M Extreme 4 Micro ATX LGA1150
    Memory
    Corsair CMZ16GX3M2A1600C9 Vengeance 16GB (2x8GB) DDR3 1600 Mhz CL9
    Graphics Card(s)
    SAPPHIRE DUAL-X R9 270X 2GB GDDR5 OC WITH BOOST
    Sound Card
    Realtek High Definiton Audio
    Monitor(s) Displays
    LG 22M35A
    Screen Resolution
    1920 x 1080
    Hard Drives
    Kingston Technology 240GB SSDNOW V300 S
    Toshiba DT01ACA100 Hard Drive 1TB 3.5
    PSU
    Xilence Gaming Series 600W
    Case
    Thermaltake Commander G42 Window
    Keyboard
    Genesis Gaming
    Mouse
    Microsoft Windows 8 Mouse
    Internet Speed
    6 Mbps
    Browser
    Google Chrome
    Antivirus
    Eset Smart Security 7

CountMike

Well-Known Member
VIP Member
Guru
Belgrade , Serbia

Posts
4,664
#14
Guys can I ask you a question since I already have this thread.

What is your opinion about eVGA GeForce GTX 650 Superclocked 2GB DDR5? Is it a good GPU... I know that it's not the best but overall in contrast with its value... Thanks!
Don't fall for those expletives like "Superclocked" "Gamer" "Top" etc. A nice paint job and some factory OC with OV to boot and it's just another GPU and with a bit of settings, any old one, specially Ti version can do same thing, one or two frames in a game you can't feel. There's nothing special about those "super brands" except price. A bit of fiddling with it's bios can do same thing. If you have one of those or can get one for decent price, fine but paying a lot of extra money for it is not worth it.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home made
    CPU
    AMD FX 6350Be @4.8GHz
    Motherboard
    Gigabyte GA-990XA-UD3
    Memory
    8GB Kingston 1866
    Graphics Card(s)
    MSI AMD R7 260 oc
    Hard Drives
    Silicon Power V70 240GB SSD
    Kingston V300 120GB SSD
    WD 750GB Green
    WD 500GB black
    Bunch of backup HDDs.
    PSU
    Sharkoon, Silent Storm 660W
    Case
    CM Dragon Tower
    Cooling
    CCM Nepton 140xl
    Internet Speed
    10/2 Mbps
    Browser
    Firefox
    Antivirus
    WD
#15
Guys can I ask you a question since I already have this thread.

What is your opinion about eVGA GeForce GTX 650 Superclocked 2GB DDR5? Is it a good GPU... I know that it's not the best but overall in contrast with its value... Thanks!
Don't fall for those expletives like "Superclocked" "Gamer" "Top" etc. A nice paint job and some factory OC with OV to boot and it's just another GPU and with a bit of settings, any old one, specially Ti version can do same thing, one or two frames in a game you can't feel. There's nothing special about those "super brands" except price. A bit of fiddling with it's bios can do same thing. If you have one of those or can get one for decent price, fine but paying a lot of extra money for it is not worth it.
Ok. But it is the same price without the overclocked.. In general I was wondering if it is a good GPU..
 

My Computer

System One

  • OS
    Windows 8.1 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom Build
    CPU
    Intel Core i7-4770S 3.10 GHz SKT1150 8MB
    Motherboard
    ASRock Z87M Extreme 4 Micro ATX LGA1150
    Memory
    Corsair CMZ16GX3M2A1600C9 Vengeance 16GB (2x8GB) DDR3 1600 Mhz CL9
    Graphics Card(s)
    SAPPHIRE DUAL-X R9 270X 2GB GDDR5 OC WITH BOOST
    Sound Card
    Realtek High Definiton Audio
    Monitor(s) Displays
    LG 22M35A
    Screen Resolution
    1920 x 1080
    Hard Drives
    Kingston Technology 240GB SSDNOW V300 S
    Toshiba DT01ACA100 Hard Drive 1TB 3.5
    PSU
    Xilence Gaming Series 600W
    Case
    Thermaltake Commander G42 Window
    Keyboard
    Genesis Gaming
    Mouse
    Microsoft Windows 8 Mouse
    Internet Speed
    6 Mbps
    Browser
    Google Chrome
    Antivirus
    Eset Smart Security 7

CountMike

Well-Known Member
VIP Member
Guru
Belgrade , Serbia

Posts
4,664
#16
Guys can I ask you a question since I already have this thread.

What is your opinion about eVGA GeForce GTX 650 Superclocked 2GB DDR5? Is it a good GPU... I know that it's not the best but overall in contrast with its value... Thanks!
Don't fall for those expletives like "Superclocked" "Gamer" "Top" etc. A nice paint job and some factory OC with OV to boot and it's just another GPU and with a bit of settings, any old one, specially Ti version can do same thing, one or two frames in a game you can't feel. There's nothing special about those "super brands" except price. A bit of fiddling with it's bios can do same thing. If you have one of those or can get one for decent price, fine but paying a lot of extra money for it is not worth it.
Ok. But it is the same price without the overclocked.. In general I was wondering if it is a good GPU..
Around here, Asus 750 Ti is just less than 10 E more expensive than 650 OC and newer chip too. I'd rather go for that one. It's not a fluke it's one of most popular ones in mid range cards.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home made
    CPU
    AMD FX 6350Be @4.8GHz
    Motherboard
    Gigabyte GA-990XA-UD3
    Memory
    8GB Kingston 1866
    Graphics Card(s)
    MSI AMD R7 260 oc
    Hard Drives
    Silicon Power V70 240GB SSD
    Kingston V300 120GB SSD
    WD 750GB Green
    WD 500GB black
    Bunch of backup HDDs.
    PSU
    Sharkoon, Silent Storm 660W
    Case
    CM Dragon Tower
    Cooling
    CCM Nepton 140xl
    Internet Speed
    10/2 Mbps
    Browser
    Firefox
    Antivirus
    WD
#17
I found the problem. I did not notice that the card had two PCI e connectors and I connected only one. That was the problem. Now the card runs just fine. Amazing GPU... very happy!
 

My Computer

System One

  • OS
    Windows 8.1 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom Build
    CPU
    Intel Core i7-4770S 3.10 GHz SKT1150 8MB
    Motherboard
    ASRock Z87M Extreme 4 Micro ATX LGA1150
    Memory
    Corsair CMZ16GX3M2A1600C9 Vengeance 16GB (2x8GB) DDR3 1600 Mhz CL9
    Graphics Card(s)
    SAPPHIRE DUAL-X R9 270X 2GB GDDR5 OC WITH BOOST
    Sound Card
    Realtek High Definiton Audio
    Monitor(s) Displays
    LG 22M35A
    Screen Resolution
    1920 x 1080
    Hard Drives
    Kingston Technology 240GB SSDNOW V300 S
    Toshiba DT01ACA100 Hard Drive 1TB 3.5
    PSU
    Xilence Gaming Series 600W
    Case
    Thermaltake Commander G42 Window
    Keyboard
    Genesis Gaming
    Mouse
    Microsoft Windows 8 Mouse
    Internet Speed
    6 Mbps
    Browser
    Google Chrome
    Antivirus
    Eset Smart Security 7

CountMike

Well-Known Member
VIP Member
Guru
Belgrade , Serbia

Posts
4,664
#18
I found the problem. I did not notice that the card had two PCI e connectors and I connected only one. That was the problem. Now the card runs just fine. Amazing GPU... very happy!
Hmmmm. I asked you that in my first post, you said it was. That's usually first thing to check. Glad it's sorted out. Be happy.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home made
    CPU
    AMD FX 6350Be @4.8GHz
    Motherboard
    Gigabyte GA-990XA-UD3
    Memory
    8GB Kingston 1866
    Graphics Card(s)
    MSI AMD R7 260 oc
    Hard Drives
    Silicon Power V70 240GB SSD
    Kingston V300 120GB SSD
    WD 750GB Green
    WD 500GB black
    Bunch of backup HDDs.
    PSU
    Sharkoon, Silent Storm 660W
    Case
    CM Dragon Tower
    Cooling
    CCM Nepton 140xl
    Internet Speed
    10/2 Mbps
    Browser
    Firefox
    Antivirus
    WD
#19
Count I connected one because i was confused with my old one. I did not notice in first place tha it had two. Glad it was sorted out too... :)
 

My Computer

System One

  • OS
    Windows 8.1 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom Build
    CPU
    Intel Core i7-4770S 3.10 GHz SKT1150 8MB
    Motherboard
    ASRock Z87M Extreme 4 Micro ATX LGA1150
    Memory
    Corsair CMZ16GX3M2A1600C9 Vengeance 16GB (2x8GB) DDR3 1600 Mhz CL9
    Graphics Card(s)
    SAPPHIRE DUAL-X R9 270X 2GB GDDR5 OC WITH BOOST
    Sound Card
    Realtek High Definiton Audio
    Monitor(s) Displays
    LG 22M35A
    Screen Resolution
    1920 x 1080
    Hard Drives
    Kingston Technology 240GB SSDNOW V300 S
    Toshiba DT01ACA100 Hard Drive 1TB 3.5
    PSU
    Xilence Gaming Series 600W
    Case
    Thermaltake Commander G42 Window
    Keyboard
    Genesis Gaming
    Mouse
    Microsoft Windows 8 Mouse
    Internet Speed
    6 Mbps
    Browser
    Google Chrome
    Antivirus
    Eset Smart Security 7

brkkab123

New Member
Member
Melbourne,FL.

Posts
187
#20
That's good to here. Have fun.
 

My Computer

System One

  • OS
    Windows 8.1 Pro w/Media Center x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    self built
    CPU
    AMD FX 8350
    Motherboard
    Asus Sabertooth 990fx r2.0
    Memory
    G-Skill Ripjaws-X DDR3 2400 16 gbs.
    Graphics Card(s)
    MSI N760 TF 2GD5OC
    Sound Card
    on-bord Realtek ALC 889/ALC 892
    Monitor(s) Displays
    ViewSonic VX2250wm-LED
    Screen Resolution
    1920 x 1080
    Hard Drives
    Samsung 840 Pro 256 gb. ssd. & Seagate Barracuda 7200.14 3.o tb.
    PSU
    Corsair HX-850 watt
    Case
    Corsair Carbide 500r White
    Cooling
    Corsair Hydro Series H-100, 3 120mm. & 1 200mm. case fan's
    Keyboard
    Logitech wired
    Mouse
    Logitech wired
    Internet Speed
    30 m.b.p.s.
    Browser
    IE 11 & Firefox 26
    Antivirus
    BitDefender Internet Security 2014
    Other Info
    Iomega Pro Series U.S.B. 2.0/eS.A.T.A. 2.0tb. h.d., Seagate Backup Plus U.S.B. 3.0 3.0tb. h.d., Hauppage WinTV HVR-1850 t.v. tuner, Logitech x530 5.1 speaker's, Logitech c615 webcam, Logitech h150 headset, M.S. Xbox 360 wired gamepad & Xbox 360 as W.M.C. extender