• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

multi core support in windows 8 preview


ayres48

New Member
Posts
3
#1
Hi all.

I have installed Win 8 preview and really like the OS however I have come across a problem and would be very grateful for any help people can give me. for some reason the OS only seeing one of the 3 core's of my CPU does any one know of a way to get it to see the other core's or of a possible work around for the problem.

thanks in advance
 

My Computer

System One

  • OS
    windows 8 design preview
    System Manufacturer/Model
    cutom
    CPU
    phenom x3 8450
    Motherboard
    ECS GeForce 7050m-m
    Memory
    corsair 2GB
    Graphics Card(s)
    NVIDIA GeForce 8400 GS
    Monitor(s) Displays
    23" 1080p touch screen
    Hard Drives
    500gb Seagate
    1tb store e alu
    500gb solid state drive
    Case
    cooler master elite 340 black
    Cooling
    coolermaster case fans, 3x custom fit fans, master cooler Arctic Cooling Freezer 7 Pro
    Keyboard
    yes
    Mouse
    yes

Dwarf

The Contemplator, (1963-2013)
Moderator
Doncaster, UK

Posts
638
#2
Hi ayres48 and welcome to Windows 8 Forums :party:

Is this what you mean?

Capture.PNG Capture1.PNG

The first image shows a single graph for both CPU cores, whereas the second image shows a separate graph for each core. To switch from single to separate mode, right-click the graph, mouse over Change graph to and click on Logical Processors. To switch from separate to single mode, click on Overall Utilization instead.
 

My Computer

System One

  • OS
    Windows 8.1 Pro RTM x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Dwarf Dwf/11/2012 r09/2013
    CPU
    Intel Core-i5-3570K 4-core @ 3.4GHz (Ivy Bridge) (OC 4.2GHz)
    Motherboard
    ASRock Z77 Extreme4-M
    Memory
    4 x 4GB DDR3-1600 Corsair Vengeance CMZ8GX3M2A1600C9B (16GB)
    Graphics Card(s)
    MSI GeForce GTX770 Gaming OC 2GB
    Sound Card
    Realtek High Definition on board solution (ALC 898)
    Monitor(s) Displays
    ViewSonic VA1912w Widescreen
    Screen Resolution
    1440x900
    Hard Drives
    OCZ Agility 3 120GB SATA III x2 (RAID 0)
    Samsung HD501LJ 500GB SATA II x2
    Hitachi HDS721010CLA332 1TB SATA II
    Iomega 1.5TB Ext USB 2.0
    WD 2.0TB Ext USB 3.0
    PSU
    XFX Pro Series 850W Semi-Modular
    Case
    Gigabyte IF233
    Cooling
    1 x 120mm Front Inlet 1 x 120mm Rear Exhaust
    Keyboard
    Microsoft Comfort Curve Keyboard 3000 (USB)
    Mouse
    Microsoft Comfort Mouse 3000 for Business (USB)
    Internet Speed
    NetGear DG834Gv3 ADSL Modem/Router (Ethernet) ~4.0 Mb/sec (O2)
    Browser
    IE 11
    Antivirus
    Avast! 8.0.1497 MalwareBytes 1.75.0.1300
    Other Info
    Optical Drive: HL-DT-ST BD-RE BH10LS30 SATA Bluray
    Lexmark S305 Printer/Scanner/Copier (USB)
    WEI Score: 8.1/8.1/8.5/8.5/8.25
    Asus Eee PC 1011PX Netbook (Windows 7 x86 Starter)

ayres48

New Member
Posts
3
#3
yes except mine is only showing a single core
Untitled.png
 

My Computer

System One

  • OS
    windows 8 design preview
    System Manufacturer/Model
    cutom
    CPU
    phenom x3 8450
    Motherboard
    ECS GeForce 7050m-m
    Memory
    corsair 2GB
    Graphics Card(s)
    NVIDIA GeForce 8400 GS
    Monitor(s) Displays
    23" 1080p touch screen
    Hard Drives
    500gb Seagate
    1tb store e alu
    500gb solid state drive
    Case
    cooler master elite 340 black
    Cooling
    coolermaster case fans, 3x custom fit fans, master cooler Arctic Cooling Freezer 7 Pro
    Keyboard
    yes
    Mouse
    yes

Brink

Administrator
Administrator
mvp
Posts
24,216
#4

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

Dwarf

The Contemplator, (1963-2013)
Moderator
Doncaster, UK

Posts
638
#5
OK, it looks as though only one core is selected either in the BIOS (you will need to refer to your motherboard manual to check for the setting to change) or in msconfig. With the latter, click on the Boot tab and then Advanced options... Ensure that the checkbox next to Number of processors: is unchecked and then click OK twice to exit. Restart for changes to take effect. Note that you cannot utilise more processor cores than permitted in the BIOS (in other words, if you have a triple-core processor and only 2 cores are enabled in the BIOS, then unchecking the setting in msconfig will only allow 2 cores to be used and not all 3).
 

My Computer

System One

  • OS
    Windows 8.1 Pro RTM x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Dwarf Dwf/11/2012 r09/2013
    CPU
    Intel Core-i5-3570K 4-core @ 3.4GHz (Ivy Bridge) (OC 4.2GHz)
    Motherboard
    ASRock Z77 Extreme4-M
    Memory
    4 x 4GB DDR3-1600 Corsair Vengeance CMZ8GX3M2A1600C9B (16GB)
    Graphics Card(s)
    MSI GeForce GTX770 Gaming OC 2GB
    Sound Card
    Realtek High Definition on board solution (ALC 898)
    Monitor(s) Displays
    ViewSonic VA1912w Widescreen
    Screen Resolution
    1440x900
    Hard Drives
    OCZ Agility 3 120GB SATA III x2 (RAID 0)
    Samsung HD501LJ 500GB SATA II x2
    Hitachi HDS721010CLA332 1TB SATA II
    Iomega 1.5TB Ext USB 2.0
    WD 2.0TB Ext USB 3.0
    PSU
    XFX Pro Series 850W Semi-Modular
    Case
    Gigabyte IF233
    Cooling
    1 x 120mm Front Inlet 1 x 120mm Rear Exhaust
    Keyboard
    Microsoft Comfort Curve Keyboard 3000 (USB)
    Mouse
    Microsoft Comfort Mouse 3000 for Business (USB)
    Internet Speed
    NetGear DG834Gv3 ADSL Modem/Router (Ethernet) ~4.0 Mb/sec (O2)
    Browser
    IE 11
    Antivirus
    Avast! 8.0.1497 MalwareBytes 1.75.0.1300
    Other Info
    Optical Drive: HL-DT-ST BD-RE BH10LS30 SATA Bluray
    Lexmark S305 Printer/Scanner/Copier (USB)
    WEI Score: 8.1/8.1/8.5/8.5/8.25
    Asus Eee PC 1011PX Netbook (Windows 7 x86 Starter)

ayres48

New Member
Posts
3
#6
bios is correct i have checked and the number of processors is unchecked have set up to multi boot from a separate hard drive and all three cores are working on there even cpu-z is showing 1 core on here
 

My Computer

System One

  • OS
    windows 8 design preview
    System Manufacturer/Model
    cutom
    CPU
    phenom x3 8450
    Motherboard
    ECS GeForce 7050m-m
    Memory
    corsair 2GB
    Graphics Card(s)
    NVIDIA GeForce 8400 GS
    Monitor(s) Displays
    23" 1080p touch screen
    Hard Drives
    500gb Seagate
    1tb store e alu
    500gb solid state drive
    Case
    cooler master elite 340 black
    Cooling
    coolermaster case fans, 3x custom fit fans, master cooler Arctic Cooling Freezer 7 Pro
    Keyboard
    yes
    Mouse
    yes

Pooch

Power User
Power User
#7
Hello ayres

Mouse over the Windows flag and select Search, type in Device Manager and click on the magnifying glass to search, Under settings you should now see three apps have been found, click on settings then select Device Manager.

In Device Manager click on the little arrow next to Processors this will open up the section (see my snip)

Capture.PNG

Now right click on your core you should only have one showing and select uninstall, accept the warning Capture1.PNG


then click on restart your Computer Capture2.PNG


When the computer restarts it should find and install all cores.

If this does not work you are probably looking at a new install
 

My Computer

System One

  • OS
    Windows 7 and Windows Developer Dual efi boot
    System Manufacturer/Model
    Home Brew
    CPU
    Intel Core i7-2600K
    Motherboard
    Asus P8P67
    Memory
    16 GB G Skill F3-10666 CL9D-4GBRL
    Graphics Card(s)
    ATI Radeon HD 6870
    Sound Card
    ATI Radeon HDMI / Realtek ALC892
    Monitor(s) Displays
    2 x 22" standard monitors / LG32LC56 to watch films
    Screen Resolution
    1920 x1080
    Hard Drives
    2 x OCZ Vertex2 120GB in RAID 0
    3 x Samsung103SJ
    1 x Samsung103UJ
    1 x WD3200BEVT
    1 x Hitachi5K320-160
    PSU
    Thermaltake Toughpower Cable Management 750W
    Case
    Antec 300
    Cooling
    Noctua NH-U12P SE2 and 5 120mm Case fans
    Keyboard
    Microsoft Comfort Curve Keyboard 2000
    Mouse
    Hama M3110 / Logitech M305
    Internet Speed
    16000
    Other Info
    I have also used Fedora, Suse, Ubuntu Linux
    And all other Windows from 95 to date except ME

jeffrys

Power User
Power User
BELGIUM

Posts
503
#8
hello guys,

well i am confused here. i have the I5-670 Clarkdale, 2 cores, 4 threads, but i only see 1 physical and 1 logical processor like Ayres shows

If i change this to 2 processors and 4 logical, restart....will Win8 boot?

What i mean is, suppose one sets 4 processors and has only 2 what will happens?

correction, it only shows 1 processor in MSCONFIG and cannot put in more, but 4 cores in device manager


I hate hangups or boot problems...who doesn't

thanks


Jeff
 

My Computer

System One

  • OS
    WINDOWS 8.1 x64
    Computer type
    PC/Desktop
    CPU
    INTEL CORE I--3770K LGA1155
    Motherboard
    ASUS P8Z77-V
    Memory
    KINGSTON 2400 MHZ KHX24C11K4 16GB
    Graphics Card(s)
    INTEL HD GRAFICS 4000
    Monitor(s) Displays
    Philip BDL3245€ 32 inch
    Screen Resolution
    1920 x 1080
    Hard Drives
    2 SAMSUNG 840 PRO RAID 0 ON BOARD 2 x 128 GB
    Keyboard
    LOGITEC MX™ 5500
    Mouse
    LOGITEC MX 5500
    Internet Speed
    120 Mbps

vrosa

Tech Addict
VIP Member
Pro User
#9
I hate hangups or boot problems...who doesn't
I'm with you mate, such probs sUcK :(
 

My Computer

System One

  • OS
    Windows 10.0.10122
    Computer type
    PC/Desktop
    System Manufacturer/Model
    My Build - Vorttex Ultimate
    CPU
    Core i7 @ 4500 MHz
    Motherboard
    ASUS Z87-Plus
    Memory
    32GB DDR3 @ 1822 MHz (OC)
    Graphics Card(s)
    Radeon R9 280X 3GB @ 1180 / 6800 MHz
    Sound Card
    7.1 HDA
    Monitor(s) Displays
    LCD LG 22" + CRT LG 17"
    Screen Resolution
    1760 x 1320 / 1280 x 960
    Hard Drives
    1 x 240 GB SSD (System)
    3 x 500 GB HDD (Data/Media)
    1 x 2000 GB e-HDD (Backup)
    PSU
    ThermalTake 1000W PSU
    Case
    Corsair Carbide R300
    Cooling
    Corsair H60 (Push-Pull)
    Keyboard
    Microsoft Wireless Keyboard
    Mouse
    Microsoft Wireless Mouse
    Internet Speed
    60 Mbps (Down) 5 Mbps (Up)
    Browser
    IE, FF, Chrome
    Antivirus
    AVG Internet Security 2015
    Other Info
    Some wired stuff

Users Who Are Viewing This Thread (Users: 0, Guests: 1)