• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Mouse pointer dissapear-mouse not working


ShadrianK

New Member
Posts
2
#1
Hello, i happened to have a problem lately with mouse and mouse pointer. Yesterday i was playing a game and my pc suddenly started freezing and laging. So i hard reset him after that i boot into windows 8 and my mouse wasnt working at all. And pointer was no were to be seen either. Today i tried restoring pc but that dont help me. In bios and in advance startup options mouse is working. So i assume its in the windows. My specs are:
windows 8.1
gigabyte z77-hd3
intel core i5-3570k 3.8ghz
16 gb ram
Western digital 1TB HDD
nvidia geforce gtx 650 1GB
fsp 750W PSU
I tried everything except reinstalling windows (OS was installed week ago).
 

My Computer

System One

  • OS
    windows 8.1

lmaneke

New Member
Member
Marion

Posts
111
#2
I have heard of stability issues on those Gigabyte motherboards where people are having those problems with their mice.

Is your BIOS up to date? maybe it will contain an update on the website for the BIOS that improves system stability.

Is this a PS2 Mouse, or a USB mouse. If a USB, disconnect and then reconnect. If its a USB mouse that is wireless, make sure the battery is good, and if you have another computer, do a test.

Also try to boot from your Windows Installation Media and see if your mouse shows there, could give it a try.

If freezing and lagging during gaming, then could be possible overheating. Do you have a program installed like HWmonitor checking your CPU and GPU thermals. Make sure they aren't getting to hot.

If problem continues to persist. I would start troubleshooting. If you have another computer. or spare hard disk that is SATA, try installing windows on that, and try to duplicate the issue, if it comes back, rule out the hard drive.

Next would be either the GPU, RAM, or Motherboard. You would have to stress test the GPU by using Furmark, or similar program, like MSI Kombuster. If GPU stress test passes, move on to Memory.

while computer is powered down, and PSU off or unplugged. remove and reseat the memory modules, making sure they are fully seated, Do memory diagnostics with memtestx86 or something similar, and do a few passes, If memory check passes, Its more than likely there is a problem with the motherboard.

Weird problem for sure. You may have to do a RMA on that board if you haven't had it long.
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    ASUS
    CPU
    Intel Core 2 Quad Q6600 2.40 ghz
    Motherboard
    ASUS P5K PRO
    Memory
    2 GB DDR2
    Graphics Card(s)
    PNY NVIDIA Geforce GT 630
    Browser
    Internet Explorer 11
    Antivirus
    Windows Defender

ShadrianK

New Member
Posts
2
#3
so problem was in windows, the driver for mouses (microsoft HID-compliant mouse) was unistalled so i simply just reinstall windows and its working again and sorry about being offline. But anyway thank you for your help i will take those advices in future problems.
 

My Computer

System One

  • OS
    windows 8.1