• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Mobile Intel Series 4 and Intel HD Graphics 1st Generation


Posts
175
You should uninstall your graphics drivers and after pc restart try to run windows update, maybe there is a new drivers version from microsoft, cause like i said before, microsoft updated intels first gen graphics drivers, it includes opengl too, so maybe they updated some more drivers ?
 

My Computer

System One

  • OS
    ljkhlj
Posts
8
yea, I did removed the old intel driver using driver fusion in safemode. it left no native intel drivers in my laptop so it runs on non-native display (looks like 800x600 fully stretched). windows update was set to check for drivers but let me choose which to install, sumthin like that. installed custom cert installer provided in first post and installed this modded driver. fingers crossed and after successful restart, I now see my gui sitting on tray again! what a relief! big thanks to thread starter! not really bothered with little watermark since I can now customize my graphics settings in control panel. what'd you do to make gui work? I really thought it has something to do with my outdated .net 3.5
 

My Computer

System One

  • OS
    Windows 8 pro x64

Adam1964

New Member
Posts
1
With many thanks

Just wanted to thank the original poster and driver mod fellow. Your work has enabled me to overcome a surprise that struck this morning, when trying to run the Avid 6.5.1 video editor which I carry around on my laptop for unexpected location editing. Your driver mod enabled this program, which wouldn't display moving pictures with the Windows 8 Microsoft driver, to work again. Company policy dictates our laptops and operating systems; my job involves a little more accuracy on the part of video drivers than the company IT department is able to think about!

This is a Toshiba Satellite C660 device on Windows 8 Pro, running the Intel Express G45 chipset with a Core Duo (possibly) processor. I followed the instructions on the first post, downloading the driver from the link, and the certificate mod also along with the test-message removal program. All I did was follow instructions. Windows Update is switched to "optional" at all times but I religiously install all security updates. The desktop background still has the test-message overlay (the removal program stated "success"), but no program suffers from it, including the editor.

So the job got done, and IT will see my solution (your solution) later and I'll deal with it from there onwards. THANK YOU. Got a PayPal?
 

My Computer

System One

  • OS
    Windows 8 Pro 64-bit
Posts
8
Now here's my feedback after using it for quite a while. Despite the fact that I finally managed to control the 3d graphics settings in control panel, I noticed that the game I am playing (soulcraft from windows store) before I installed this driver lags noticeably. It runs between 21-28 fps compared to 29-35 fps when using intel gma driver with modified inf only (I mean, that part where ; no install on Windows 8, was replaced and nothing else was modified, even intelgfx gui is not working). I tried running Bubble Blast 2 and the lag is very noticeable. Now opera and chrome lags a bit with smooth scrolling enabled, even in light webpages like google search, so I think this is not app-specific but system wide. My onboard graphics is intel gma 4500mhd. Thank you in advance!
 

My Computer

System One

  • OS
    Windows 8 pro x64

XDleader555

New Member
Power User
I'm not sure...

Posts
253
@Adam No paypal, the thanks you gave is enough. It's feels great helping people
@TalaPantas I added registry key to the driver which overwrites the original registry key installed by the windows driver which disabled the gui. And I can't do much about the lag. I don't have a laptop with the series 4 to test new drivers with anymore. (and I'm pretty sure the Series 4 graphics weren't that powerful in the first place.)
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    CPU
    Intel Core i5-2500k
    Motherboard
    ASRock z77 Extreme 4
    Memory
    Team Elite 8GB (4 x 2GB)
    Graphics Card(s)
    Intel HD Graphics 3000 & Nvidia GT 530
    Sound Card
    Realtek ALC892
    Screen Resolution
    1920x1080
    Hard Drives
    Western Digital Caviar Black 750 GB SATA III 7200 RPM
    PSU
    Antec NEO ECO 620C 620W
    Case
    NZXT GAMMA Classic Series
    Cooling
    Cooler Master Hyper 212 Plus
    Keyboard
    i-rocks RF-6570
    Mouse
    i-rocks RF-7550A
    Internet Speed
    17Mbps
Posts
8
If it would not be too much for you, can you show us the location of modified registry keys to get igfxui to work? I'm just kind of interested to knowing it nothing else (im a script kiddie and i'd love messing with it XD), but it's really ok if you won't and yea, 4500MHD s*cks really really bad and all, but at least it allows me to play some cool indie 3D games run by unity engine, though not here in windows 8 since i can't bear the lags and frame skips compared to running it in windows 7.
i always know someone somewhere is there to help. really glad i came into the right place and found the right person XD
hoping for your continuous support and more power
big thanks XDleader555!
 

My Computer

System One

  • OS
    Windows 8 pro x64

XDleader555

New Member
Power User
I'm not sure...

Posts
253
This is the setting in the inf I found that disabled the CUI (When set to 1, it is disabled. I set it to 0 to enable it)
HKR,, CUINotRequired, %REG_DWORD%, 1

I'm not sure of the specific registry though.
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    CPU
    Intel Core i5-2500k
    Motherboard
    ASRock z77 Extreme 4
    Memory
    Team Elite 8GB (4 x 2GB)
    Graphics Card(s)
    Intel HD Graphics 3000 & Nvidia GT 530
    Sound Card
    Realtek ALC892
    Screen Resolution
    1920x1080
    Hard Drives
    Western Digital Caviar Black 750 GB SATA III 7200 RPM
    PSU
    Antec NEO ECO 620C 620W
    Case
    NZXT GAMMA Classic Series
    Cooling
    Cooler Master Hyper 212 Plus
    Keyboard
    i-rocks RF-6570
    Mouse
    i-rocks RF-7550A
    Internet Speed
    17Mbps
Posts
8
ok thanks
strange i cant find that line in the driver for 4 Series i just downloaded from here http://downloadcenter.intel.com/Detail_Desc.aspx?lang=eng&DwnldID=22166 . is that from zip or exe or i dont get the right download link :p?


snap2wb.png

i tried searching the entire inf from your mod for "CUINotRequired"
and i got 2 hits:

[DisableCommonUserInterface_AddSwSettings]
;If this Registry key is set to 1 then CUI will not Loaded.
HKR,, CUINotRequired, %REG_DWORD%, 0

[DisableCommonUserInterface_DelSwSettings]
HKR,, CUINotRequired

these lines does not seem to be included in the driver i just downloaded from above link. will try to copy/paste these lines and mess up with it at the moment ;)
 
Last edited:

My Computer

System One

  • OS
    Windows 8 pro x64

XDleader555

New Member
Power User
I'm not sure...

Posts
253
ok thanks
strange i cant find that line in the driver for 4 Series i just downloaded from here http://downloadcenter.intel.com/Detail_Desc.aspx?lang=eng&DwnldID=22166 . is that from zip or exe or i dont get the right download link :p?


View attachment 17215

i tried searching the entire inf from your mod for "CUINotRequired"
and i got 2 hits:

[DisableCommonUserInterface_AddSwSettings]
;If this Registry key is set to 1 then CUI will not Loaded.
HKR,, CUINotRequired, %REG_DWORD%, 0

[DisableCommonUserInterface_DelSwSettings]
HKR,, CUINotRequired

these lines does not seem to be included in the driver i just downloaded from above link. will try to copy/paste these lines and mess up with it at the moment ;)
It's not there by default. So when you install the driver the registry is never changed to 0. It stays at 1. That's why the CUI is disabled by default.
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    CPU
    Intel Core i5-2500k
    Motherboard
    ASRock z77 Extreme 4
    Memory
    Team Elite 8GB (4 x 2GB)
    Graphics Card(s)
    Intel HD Graphics 3000 & Nvidia GT 530
    Sound Card
    Realtek ALC892
    Screen Resolution
    1920x1080
    Hard Drives
    Western Digital Caviar Black 750 GB SATA III 7200 RPM
    PSU
    Antec NEO ECO 620C 620W
    Case
    NZXT GAMMA Classic Series
    Cooling
    Cooler Master Hyper 212 Plus
    Keyboard
    i-rocks RF-6570
    Mouse
    i-rocks RF-7550A
    Internet Speed
    17Mbps
Posts
8
Got it!

searched for CUINotRequired in registry hive and it appears to be device specific. Im fine with that since it will only be done once. Now the igfxpanel fired up (after restart obviously) right after setting CUINotRequired to "0" just like what you said, in
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000 & HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0001

Tried doing short benchmarks using novabench and it appears that enabling "software processing" in vertex mode does not do some magic anymore as much as it does in windows 7 and accdg to sites showing how to tweak intel gma.
snap4bj.png snap1r.png

What took me by surprise is that "application settings," still an option in vertex mode, significantly increases the fps from the usual 28-32 in windos 7 to 29 to 56 here in windows 8! That's almost twice an increase I never thought it can ever get!
snap3o.png snap2r.png
Feels like some games that I can play pretty good in windows 7 does not do well here in windows 8 for some reason, though novebench tells otherwise. Glad windows 8 was able to utilize some hidden performance tweaks to get the best out of this poor fella.
Will try to do this with your mod driver and I'll conduct the same benchmark with the same settings and we'll see.
 

My Computer

System One

  • OS
    Windows 8 pro x64

XDleader555

New Member
Power User
I'm not sure...

Posts
253
Got it!

searched for CUINotRequired in registry hive and it appears to be device specific. Im fine with that since it will only be done once. Now the igfxpanel fired up (after restart obviously) right after setting CUINotRequired to "0" just like what you said, in
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000 & HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0001

Tried doing short benchmarks using novabench and it appears that enabling "software processing" in vertex mode does not do some magic anymore as much as it does in windows 7 and accdg to sites showing how to tweak intel gma.
View attachment 17247 View attachment 17244

What took me by surprise is that "application settings," still an option in vertex mode, significantly increases the fps from the usual 28-32 in windos 7 to 29 to 56 here in windows 8! That's almost twice an increase I never thought it can ever get!
View attachment 17246 View attachment 17245
Feels like some games that I can play pretty good in windows 7 does not do well here in windows 8 for some reason, though novebench tells otherwise. Glad windows 8 was able to utilize some hidden performance tweaks to get the best out of this poor fella.
Will try to do this with your mod driver and I'll conduct the same benchmark with the same settings and we'll see.
If you find anything (Say, a registry key which is supposed to be changed in windows 8) tell me and I'll add it to the Drivers. I saw a guy in this thread mixing drivers to get slightly better performance.

What I would do is look over the inf from the Intel HD 3000/4000 package and make sure everything is correctly set. My theory is that something from the Newer HD 3000 driver could be copied to the modified driver (say the openGL dll) and allow netflix to be played.
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    CPU
    Intel Core i5-2500k
    Motherboard
    ASRock z77 Extreme 4
    Memory
    Team Elite 8GB (4 x 2GB)
    Graphics Card(s)
    Intel HD Graphics 3000 & Nvidia GT 530
    Sound Card
    Realtek ALC892
    Screen Resolution
    1920x1080
    Hard Drives
    Western Digital Caviar Black 750 GB SATA III 7200 RPM
    PSU
    Antec NEO ECO 620C 620W
    Case
    NZXT GAMMA Classic Series
    Cooling
    Cooler Master Hyper 212 Plus
    Keyboard
    i-rocks RF-6570
    Mouse
    i-rocks RF-7550A
    Internet Speed
    17Mbps
Posts
8
ah! Ket. yeah, been following his thread and his mod driver is what i used to have in this box before moving to 8. for now everything seems to be good. i finally installed your mod (after doing some comparisons against unmodded intel gma driver) and will take that advice about intel hd 3000. as for some stuff to be added in your list, i'll post right on as i encountered one.

rated 5 for this great contribution!
 

My Computer

System One

  • OS
    Windows 8 pro x64

Skytiimez

New Member
Posts
2
Won't work for me.... have you one for Intel(R) Mobile Chipset Family 4 Express - (Microsoft Corporation - WDDM 1.1) ?

Windows 8 Pro with Media Center (x86)
 

My Computer

System One

  • OS
    Windows 8 Pro with Media Center (x86)
    System Manufacturer/Model
    TOSHIBA Satellite C660-10D
    CPU
    TOSHIBA Laptop
    Memory
    464 GB
    Graphics Card(s)
    Mobile Intel(R) serie 4 Express Chipset Family (Microsoft Corporation - WDDM 1.1)
    Monitor(s) Displays
    Mobile Intel(R) serie 4 Express Chipset Family (Microsoft Corporation - WDDM 1.1)
    Mouse
    Logitech M235
    Browser
    Comodo Dragon

XDleader555

New Member
Power User
I'm not sure...

Posts
253
Won't work for me.... have you one for Intel(R) Mobile Chipset Family 4 Express - (Microsoft Corporation - WDDM 1.1) ?

Windows 8 Pro with Media Center (x86)
Make sure to read the first post completely.
1. Download and install the custom certificate
2. Download the correct driver for your card
3. Install the driver

If you still can't get it to install send me your hardware ID's for your graphics Card
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    CPU
    Intel Core i5-2500k
    Motherboard
    ASRock z77 Extreme 4
    Memory
    Team Elite 8GB (4 x 2GB)
    Graphics Card(s)
    Intel HD Graphics 3000 & Nvidia GT 530
    Sound Card
    Realtek ALC892
    Screen Resolution
    1920x1080
    Hard Drives
    Western Digital Caviar Black 750 GB SATA III 7200 RPM
    PSU
    Antec NEO ECO 620C 620W
    Case
    NZXT GAMMA Classic Series
    Cooling
    Cooler Master Hyper 212 Plus
    Keyboard
    i-rocks RF-6570
    Mouse
    i-rocks RF-7550A
    Internet Speed
    17Mbps
Plz provide detail step for my acer aspire 5738 with windows 8 pro.
it gives me error of open gl 1.1 is very low minimum 2.0 is required for some application...
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    System Manufacturer/Model
    ACER Aspire 5738

skelbley

New Member
Posts
1
Just wanted to thank XDleader for this, I'll be getting an HP 2740p in a few days and plan to upgrade it to Windows 8. I'll make sure to report back with my results.
 

My Computer

System One

  • OS
    Windows 7 Professional x64
[DEL]Hi there, I hope someone can help, I am trying to update my graphics drivers (intel mobile 4), I'm trying to use the drivers mentioned at the beginning of this thread.
When I try to install them, I get a message saying
"The driver selected for this device does not support this version of windows"
do I need to update something I am using windows 8 professional, that is fully updated.

Thanks.

Hardware ID: PCI\VEN_8086&DEV_2A42&SUBSYS_03001025&REV_07[/DEL]

Ok so managed to get the graphics drivers installed, and also found a driver for the SMO8800 ST Micro accelerometer, but I cannot get my screen to auto rotate, which did work on windows 7. Any ideas?

Thanks.
 
Last edited:

My Computer

System One

  • OS
    Windows 8
    Computer type
    Laptop
    System Manufacturer/Model
    Acer 1825PTZ

XDleader555

New Member
Power User
I'm not sure...

Posts
253
[DEL]Hi there, I hope someone can help, I am trying to update my graphics drivers (intel mobile 4), I'm trying to use the drivers mentioned at the beginning of this thread.
When I try to install them, I get a message saying
"The driver selected for this device does not support this version of windows"
do I need to update something I am using windows 8 professional, that is fully updated.

Thanks.

Hardware ID: PCI\VEN_8086&DEV_2A42&SUBSYS_03001025&REV_07[/DEL]

Ok so managed to get the graphics drivers installed, and also found a driver for the SMO8800 ST Micro accelerometer, but I cannot get my screen to auto rotate, which did work on windows 7. Any ideas?

Thanks.
Right click the desktop -> screen resolution -> Allow the Screen to autorotate

There's a few more solutions listed here.
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    CPU
    Intel Core i5-2500k
    Motherboard
    ASRock z77 Extreme 4
    Memory
    Team Elite 8GB (4 x 2GB)
    Graphics Card(s)
    Intel HD Graphics 3000 & Nvidia GT 530
    Sound Card
    Realtek ALC892
    Screen Resolution
    1920x1080
    Hard Drives
    Western Digital Caviar Black 750 GB SATA III 7200 RPM
    PSU
    Antec NEO ECO 620C 620W
    Case
    NZXT GAMMA Classic Series
    Cooling
    Cooler Master Hyper 212 Plus
    Keyboard
    i-rocks RF-6570
    Mouse
    i-rocks RF-7550A
    Internet Speed
    17Mbps

Users Who Are Viewing This Thread (Users: 0, Guests: 2)