• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Main user account type changed to guest, can't change back


#1
Hey all,

I have spent the weekend trying to figure out how to change my account type back to administrator but with no luck.

I have been running this laptop as my main machine for a few months now with no problems, however, I realised I had a problem when I wanted to change some networking settings on Friday when the UAC said I needed admin privileges and wouldn't let me enter a password or click "Yes", hence not allowing me to go any further.

I went to control panel > User accounts and saw my account type has been changed to Guest.

Now I have thought long and hard and I have not changed or had any need to change my account type to guest, nor has anyone else had access to my laptop, so I can only assume this has been done in the last week or so during a Windows update.

I'll tell you what I did to try to resolve this below:

First of all I tried to enable the hidden administrator account while in my account by running command prompt as admin (and then entering net user Administrator /active:yes) but as I don't have admin privileges I couldn't even open the command prompt so I couldn't get any further.

After reading around the net and this forum I found this thread and gave it a try. After restarting the laptop and booting into safe mode I was expecting to see and Administrator account next to my account at the log in screen, however, there was only the administrator account to choose from, so I clicked it and it went through the first time initialisation of the account and then showed me the start menu, I then went to run the command prompt as admin and it worked, I entered net user Administrator /active:yes which worked with no problems. I then went to the user accounts in control panel to "Manage other accounts" but my usual account was nowhere to be found. So I thought I'd restart the laptop and see what happens out of safe mode.

When it restarted I was still only presented with the admin account, so I logged in to disable the hidden by entering net user Administrator /active:no in the command prompt run as admin and then restarted.

After restarting again I was expecting to see my account but was still presented with only the admin account, but when I clicked on it it said it was disabled and I was completely locked out of windows.

Luckily I created a restore point so I managed to restore my settings, and was back at square one.

After a bit of testing it seems my main user account is being removed when I enter safe mode, but do nothing else. I have no idea why entering safe mode is removing my account.

I am at a bit of a loss as I can't seem to activate admin privileges on my account, but if i try to fix it I lose my account completely.

I did find this thread, but I can't find the download link for Hiren's boot cd.

If anyone has any help, fixes or advice I'd really appreciate it as I don't really want to restore my laptop to factory. Even if I do restore it to factory will this problem happen again?!

Any help would be absolutely great!

Cheers

Mark
 

My Computer

System One

  • OS
    Windows 8.1 64 bit
    Computer type
    Laptop
    System Manufacturer/Model Number
    Lenovo Z510
    CPU
    Intel i7-4702MQ @2.2 GHz
    Memory
    8GB
Posts
1,870
#2

My Computer

System One

  • OS
    Windows 10 Pro Prieview x64
    Computer type
    Laptop
    System Manufacturer/Model Number
    MacBook Pro Core2Duo
    CPU
    T7600
    Memory
    3
    Graphics Card(s)
    ATI Radeon X1600
    Monitor(s) Displays
    Internal
    Screen Resolution
    1440 x 800
    Hard Drives
    40GB
    Keyboard
    Apple
    Mouse
    Apple
    Internet Speed
    Varies
    Browser
    Various
    Antivirus
    Defender
#3
Hi Adamf,

Thanks for your reply.

I tried the option 2 for enabling the built in admin account with the regedit, however, it did the same as last time, it completely deleted my main account.

I'll try the Hirens BootCD and see if that helps.

M
 

My Computer

System One

  • OS
    Windows 8.1 64 bit
    Computer type
    Laptop
    System Manufacturer/Model Number
    Lenovo Z510
    CPU
    Intel i7-4702MQ @2.2 GHz
    Memory
    8GB
#4
Nope, that didn't work either.

I managed to load mini XP but it was missing the HBCD menu with all the options.

Does anyone else have any advice?

I think I'm going to have to restore back to factory settings.

Mark
 

My Computer

System One

  • OS
    Windows 8.1 64 bit
    Computer type
    Laptop
    System Manufacturer/Model Number
    Lenovo Z510
    CPU
    Intel i7-4702MQ @2.2 GHz
    Memory
    8GB