• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Lock Screen Slide Show - Turn On or Off in Windows 8.1


Brink

Administrator
Administrator
mvp
Posts
23,897
#21
How do the paths look when you view them in File Explorer instead?
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone
Posts
32
#22
Through file explorer, paths are working as expected. Its just the metro file browser interface that seems to not recognize anything other than Onedrive.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model
    Asus N550JV-DB72T
    Graphics Card(s)
    nNidia GeForce750M
    Monitor(s) Displays
    (2) Asus VN247H-P
    Screen Resolution
    1920x1080

Brink

Administrator
Administrator
mvp
Posts
23,897
#23
If this just recently happened, then you could do a system restore using a restore point dated before this started to hopefully undo and fix it.
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone
Posts
32
#24
Hey there Brink... I ended up re-indexing and rebuilding my libraries, so that now when I select This PC, everything is there as it should be!

Bu now there is some peculiar behavior with the lock screen slideshow displaying my, ahem, hidden files. I have a folder or two on my external drive that have been marked as hidden under the folder properties, but I was very surprised to see a couple of the images from these folders come up during a slideshow.

The folders, sub-folders and contents within these hidden folders are properly shown as hidden through other apps, for example, from the mail app, when selecting attach file, then browsing to the external drive and looking for these hidden folders, they are not displayed or otherwise presented. Only during the lock screen slideshow have I seen them come up. Under PC and devices >lock screen > play a slide show from the lock screen > use pictures from... the only items listed are the OneDrive pictures and the desktop pictures libraries. The hidden folders on the external drive are definitely not there! Any suggestions as to what is going on?
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model
    Asus N550JV-DB72T
    Graphics Card(s)
    nNidia GeForce750M
    Monitor(s) Displays
    (2) Asus VN247H-P
    Screen Resolution
    1920x1080

Brink

Administrator
Administrator
mvp
Posts
23,897
#25

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

avada

Member
Member
Posts
162
#26
Hi!

It seems like this doesn't work at all for me. I changed it to slideshow (with selecting a folder, etc) but I still have the old image that I used for the lockscreen.
Do I need a restart? It's not mentioned, and I don't see why shouldn't it be applied instantly.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Ryzen 5 1600
    Motherboard
    Asus Prime B350-PLUS
    Memory
    G.SKILL Trident Z 16GB (2x8GB) DDR4 3000MHz F4-3000C15D-16GTZB
    Graphics Card(s)
    nVIDIA GeForce GTS 450 (Asus ENGTS450)
    PSU
    500w FSP

avada

Member
Member
Posts
162
#27
It seems like my reg keys are different though:
lockscreen.png

I don't have SlideshowAutoLock for one. (SlideshowDuration I custom set to 10 minutes, but it didn't work when I set 30 mins in the GUI)

Also:
What on earth is "AutoLockScreenTimeoutActive" which is only mentioned in a warning within this tutorial and never explained...
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Ryzen 5 1600
    Motherboard
    Asus Prime B350-PLUS
    Memory
    G.SKILL Trident Z 16GB (2x8GB) DDR4 3000MHz F4-3000C15D-16GTZB
    Graphics Card(s)
    nVIDIA GeForce GTS 450 (Asus ENGTS450)
    PSU
    500w FSP

Brink

Administrator
Administrator
mvp
Posts
23,897
#28
Hello avada, :)

Just to make sure, this will only apply to your lock screen while you are signed in to Windows and have locked (Win+L) the computer.

If a DWORD is missing in the registy, it means that it's setting has not been changed in Settings yet. You would just need to manually add the DWORD as per the blue note box under step 4 in Option 2 to be able to change it in the registry.

The red warning box in step 5 Option 2 is to make sure that is set to be able play a slide show on your lock screen.
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

avada

Member
Member
Posts
162
#29
Hello avada, :)

Just to make sure, this will only apply to your lock screen while you are signed in to Windows and have locked (Win+L) the computer.

If a DWORD is missing in the registy, it means that it's setting has not been changed in Settings yet. You would just need to manually add the DWORD as per the blue note box under step 4 in Option 2 to be able to change it in the registry.

The red warning box in step 5 Option 2 is to make sure that is set to be able play a slide show on your lock screen.
-Indeed. That's what I was expecting. But the image just wouldn't change.

-Okay. I set everything I wanted then.

-But that key wasn't there at all, and isn't explained. What does AutoLockScreenTimeoutActive do? (I see you removed it from the warning) Should I create it manually since it's not there?
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Ryzen 5 1600
    Motherboard
    Asus Prime B350-PLUS
    Memory
    G.SKILL Trident Z 16GB (2x8GB) DDR4 3000MHz F4-3000C15D-16GTZB
    Graphics Card(s)
    nVIDIA GeForce GTS 450 (Asus ENGTS450)
    PSU
    500w FSP

avada

Member
Member
Posts
162
#30
I tried deleting the Lock Screen screen altogether. ...And the picture still remained... And the screen switched off after a minute. (it was set to 30 minutes). It's like the settings and values don't matter at all.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Ryzen 5 1600
    Motherboard
    Asus Prime B350-PLUS
    Memory
    G.SKILL Trident Z 16GB (2x8GB) DDR4 3000MHz F4-3000C15D-16GTZB
    Graphics Card(s)
    nVIDIA GeForce GTS 450 (Asus ENGTS450)
    PSU
    500w FSP

Brink

Administrator
Administrator
mvp
Posts
23,897
#31
AutoLockScreenTimeoutActive was a left over from a previous update of the tutorial. It's removed now.

Let's see some screenshots of your lock screen slide show settings in Settings to see if anything may stand out.

Usually, it's best to select a folder that only contains the images you want to use for the slide show, and doesn't contain anything else.
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

avada

Member
Member
Posts
162
#32
AutoLockScreenTimeoutActive was a left over from a previous update of the tutorial. It's removed now.

Let's see some screenshots of your lock screen slide show settings in Settings to see if anything may stand out.
I told you what I set, but here it is:
(The preview broke when I deleted the Lock Screen registry key. But it still won't work.)
lockscreen-settings.png

AutoLockScreenTimeoutActive was a left over from a previous update of the tutorial. It's removed now.

Let's see some screenshots of your lock screen slide show settings in Settings to see if anything may stand out.

Usually, it's best to select a folder that only contains the images you want to use for the slide show, and doesn't contain anything else.
That's the case I use the default pictures folder, just as I do for wallpapers.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Ryzen 5 1600
    Motherboard
    Asus Prime B350-PLUS
    Memory
    G.SKILL Trident Z 16GB (2x8GB) DDR4 3000MHz F4-3000C15D-16GTZB
    Graphics Card(s)
    nVIDIA GeForce GTS 450 (Asus ENGTS450)
    PSU
    500w FSP

Brink

Administrator
Administrator
mvp
Posts
23,897
#33
No offense to you, but I just like to see screenshots to verify to help rule out any possible misunderstandings about the settings, and see if anything stands out that might not have been thought about.

In your screenshot, you have a red "You need more than one for the slides" message. It looks like you need to add another folder to be able to play a slide show on the lock screen.
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

avada

Member
Member
Posts
162
#34
In your screenshot, you have a red "You need more than one for the slides" message. It looks like you need to add another folder to be able to play a slide show on the lock screen.
(stupid windows can't even read it's own default pictures folder...)
That's of no significance. I had the folder added before and did it again. Still the same old lockscreen picture.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Ryzen 5 1600
    Motherboard
    Asus Prime B350-PLUS
    Memory
    G.SKILL Trident Z 16GB (2x8GB) DDR4 3000MHz F4-3000C15D-16GTZB
    Graphics Card(s)
    nVIDIA GeForce GTS 450 (Asus ENGTS450)
    PSU
    500w FSP

Brink

Administrator
Administrator
mvp
Posts
23,897
#35
As a test, add a second folder, and put the images you want inside the second folder to see how that does for you.
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

avada

Member
Member
Posts
162
#36
As a test, add a second folder, and put the images you want inside the second folder to see how that does for you.
Nothing. Though I noticed that I always get the idiotic "need more than one image for slideshow" message when I revisit the settings.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Ryzen 5 1600
    Motherboard
    Asus Prime B350-PLUS
    Memory
    G.SKILL Trident Z 16GB (2x8GB) DDR4 3000MHz F4-3000C15D-16GTZB
    Graphics Card(s)
    nVIDIA GeForce GTS 450 (Asus ENGTS450)
    PSU
    500w FSP

Brink

Administrator
Administrator
mvp
Posts
23,897
#37
Odd. I take that both folders have more than one image in them?
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

avada

Member
Member
Posts
162
#38

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Ryzen 5 1600
    Motherboard
    Asus Prime B350-PLUS
    Memory
    G.SKILL Trident Z 16GB (2x8GB) DDR4 3000MHz F4-3000C15D-16GTZB
    Graphics Card(s)
    nVIDIA GeForce GTS 450 (Asus ENGTS450)
    PSU
    500w FSP

Brink

Administrator
Administrator
mvp
Posts
23,897
#39

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

avada

Member
Member
Posts
162
#40
I think I found the issue. The "Windows Search" service apparently needs to be enabled. You can add it to the guide.

Also, apparently it disables the screensaver and vice versa, setting a screensaver disables the animated lockscreen. Can be super frustrating, when you unexpectedly disable one of them. Worth a mention in my opinion.

(Didn't find out why the default lockscreen broke though.)
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Ryzen 5 1600
    Motherboard
    Asus Prime B350-PLUS
    Memory
    G.SKILL Trident Z 16GB (2x8GB) DDR4 3000MHz F4-3000C15D-16GTZB
    Graphics Card(s)
    nVIDIA GeForce GTS 450 (Asus ENGTS450)
    PSU
    500w FSP

Users Who Are Viewing This Thread (Users: 0, Guests: 1)