What's new

Latest AMD Catalyst Graphics Driver for Windows 8

CountMike

Well-Known Member
VIP Member
Guru
New AMD 14.11.1 BETA video driver released. See first post for more details. :)
Yeah, CCC keeps bugging me about it last couple of days but I found 14.4 to work best with my setup. Will try it in W10tp first. !4.9 had few Betas pulled back and reissued, quite a mess, I hope they are not going the way ATI had problems 10 or so years ago.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home made
    CPU
    AMD Ryzen7 2700x
    Motherboard
    Asus Prime x470 Pro
    Memory
    16GB Kingston 3600
    Graphics Card(s)
    Asus strix 570 OC 4gb
    Hard Drives
    Samsung 960 evo 250GB
    Silicon Power V70 240GB SSD
    WD 1 TB Blue
    WD 2 TB Blue
    Bunch of backup HDDs.
    PSU
    Sharkoon, Silent Storm 660W
    Case
    Raidmax
    Cooling
    CCM Nepton 140xl
    Internet Speed
    40/2 Mbps
    Browser
    Firefox
    Antivirus
    WD

CountMike

Well-Known Member
VIP Member
Guru
New AMD 14.11.1 BETA video driver released. See first post for more details. :)

Just be advised that, unlike with the previous 14.9.x beta drivers, these are 64-bit only.
There re just some adjustments for BF4 and few other games. actual drivers are same since 14.9.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home made
    CPU
    AMD Ryzen7 2700x
    Motherboard
    Asus Prime x470 Pro
    Memory
    16GB Kingston 3600
    Graphics Card(s)
    Asus strix 570 OC 4gb
    Hard Drives
    Samsung 960 evo 250GB
    Silicon Power V70 240GB SSD
    WD 1 TB Blue
    WD 2 TB Blue
    Bunch of backup HDDs.
    PSU
    Sharkoon, Silent Storm 660W
    Case
    Raidmax
    Cooling
    CCM Nepton 140xl
    Internet Speed
    40/2 Mbps
    Browser
    Firefox
    Antivirus
    WD

HOODY

Banned
I've decided to not install anymore beta graphics drivers, I may or may not even bother updating a new WHQL driver, there just isn't all that much new or advantage to an older GPU like my 7690m xt (6770m).

I seen little in the way of any benifit going from 14.4 to 14.9 And having to set the system BIOS now to dynamic, I hardly if ever even see the Radeon card being usd at all, its mostly the Intel 3000 chip doing the work.
 

My Computer

System One

  • OS
    W8.1up1 Pro x64 w/media center
    Computer type
    Laptop
    System Manufacturer/Model
    dv7t-6c00 HP
    CPU
    2670QM
    Motherboard
    HP
    Memory
    8g
    Graphics Card(s)
    Radeon 7690M XT (6770m) /Intel 3000
    Sound Card
    IDT HD Intel
    Monitor(s) Displays
    Laptop 17.3"/Samsung 26"
    Screen Resolution
    1920x1080 HD
    Hard Drives
    Hitichi 750g 5400 rpm Laptop
    Case
    Brushed Aluminum (steel)
    Keyboard
    external USB
    Mouse
    external USB
    Internet Speed
    DSL
    Browser
    FF, IE, Chrome
    Antivirus
    COMODO Security Suite

blackroseMD1

Member
VIP Member
Member
New beta drivers are up. 14.11.2

Highlights of AMD Catalyst™ 14.11.2 Windows® Beta Driver Performance Improvements
Dragon Age: Inquisition performance optimizations
- Up to 5% performance increase over Catalyst™ 14.11.1 beta in single GPU scenarios with Anti-Aliasing enabled.
- Optimized AMD CrossFire™ profile
Far Cry 4 performance optimizations
- Up to 50% performance increase over Catalyst™ 14.11.1 beta in single GPU scenarios with Anti-Aliasing enabled.

Important Notes
The AMD CrossFire™ profile for Far Cry 4 is currently disabled in this driver while AMD works with Ubisoft to investigate an issue where AMD CrossFire™ configurations are not performing as intended. An update is expected on this issue in the near future through an updated game patch or an AMD driver posting.

Resolved Issues
[409235]: Small chance of intermittent screen tearing or corruption in Call of Duty®: Advanced Warfare on high settings 4K resolution in AMD CrossFire™ mode.
[408892]: World of Warcraft can sometimes exhibit corruption when using CMAA in AMD CrossFire™ configurations.
[407431]: Minecraft sometimes produces corruption when changing video settings in windowed mode.
[407338]: XDMA Quad CrossFire™ configurations in portrait Eyefinity modes sometimes display tearing or stuttering.
Known Issues
[408723]: System can sometimes hang when upgrading to Catalyst™ 14.11.2 from Catalyst™14.7 in AMD CrossFire™ configurations. As a workaround please completely uninstall previous Catalyst™ software versions before installing Catalyst™14.11.2 beta.
[409518]: Slight performance drops in FIFA 2015 on AMD CrossFire™ configurations.
[409502]: Occasional flickering sometimes observed while playing FIFA 2015 in AMD Dual Graphics configurations.
[409638]: Slight Battlefield 4 performance drop on AMD Radeon™ R9 290X in AMD CrossFire™ configuration.
[409628]: AMD Radeon™ R9 285 intermittently hangs in Hitman Absolution on new game start.
[408484]: AMD Radeon™ R9 285 can sometimes exhibit flickering in Assassins Creed Unity.
[409613]: Assassins Creed Unity can sometimes experience frame stutter on some AMD CrossFire™ configurations.
[408706]: Call of Duty: Advanced Warfare intermittent black screen when loading game in Quad AMD Crossfire™ configurations.
[409600]: Civilization: Beyond Earth mantle users in AMD CrossFire™ configurations may sometimes experience an issue where they cannot change their game resolution. As a work around please use "Enable MGPU=1" in the games configuration .ini file.

AMD is currently working with BioWare to resolve the following issues:
Flickering is sometimes observed in Dragon Age: Inquisition on a limited number of surfaces in AMD CrossFire™ configurations.

AMD is currently working with Ubisoft to resolve the following issues:
Uneven hair corruption sometimes observed in Assassins Creed Unity when applying "ultra" game settings.
Flickering occasionally observed between windows on walls in Assassins Creed Unity.
Windows/Doors intermittently flash with black textures in Assassins Creed Unity.
Assassins Creed Unity occasionally exits to desktop when "ultra" game settings are applied.
 
Last edited:

My Computer

System One

  • OS
    Windows 10 Tech Preview 10041 x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom built
    CPU
    AMD FX-8350 8-core Black Edition @ 4.0 Ghz (4.2 Turbo)
    Motherboard
    Gigabyte GA-990FXA-UD3
    Memory
    16GB DDR3 1333
    Graphics Card(s)
    Asus R9 290 DirectCU II OC, Gigabyte R9 290 Windforce OC in Xfire
    Sound Card
    Integrated w/ Creative A250 2.1 speakers
    Monitor(s) Displays
    Main: Asus VN289H 28" Secondary: Acer G246HL 24"
    Screen Resolution
    3840x1080
    Hard Drives
    128 GB SanDisk Ultra Plus (Windows drive)

    240 GB Crucial M500 SSD (Data drive)

    1 TB WDC WD10EACS 7200RPM HDD (Data drive)

    2 TB Seagate Expansion Desktop external HDD (Backup drive)
    PSU
    900w Antec HCG-900
    Case
    Raidmax Agusta Full ATX
    Cooling
    Corsair H80 liquid
    Keyboard
    Cooler Master Devastator KB24
    Mouse
    Cooler Master Devastator MS2K 1000/1600/2000 DPI
    Internet Speed
    100 Mbps cable
    Browser
    Chrome

sygnus21

Member
VIP Member
Power User
Edit: Above post fixed :thumbsup:

That said, these are just in time for Dragon Age: Inquisition's release, in which I receive my copy tomorrow :geek:

Hopefully these don't re-break my NEC monitor calibration software, which is fixed in 14.11.1
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom built by me
    CPU
    Haswell i7-4770K
    Motherboard
    Gigabyte G1 Sniper 5 (BIOS F9)
    Memory
    Corsair Dominator Platinum 32 gig (1866MHz)
    Graphics Card(s)
    Sapphire R9-280 Vapor X
    Sound Card
    Soundblaster ZXR
    Monitor(s) Displays
    NEC PA242W - 24 inch
    Screen Resolution
    1920 x 1200
    Hard Drives
    Samsung 512gig 850 Pro SSD (OS), Samsung 256gig 840 Pro SSD (photo editing), Western Digital Caviar Black 2TB HD
    PSU
    EVGA Supernova 1000 G2
    Case
    Cooler Master HAF X
    Cooling
    Corsair H100i Closed Loop Cooler
    Keyboard
    Logitech Wireless Wave
    Mouse
    Logitech Performance MX
    Internet Speed
    High Speed
    Browser
    IE11
    Antivirus
    Norton Security
    Other Info
    RAM Speed: 1866MHZ @ 9-10-10-27-2T, 1.5v

blackroseMD1

Member
VIP Member
Member
Haha, could have sworn I put the quote tags in there. Oops. Fixed it now.

I'm glad to see these up. Just finished getting Far Cry 4 preloaded. Hopefully they fix the crossfire issues soon.
 

My Computer

System One

  • OS
    Windows 10 Tech Preview 10041 x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom built
    CPU
    AMD FX-8350 8-core Black Edition @ 4.0 Ghz (4.2 Turbo)
    Motherboard
    Gigabyte GA-990FXA-UD3
    Memory
    16GB DDR3 1333
    Graphics Card(s)
    Asus R9 290 DirectCU II OC, Gigabyte R9 290 Windforce OC in Xfire
    Sound Card
    Integrated w/ Creative A250 2.1 speakers
    Monitor(s) Displays
    Main: Asus VN289H 28" Secondary: Acer G246HL 24"
    Screen Resolution
    3840x1080
    Hard Drives
    128 GB SanDisk Ultra Plus (Windows drive)

    240 GB Crucial M500 SSD (Data drive)

    1 TB WDC WD10EACS 7200RPM HDD (Data drive)

    2 TB Seagate Expansion Desktop external HDD (Backup drive)
    PSU
    900w Antec HCG-900
    Case
    Raidmax Agusta Full ATX
    Cooling
    Corsair H80 liquid
    Keyboard
    Cooler Master Devastator KB24
    Mouse
    Cooler Master Devastator MS2K 1000/1600/2000 DPI
    Internet Speed
    100 Mbps cable
    Browser
    Chrome

sygnus21

Member
VIP Member
Power User
Thanks Brian. I figured it was a mistake, I was just messing with you :D

Anyway let us know what you think of Far Cry 4. I usually hang out in the seven forums since their gaming section is much more active than here. I also have a thread over there that I might change to discuss Dragon Age: Inquisition. It's currently named - Dragon Age: Inquisition's system requirements

I'll install these drivers later on since I get my copy of DA:I tomorrow.

And again, thanks ;) :thumb:
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom built by me
    CPU
    Haswell i7-4770K
    Motherboard
    Gigabyte G1 Sniper 5 (BIOS F9)
    Memory
    Corsair Dominator Platinum 32 gig (1866MHz)
    Graphics Card(s)
    Sapphire R9-280 Vapor X
    Sound Card
    Soundblaster ZXR
    Monitor(s) Displays
    NEC PA242W - 24 inch
    Screen Resolution
    1920 x 1200
    Hard Drives
    Samsung 512gig 850 Pro SSD (OS), Samsung 256gig 840 Pro SSD (photo editing), Western Digital Caviar Black 2TB HD
    PSU
    EVGA Supernova 1000 G2
    Case
    Cooler Master HAF X
    Cooling
    Corsair H100i Closed Loop Cooler
    Keyboard
    Logitech Wireless Wave
    Mouse
    Logitech Performance MX
    Internet Speed
    High Speed
    Browser
    IE11
    Antivirus
    Norton Security
    Other Info
    RAM Speed: 1866MHZ @ 9-10-10-27-2T, 1.5v

LovingWindows

New Member
VIP Member
Power User
Was previously using 14.11.1 Beta due to a problem with Catalyst crashing in 14.9, got the update for 14.11.2 and been using that since a few moments after it was put on AMD website.

Working like a charm so far. I tend to not use beta drivers, as AMD can't be held responsible if somethings breaks because of it...but I use Catalyst a lot for setting custom 3D profiles and 14.9 version was giving me problems (such as crashing).
 

My Computer

System One

  • OS
    Windows 8.1 x64
    Computer type
    Laptop

Brink

Administrator
Administrator
mvp
New AMD 14.12 WHQL video driver released. See first post for more details. :)
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

Mark Phelps

New Member
VIP Member
Pro User
New AMD 14.12 WHQL video driver released. See first post for more details. :)

Does NOT install these drivers, only the AMD Install Manager and a couple of other items. Tried this twice on my AMD R7 240 previously running 14.9. First install appeared to work OK but when rebooting and checking CCC software info, 14.9 was still there.

Removed the drivers using Programs and Features, rebooted, confirmed AMD driver no longer installed, tried again. Appeared to go through all the motions but only installed the AMD Install Manager, AHCI driver, and USB driver -- nothing else. Checked the installation log and only those three items were listed. Rebooted, and no AMD entry in apps list, no AMD item in system tray, Device Manager still showed generic drivers installed.

Retried using the 14.11.2 beta drivers. This time, it went through all the steps and DID actually install the drivers and all the other stuff. Rebooted and AMD is in apps list and in the system tray.

But NOW! I get annoying popups that a newer version of the driver is available -- 14.12!

OK ... web page to the AMD site finally opened and the 14.2 driver there is 212MB, not the 48MB link from the first post in this thread. So, maybe the thread link is bad. I'll download and try this larger version -- and report back.

UPDATE: Downloaded and installed using the 200+MB version of the file -- and it worked fine.
 
Last edited:

My Computer

Cliff S

Missing my GIF avatars:(
Pro User
Worked for me. I've been using them for the last seven hours with absolutely no problems and the amdmantel64.dll does not crash any more either(not having to change .dll to .old). I have the AMD Radeon R5 235(HD7000 series).
 

My Computer

System One

  • OS
    Windows 8.1 Update Pro in Hyper-V/Windows 10 Pro 64 bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Cliff's Black & Blue Wonder
    CPU
    Intel Core i9-9900K
    Motherboard
    ASUS ROG Maximus X Hero
    Memory
    32 GB Quad Kit, G.Skill Trident Z RGB Series schwarz, DDR4-3866, 18-19-19-39-2T
    Graphics Card(s)
    ASUS GeForce RTX 3090 ROG Strix O24G, 24576 MB GDDR6X
    Sound Card
    (1) HD Webcam C270 (2) NVIDIA High Definition Audio (3) Realtek High Definition Audio
    Monitor(s) Displays
    BenQ BL2711U(4K) and a hp 27vx(1080p)
    Screen Resolution
    1920 x 1080 x 32 bits (4294967296 colors) @ 60 Hz
    Hard Drives
    C: Samsung 960 EVO NVMe M.2 SSD
    E: & O: Libraries & OneDrive-> Samsung 850 EVO 1TB
    D: Hyper-V VM's -> Samsung PM951 Client M.2 512Gb SSD
    G: System Images -> HDD Seagate Barracuda 2TB
    PSU
    Corsair HX1000i High Performance ATX Power Supply 80+ Platinum
    Case
    hanteks Enthoo Pro TG
    Cooling
    Thermaltake Floe Riing RGB TT Premium-Edition 360mm and 3 Corsair blue LED fans
    Keyboard
    Trust GTX THURA
    Mouse
    Trust GTX 148
    Internet Speed
    25+/5+ (+usually faster)
    Browser
    Edge; Chrome; IE11
    Antivirus
    Windows Defender of course & Malwarebytes Anti-Exploit as a
    Other Info
    Router: FRITZ!Box 7490
    Sound system: SHARP HT-SBW460 Dolby Atmos Soundbar
    Webcam: Logitech BRIO ULTRA HD PRO WEBCAM 4K webcam with HDR

blackroseMD1

Member
VIP Member
Member
New AMD 14.12 WHQL video driver released. See first post for more details. :)

Man, this looks like a doozy of an update. Virtual 4K on 1080p monitors? Awesome.
 

My Computer

System One

  • OS
    Windows 10 Tech Preview 10041 x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom built
    CPU
    AMD FX-8350 8-core Black Edition @ 4.0 Ghz (4.2 Turbo)
    Motherboard
    Gigabyte GA-990FXA-UD3
    Memory
    16GB DDR3 1333
    Graphics Card(s)
    Asus R9 290 DirectCU II OC, Gigabyte R9 290 Windforce OC in Xfire
    Sound Card
    Integrated w/ Creative A250 2.1 speakers
    Monitor(s) Displays
    Main: Asus VN289H 28" Secondary: Acer G246HL 24"
    Screen Resolution
    3840x1080
    Hard Drives
    128 GB SanDisk Ultra Plus (Windows drive)

    240 GB Crucial M500 SSD (Data drive)

    1 TB WDC WD10EACS 7200RPM HDD (Data drive)

    2 TB Seagate Expansion Desktop external HDD (Backup drive)
    PSU
    900w Antec HCG-900
    Case
    Raidmax Agusta Full ATX
    Cooling
    Corsair H80 liquid
    Keyboard
    Cooler Master Devastator KB24
    Mouse
    Cooler Master Devastator MS2K 1000/1600/2000 DPI
    Internet Speed
    100 Mbps cable
    Browser
    Chrome

LovingWindows

New Member
VIP Member
Power User
Loving the new Omega drivers by AMD, so much performance boosts all over the place! Even the AHCI driver has boosted my read/write speeds by a bunch.
 

My Computer

System One

  • OS
    Windows 8.1 x64
    Computer type
    Laptop

HOODY

Banned
No problem installing here either, no problems running. I only installed these cause they were WHQL, just to see, as usual I probly won't see any differance, since I don't play any heavy graphics intense games. And since you no longer set the fixed option, all I see is my Intel 3000 running anyway now.
 

My Computer

System One

  • OS
    W8.1up1 Pro x64 w/media center
    Computer type
    Laptop
    System Manufacturer/Model
    dv7t-6c00 HP
    CPU
    2670QM
    Motherboard
    HP
    Memory
    8g
    Graphics Card(s)
    Radeon 7690M XT (6770m) /Intel 3000
    Sound Card
    IDT HD Intel
    Monitor(s) Displays
    Laptop 17.3"/Samsung 26"
    Screen Resolution
    1920x1080 HD
    Hard Drives
    Hitichi 750g 5400 rpm Laptop
    Case
    Brushed Aluminum (steel)
    Keyboard
    external USB
    Mouse
    external USB
    Internet Speed
    DSL
    Browser
    FF, IE, Chrome
    Antivirus
    COMODO Security Suite

blackroseMD1

Member
VIP Member
Member
I'm seeing massive improvements in both Far Cry 4 (frame rate drops into the 20s have vanished, averaging 40 to 80 FPS now) and Assassin's Creed Unity (30-50 FPS now, teens to 40 before) with only 1 GPU enabled. Both games still take massive framerate drops with crossfire enabled though.
 

My Computer

System One

  • OS
    Windows 10 Tech Preview 10041 x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom built
    CPU
    AMD FX-8350 8-core Black Edition @ 4.0 Ghz (4.2 Turbo)
    Motherboard
    Gigabyte GA-990FXA-UD3
    Memory
    16GB DDR3 1333
    Graphics Card(s)
    Asus R9 290 DirectCU II OC, Gigabyte R9 290 Windforce OC in Xfire
    Sound Card
    Integrated w/ Creative A250 2.1 speakers
    Monitor(s) Displays
    Main: Asus VN289H 28" Secondary: Acer G246HL 24"
    Screen Resolution
    3840x1080
    Hard Drives
    128 GB SanDisk Ultra Plus (Windows drive)

    240 GB Crucial M500 SSD (Data drive)

    1 TB WDC WD10EACS 7200RPM HDD (Data drive)

    2 TB Seagate Expansion Desktop external HDD (Backup drive)
    PSU
    900w Antec HCG-900
    Case
    Raidmax Agusta Full ATX
    Cooling
    Corsair H80 liquid
    Keyboard
    Cooler Master Devastator KB24
    Mouse
    Cooler Master Devastator MS2K 1000/1600/2000 DPI
    Internet Speed
    100 Mbps cable
    Browser
    Chrome

Brink

Administrator
Administrator
mvp
AMD Catalyst HDMI Scaling Hotfix Software Suite version 14.501.1003.1001 available. See first post for more details. :)
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

blackroseMD1

Member
VIP Member
Member
AMD Catalyst HDMI Scaling Hotfix Software Suite version 14.501.1003.1001 available. See first post for more details. :)

Hmm...so should I uninstall the WHQL driver before installing this, or just install this over the 14.12 driver?
 

My Computer

System One

  • OS
    Windows 10 Tech Preview 10041 x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom built
    CPU
    AMD FX-8350 8-core Black Edition @ 4.0 Ghz (4.2 Turbo)
    Motherboard
    Gigabyte GA-990FXA-UD3
    Memory
    16GB DDR3 1333
    Graphics Card(s)
    Asus R9 290 DirectCU II OC, Gigabyte R9 290 Windforce OC in Xfire
    Sound Card
    Integrated w/ Creative A250 2.1 speakers
    Monitor(s) Displays
    Main: Asus VN289H 28" Secondary: Acer G246HL 24"
    Screen Resolution
    3840x1080
    Hard Drives
    128 GB SanDisk Ultra Plus (Windows drive)

    240 GB Crucial M500 SSD (Data drive)

    1 TB WDC WD10EACS 7200RPM HDD (Data drive)

    2 TB Seagate Expansion Desktop external HDD (Backup drive)
    PSU
    900w Antec HCG-900
    Case
    Raidmax Agusta Full ATX
    Cooling
    Corsair H80 liquid
    Keyboard
    Cooler Master Devastator KB24
    Mouse
    Cooler Master Devastator MS2K 1000/1600/2000 DPI
    Internet Speed
    100 Mbps cable
    Browser
    Chrome

HOODY

Banned
I doubt I need to concern myself over this, I don't use HDMI as it is. And 14.12 is just fine.
 

My Computer

System One

  • OS
    W8.1up1 Pro x64 w/media center
    Computer type
    Laptop
    System Manufacturer/Model
    dv7t-6c00 HP
    CPU
    2670QM
    Motherboard
    HP
    Memory
    8g
    Graphics Card(s)
    Radeon 7690M XT (6770m) /Intel 3000
    Sound Card
    IDT HD Intel
    Monitor(s) Displays
    Laptop 17.3"/Samsung 26"
    Screen Resolution
    1920x1080 HD
    Hard Drives
    Hitichi 750g 5400 rpm Laptop
    Case
    Brushed Aluminum (steel)
    Keyboard
    external USB
    Mouse
    external USB
    Internet Speed
    DSL
    Browser
    FF, IE, Chrome
    Antivirus
    COMODO Security Suite

Phone Man

Retired Bell Head
VIP Member
Pro User
New AMD 14.12 WHQL video driver released. See first post for more details. :)

Does NOT install these drivers, only the AMD Install Manager and a couple of other items. Tried this twice on my AMD R7 240 previously running 14.9. First install appeared to work OK but when rebooting and checking CCC software info, 14.9 was still there.

Removed the drivers using Programs and Features, rebooted, confirmed AMD driver no longer installed, tried again. Appeared to go through all the motions but only installed the AMD Install Manager, AHCI driver, and USB driver -- nothing else. Checked the installation log and only those three items were listed. Rebooted, and no AMD entry in apps list, no AMD item in system tray, Device Manager still showed generic drivers installed.

Retried using the 14.11.2 beta drivers. This time, it went through all the steps and DID actually install the drivers and all the other stuff. Rebooted and AMD is in apps list and in the system tray.

But NOW! I get annoying popups that a newer version of the driver is available -- 14.12!

OK ... web page to the AMD site finally opened and the 14.2 driver there is 212MB, not the 48MB link from the first post in this thread. So, maybe the thread link is bad. I'll download and try this larger version -- and report back.

UPDATE: Downloaded and installed using the 200+MB version of the file -- and it worked fine.

There are two downloads for 14.12. The 200+MB is for the Video card and the 48+MB is for the Chip set

Omega 1.PNGOmega 2.PNG

Jim :cool:
 

My Computer

System One

  • OS
    Windows 7 HP 64bit, Windows 8.1 Pro w/Media Center 64BIT
    Computer type
    PC/Desktop
    System Manufacturer/Model
    ASUS - Home Built
    CPU
    AMD Phenom II X6 1100T
    Motherboard
    ASUS M5A99X EVO
    Memory
    Crucial Balistic DDR-3 1866 CL 9 (8 GB)
    Graphics Card(s)
    MSI R6850 Cyclone IGD5 PE
    Sound Card
    On Chip
    Monitor(s) Displays
    ASUS VE258Q 25" LED with DVI-HDMI-DisplayPort
    Screen Resolution
    1920 x 1080
    Hard Drives
    Two WD Cavier Black 2TB Sata 6gbs
    WD My Book Essential 2TB USB 3.0
    PSU
    Seasonic X650 80 Plus GOLD Modular
    Case
    Corsair 400R
    Cooling
    Antec Kuhler H2O 620, Two 120mm and four 140mm
    Keyboard
    AVS Gear Blue LED Backlight
    Mouse
    Logitech Marble Mouse USB, Logitech Precision Game Pad
    Internet Speed
    15MB
    Antivirus
    NIS, Malwarebytes Premium 2
    Other Info
    APC UPS ES 750, Netgear WNR3500L Gigabit & Wireless N Router with SamKnows Test Program,
    Motorola SB6120 Gigabit Cable Modem.
    Brother HL-2170W Laser Printer,
    Epson V300 Scanner
Top