What's new

Laptop colors darken when unplugged [not brightness]

Pining4A

New Member
I've recently picked up a Samsung ATIV Book 9 Plus (first windows 8 experience) and have come across a display issue whenever the laptop gets unplugged, namely that the colors become incredibly dark as it the contrast takes a dive.

Here is a recreation.
http://i.imgur.com/CCIb6pQ.png

Specs from amazon:


  • Intel Core i5-4200U Processor
  • 4GB (4GB x 1) DDR3 Memory (1600MHz)
  • 128 GB Solid-State Drive SATA3
  • 13.3" LED QHD+, 3200 x 1800, 16:9, 10 Point Capacitive Touch Screen, Intel HD Graphics 4400
  • Windows 8 (64-bit)

    Any help in resolving this issue will be greatly appreciated
 

My Computer

System One

  • OS
    Windows 8

Ztruker

Well-Known Member
VIP Member
Guru
You say it's not brightness, but have you tried using the brightness keys to see if it makes any difference?
 

My Computer

System One

  • OS
    Windows 10 Pro X64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Lenovo IdeaCenter K450
    CPU
    Intel Quad Core i7-4770 @ 3.4Ghz
    Motherboard
    Lenovo
    Memory
    16.0GB PC3-12800 DDR3 SDRAM 1600 MHz
    Graphics Card(s)
    Intel Integrated HD Graphics
    Sound Card
    Realtek HD Audio
    Monitor(s) Displays
    HP h2207
    Screen Resolution
    1680x1050@59Hz
    Hard Drives
    250GB Samsung EVO SATA-3 SSD;
    2TB Seagate ST2000DM001 SATA-2;
    1.5TB Seagate ST3150041AS SATA
    PSU
    500W
    Keyboard
    Wired USB
    Mouse
    Wired USB
    Internet Speed
    3GB Up, 30GB Down
    Browser
    SeaMonkey
    Antivirus
    Windows Defender; MBAM Pro
    Other Info
    UEFI/GPT
    PLDS DVD-RW DH16AERSH

Pining4A

New Member
It really has nothing to do with brightness at all. I'm used the brightness keys on my keyboard and adjusted them in the power options while the laptop was unplugged to no avail. This really is just the colors on-screen darkening heavily

When I unplug my laptop I can see that the contrast starts gradually increasing until all the colors show up like in the picture. I've heard that this might be something related to power-saving but I haven't found anything of the sort in the Intel Graphics Control Panel
 

My Computer

System One

  • OS
    Windows 8

popeye

New Member
VIP Member
Guru
So changing settings here has no affect?

Capture.JPG
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64-bit
    Computer type
    Laptop
    System Manufacturer/Model
    Acer V3 771G-6443
    CPU
    i5-3230m
    Motherboard
    Acer VA70_HC (U3E1)
    Memory
    8GB DDR3 PC3-12800 (800 MHz)
    Graphics Card(s)
    HD4000 + GeForce GT 730M
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    17" Generic PnP Display on Intel HD Graphics 4000
    Screen Resolution
    1600x900 pixels
    Hard Drives
    Samsung SSD 850 EVO 250 GB
    ADATA SSD SP900 128GB
    PSU
    90 watt brick
    Mouse
    Bluetooth
    Antivirus
    Comodo
    Other Info
    Asus RT-AC56R dual-band WRT router (Merlin firmware). Intel 7260.HMWWB.R dual-band ac wireless adapter.

SebasSmits

Member
Member
Have you tried activating in stead of brightness your LCD background. Most laptops got that with a fn button. My fn combination for LCD background On/Off is fn+f7. f7 shows a small icon with a crossed screen.
 

My Computer

System One

  • OS
    Win 8.1, Win 8, Win 7, Win Vista, Win XP
    Computer type
    Laptop
    System Manufacturer/Model
    Asus X301A
    CPU
    Intel I3
    Motherboard
    Default
    Memory
    640 GB
    Graphics Card(s)
    Default
    Browser
    IE 10
    Antivirus
    Norton

Pining4A

New Member
Have you tried activating in stead of brightness your LCD background. Most laptops got that with a fn button. My fn combination for LCD background On/Off is fn+f7. f7 shows a small icon with a crossed screen.

My Laptop does not appear to have the function + F[1-12] for that feature. At this point I have concluded that all I have to do is turn off Intel Display Power Saving Technology but I have no idea how to access this.
 

My Computer

System One

  • OS
    Windows 8

caperjack

Just the Janitor
VIP Member
Guru
So changing settings here has no affect?

View attachment 28435

Huh, my Intel control panel looks nothing like that. I've scoured through it and couldn't find a tick-box for the display power saving technology.

Mine looks like this:
http://i.imgur.com/Uu0TcGL.png

Or is this a different control panel?

they may not look the same but should perform the same , popeye has max performance checked off ,you have balanced checked off ,try checking off max performance ,and make adjustments, just a thought
 

My Computer

System One

  • OS
    win8.1.1 enterprise
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Hinze57
    CPU
    AMD FX 6100 6core 3.30gHz
    Motherboard
    gigibyte ga-78lmy-s2p
    Memory
    4gig ddr3
    Graphics Card(s)
    Radon hd5000 Series
    Sound Card
    onboard realtek hd
    Monitor(s) Displays
    19" viewsonic/ 22"Samsung
    Screen Resolution
    1680x1050
    Hard Drives
    128gig ssd Kingston
    80gig WD 10000 rpm spinner
    Case
    micro
    Keyboard
    microsoft curve 200
    Mouse
    Logitech wireless M215
    Internet Speed
    high speed 20
    Browser
    ie 11
    Antivirus
    windows defender
    Other Info
    updated enterprise apr 2/14

fafhrd

Active Member
Pro User
Have you tried going to the Control Panel Power Settings and editing the Balanced Power Plan for Battery?

There is a setting to dim the display.

Your machine is factory optimized for long battery life if unplugged, and these are chipset features, controlled thru Windows, reducing consumption through the CPU, rather than just the GPU display features, controlled by the Intel Graphics control. You may also find Advanced Power Options has an option to maximize battery life thru the Graphics system when unplugged, which you can modify. There are features for Dimmed Display Brightness, Display Brightness and Adaptive Brightness as well. At least on my highly unsophisticated HP Compaq Presario, compared to your high-end Samsung ATIV-9 Plus, these features are available.
displ.PNG
It is another instance of having multiple ways to control the system features, hidden behind layers of windows and menus that is making Windows so much less intuitive.
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model
    HP COMPAQ Presario CQ57
    CPU
    AMD E- 300 APU with Radion HD Graphics 1.30GHz
    Motherboard
    inbuilt
    Memory
    4GB
    Graphics Card(s)
    ATI
    Sound Card
    High Definition Audio on-board
    Monitor(s) Displays
    notebook
    Screen Resolution
    1366x768
    Hard Drives
    Seagate ST9500325AS
    Google drive 15GB
    Skydrive 25GB
    BT Cloud
    PSU
    external 20v
    Case
    Laptop
    Cooling
    pretty good
    Keyboard
    inbuilt
    Mouse
    touchpad
    Internet Speed
    BT Infinity Unlimited - 80 up 20 down =70/16 really
    Browser
    Chrome Canary usually
    Antivirus
    Windows Defender and Malwarebytes
    Other Info
    no Start menu modifications
    Upgraded with no issues to 8.0 and to 8.1

Wullail

Active Member
Pro User
Your control panel DOES have 'display power saving technology' , 3rd tick down,...and it's toggled ON.
 

My Computer

System One

  • OS
    Windows 8 Pro
    Computer type
    PC/Desktop
    Memory
    6 GB
    Screen Resolution
    1280 x 1024
    Hard Drives
    12 TB in 6 disks
    PSU
    TX650
    Keyboard
    G15
    Mouse
    Intellimouse 3.0
    Internet Speed
    100 Mbits
    Browser
    Chrome
    Antivirus
    Trend Micro

nuvolari7

New Member
I have the same laptop (Samsung ATIV Book 9 Plus) but I ordered from Amazon UK. I think the darker colour is related to power saving but I can't find where to disable it. It's definitely nothing to do with the screen brightness. Playing with the settings in the Intel HD Graphics Control Panel, Samsung Settings app and the Power Options doesn't make any difference.

A solution I came up with fixes the problem but if you restart or shutdown the problem comes back. I just put the laptop into sleep mode when I'm not using it.

The steps for my solution are outlined below:

Export graphics driver
  1. Go to the Start Screen
  2. Type SW Update and launch the program
  3. Click Save Setup Files on the bottom left
  4. Make sure only the Graphics Driver is selected
  5. Click Export and choose a location to save the driver

Uninstall the graphics driver
  1. Right-click on Computer and select Properties
  2. Go to Device Manager
  3. Find Display adapter and expand that tree
  4. Right-Click on Intel(R) HD Graphics Family and select Uninstall
  5. Follow the wizard to uninstall the driver and restart when prompted

Reinstall the graphics driver
  1. Go to the location of where the Graphics Driver was exported
  2. Launch Setup
  3. Uncheck Automatically run WinSat and enable the Windows Aero desktop theme
  4. Follow the wizard to install the driver
  5. Do not restart when prompted or else the problem will come back

I think after restarting, something is loaded which makes the colours darker in order to save power. Hopefully in a future software update, they will give the user control over this feature.

If you need to restart because of updates or a program installation, it would require the graphics driver to be uninstalled and reinstalled again so it's not really the best solution. I'll keep you updated if I find a better way to fix it.
 

My Computer

System One

  • OS
    Windows 8

Pining4A

New Member
they may not look the same but should perform the same , popeye has max performance checked off ,you have balanced checked off ,try checking off max performance ,and make adjustments, just a thought

Your control panel DOES have 'display power saving technology' , 3rd tick down,...and it's toggled ON.

Alight so I set it to Maximum performance and unticked Display Power Saving Technology but the contrast still takes a nosedive everytime unplug my laptop

Have you tried going to the Control Panel Power Settings and editing the Balanced Power Plan for Battery?

There is a setting to dim the display.

Your machine is factory optimized for long battery life if unplugged, and these are chipset features, controlled thru Windows, reducing consumption through the CPU, rather than just the GPU display features, controlled by the Intel Graphics control. You may also find Advanced Power Options has an option to maximize battery life thru the Graphics system when unplugged, which you can modify. There are features for Dimmed Display Brightness, Display Brightness and Adaptive Brightness as well. At least on my highly unsophisticated HP Compaq Presario, compared to your high-end Samsung ATIV-9 Plus, these features are available.
View attachment 28448
It is another instance of having multiple ways to control the system features, hidden behind layers of windows and menus that is making Windows so much less intuitive.

I went into the advanced power options and threw absolutely everything into high-gear, setting everything to max performance on battery, no dimming or adaptive brightness. Nontheless, upon unplugging my laptop I still see the screen slowly losing contrast...

I have the same laptop (Samsung ATIV Book 9 Plus) but I ordered from Amazon UK. I think the darker colour is related to power saving but I can't find where to disable it. It's definitely nothing to do with the screen brightness. Playing with the settings in the Intel HD Graphics Control Panel, Samsung Settings app and the Power Options doesn't make any difference.

A solution I came up with fixes the problem but if you restart or shutdown the problem comes back. I just put the laptop into sleep mode when I'm not using it.

The steps for my solution are outlined below:

Export graphics driver
  1. Go to the Start Screen
  2. Type SW Update and launch the program
  3. Click Save Setup Files on the bottom left
  4. Make sure only the Graphics Driver is selected
  5. Click Export and choose a location to save the driver

Uninstall the graphics driver
  1. Right-click on Computer and select Properties
  2. Go to Device Manager
  3. Find Display adapter and expand that tree
  4. Right-Click on Intel(R) HD Graphics Family and select Uninstall
  5. Follow the wizard to uninstall the driver and restart when prompted

Reinstall the graphics driver
  1. Go to the location of where the Graphics Driver was exported
  2. Launch Setup
  3. Uncheck Automatically run WinSat and enable the Windows Aero desktop theme
  4. Follow the wizard to install the driver
  5. Do not restart when prompted or else the problem will come back

I think after restarting, something is loaded which makes the colours darker in order to save power. Hopefully in a future software update, they will give the user control over this feature.

If you need to restart because of updates or a program installation, it would require the graphics driver to be uninstalled and reinstalled again so it's not really the best solution. I'll keep you updated if I find a better way to fix it.

Thank you for the detailed reply. I have tried uninstalling the graphics driver prior to the creation of this thread and It DID work, the contrast would remain the same whether I unplugged my machine or not but then I couldn't control the brightness of the screen which is a huge inconvenience.

Nonetheless thank you very much, your method does not involve me having to go to the intel site and looking for the driver every time. Maybe I'll just keep on doing your method whenever I need to keep the colors the way they are whenever I travel. It baffles me that this feature cannot be turned off.


Edit: I just had a thought, is it possible to trick my laptop into believing it's plugged in when it's actually running on battery?
 

My Computer

System One

  • OS
    Windows 8

nuvolari7

New Member
Laptops require a suitable graphics driver for the brightness controls to work. It would be best to use the driver from Samsung to ensure the best compatibility. I thought I was only one with this problem until I found your post.
 

My Computer

System One

  • OS
    Windows 8

Pining4A

New Member
I think that the only way I can run this the way I want it to is to continuously uninstall and reinstall the graphics driver unless there is a way to make the laptop stay "plugged-in" even when it's running on battery
 

My Computer

System One

  • OS
    Windows 8

nuvolari7

New Member
I think that the only way I can run this the way I want it to is to continuously uninstall and reinstall the graphics driver unless there is a way to make the laptop stay "plugged-in" even when it's running on battery

I think closing the lid to put it into sleep mode is not what you want to do. It does keep the colour but some battery is used during sleep mode.

Hmm..I doubt it's possible to trick it into thinking it's plugged in. Maybe an external battery pack would work. I haven't tried it before but I think it will need to have decent capacity to power the laptop.
 

My Computer

System One

  • OS
    Windows 8

XweAponX

New Member
VIP Member
Pro User
Do you have your Desktop Theme set for "Auto Colour"? - If you do, the taskbar and explorer windows will change colour depending on which Wallpaper is being shown, if you have rotating Wallpapers. Does it do this at all when unplugged? When a laptop is unplugged, it stops the wallpaper rotation.
 

My Computer

System One

  • OS
    Windows 8 Pro with Media Center/Windows 7
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Asus M2N-MX SE Plus § DualCore AMD Athlon 64 X2, 2300 MHz (11.5 x 200) 4400+ § Corsair Value Select
    CPU
    AMD 4400+/4200+
    Motherboard
    Asus M2N-MX SE Plus/Asus A8M2N-LA (NodusM)
    Memory
    2 GB/3GB
    Graphics Card(s)
    GeForce 8400 GS/GeForce 210
    Sound Card
    nVIDIA GT218 - High Definition Audio Controller
    Monitor(s) Displays
    Hitachi 40" LCD HDTV
    Screen Resolution
    "1842 x 1036"
    Hard Drives
    WDC WD50 00AAKS-007AA SCSI Disk Device
    ST1000DL 002-9TT153 SCSI Disk Device
    WDC WD3200AAJB-00J3A0 ATA Device
    WDC WD32 WD-WCAPZ2942630 USB Device
    WD My Book 1140 USB Device
    PSU
    Works 550w
    Case
    MSI "M-Box"
    Cooling
    Water Cooled
    Keyboard
    Dell Keyboard
    Mouse
    Microsoft Intellimouse
    Internet Speed
    Cable Medium Speed
    Browser
    Chrome/IE 10
    Antivirus
    Eset NOD32 6.x/Win Defend
    Other Info
    Recently lost my Windows 8 on my main PC, had to go back to Windows 7.

XweAponX

New Member
VIP Member
Pro User
It sounds like you have your Auto-Dim set for 1 minute. The controls for this are in your Power Configuration, you can get into it via Control Panel, Power Options. IN Advanced Power Options you can set the dimming for different time values and brightness values.

For Battery, I set the brightness at 80 percent, dimming at 75 percent- Plugged in, I use 100 percent and 80% dimming. For battery, I would set the Auto Dim to 5 minutes.
 

My Computer

System One

  • OS
    Windows 8 Pro with Media Center/Windows 7
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Asus M2N-MX SE Plus § DualCore AMD Athlon 64 X2, 2300 MHz (11.5 x 200) 4400+ § Corsair Value Select
    CPU
    AMD 4400+/4200+
    Motherboard
    Asus M2N-MX SE Plus/Asus A8M2N-LA (NodusM)
    Memory
    2 GB/3GB
    Graphics Card(s)
    GeForce 8400 GS/GeForce 210
    Sound Card
    nVIDIA GT218 - High Definition Audio Controller
    Monitor(s) Displays
    Hitachi 40" LCD HDTV
    Screen Resolution
    "1842 x 1036"
    Hard Drives
    WDC WD50 00AAKS-007AA SCSI Disk Device
    ST1000DL 002-9TT153 SCSI Disk Device
    WDC WD3200AAJB-00J3A0 ATA Device
    WDC WD32 WD-WCAPZ2942630 USB Device
    WD My Book 1140 USB Device
    PSU
    Works 550w
    Case
    MSI "M-Box"
    Cooling
    Water Cooled
    Keyboard
    Dell Keyboard
    Mouse
    Microsoft Intellimouse
    Internet Speed
    Cable Medium Speed
    Browser
    Chrome/IE 10
    Antivirus
    Eset NOD32 6.x/Win Defend
    Other Info
    Recently lost my Windows 8 on my main PC, had to go back to Windows 7.

nuvolari7

New Member
I've been disabling the graphics driver before shutdown/restart and enabling the graphics driver after I login. This is inconvenient but I found it does make the screen colour ok when running on battery.

The steps below show how to do this

Included are two bat files, each can be run to either disable or enable the graphics driver. Make sure to extract devcon.exe to the same location as the bat files. Also, set the properties of devcon.exe to run as administrator.



  1. Uninstall the graphics driver and restart
  2. Reinstall the graphics but don't restart
  3. Modify the bat files using notepad to set your graphics driver hardware ID (More details below)
  4. Now you run disableGraphics.bat before shutdown/restart and enableGraphics.bat after you login.


Setting the hardware ID:

For example, disableGraphics.bat has the line:
devcon disable"PCI\VEN_8086&DEV_0A16&SUBSYS_C0EF144D&REV_09"

The part in quotes is the hardware ID which you may need to change. Do this for both bat files.You can find the ID when you go to the properties of the graphics driver in Device Manager. It will be in the Details tab, the Hardware ID is in the drop-down menu. I chose the most top ID.

I've been trying to use Task Scheduler to get these bat files to run automatically but I haven't got it work reliably. So I've just been manually running the the files when I need to shutdown or restart.
 

Attachments

  • disableGraphics.bat
    65 bytes · Views: 60
  • enableGraphics.bat
    64 bytes · Views: 63
  • devcon.zip
    24.4 KB · Views: 32
Last edited:

My Computer

System One

  • OS
    Windows 8

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top