• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Language bar in windows 8


Baidukun

Member
Member
Posts
69
#1
Language bar in windows 8 (not showingup)

There is setting in windows 8 "Use desktop language bar when it's available" it makes language bar like it was in windows 7.
But it doesn't seem to work correctly it doesn't appear when windows starts it only appears if you change language with keyboard short cut (for example shift+alt or shift+ctrl you can change that in settings).
I have set 3 input languages so it should be there and I need to use it..
windows default language preference select menu works but language bar doesn't.
Any solutions?
 

Attachments

My Computer

System One

  • OS
    Windows 7 uiltimate, Windows 8.1 pro 64bit, Windows server 2008R2, Windows 10 TP
    Computer type
    PC/Desktop

davehc

New Member
Pro User
Denmark (But English)

Posts
1,150
#2
I have two languages. I have the same setting as yourself, but I have chosen an option under "Use language list (recommended)
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    Other Info
    Use several different computers during a day, so specs are irrelevant.

jimbo45

New Member
VIP Member
Guru
Hafnarfjörður IS

Posts
4,373
#3
Hi there
Rather than a separate toolbar it's on - at least it is on mine --on the Taskbar. Click the language displayed and the other options get shown -- in my case I click on ISL and you see I also have UK and US input languages available.

You can't actually CHANGE the display language "In flight" -- you have to re-start the computer again. Note also for Display Languages you have to have either Windows 8 PRO or Windows 8 ENTERPRISE -- which IMO seems crazy -- most people in large businesses will understand (usually English if the business is an international company) and whatever the local Language is.

Having different display languages IMO is far more useful for HOME users. But that's Ms.

Cheers
jimbo
 

Attachments

My Computer

System One

  • OS
    Linux Centos 7, W8.1, W7, W2K3 Server W10
    Computer type
    PC/Desktop
    Monitor(s) Displays
    1 X LG 40 inch TV
    Hard Drives
    SSD's * 3 (Samsung 840 series) 250 GB
    2 X 3 TB sata
    5 X 1 TB sata
    Internet Speed
    0.12 GB/s (120Mb/s)

Baidukun

Member
Member
Posts
69
#4
I have two languages. I have the same setting as yourself, but I have chosen an option under "Use language list (recommended)
I'm sorry but I don't understand what you want to say with your post if you look at my picture that I attached you will see that I have "Use language list (recommended)" setting selected too.

Hi there
Rather than a separate toolbar it's on - at least it is on mine --on the Taskbar. Click the language displayed and the other options get shown -- in my case I click on ISL and you see I also have UK and US input languages available.

You can't actually CHANGE the display language "In flight" -- you have to re-start the computer again. Note also for Display Languages you have to have either Windows 8 PRO or Windows 8 ENTERPRISE -- which IMO seems crazy -- most people in large businesses will understand (usually English if the business is an international company) and whatever the local Language is.

Having different display languages IMO is far more useful for HOME users. But that's Ms.

Cheers
jimbo
Yes that is what you get by default.. language preferences menu or whatever its called with large touch oriented buttons.
I know you can not change display language on the fly.. and I have pro version so that is not concern to me.
BUT I DO NOT want to change my display language just keyboard input language. And I want windows 7 style toolbar (you can dock it on task bar but more to the left than default windows 8 style menu). it is available but doesn't load at the start even thought I have enabled it in settings (look at the pictures) it loads only after changing input language with keyboard short cut
 

Attachments

Last edited:

My Computer

System One

  • OS
    Windows 7 uiltimate, Windows 8.1 pro 64bit, Windows server 2008R2, Windows 10 TP
    Computer type
    PC/Desktop

Baidukun

Member
Member
Posts
69
#5
It is available in classic windows 7 style and default windows 8 style. I want windows 7 style selection... and it works, but doesn't load when windows start, only after changing language with keyboard short cut it will appear.
here is comparison on same pc.
some people had this problem in windows 7 and running ctfmon.exe would fix it.. but I wasn't able to do that in windows 8.
 

Attachments

My Computer

System One

  • OS
    Windows 7 uiltimate, Windows 8.1 pro 64bit, Windows server 2008R2, Windows 10 TP
    Computer type
    PC/Desktop

jimbo45

New Member
VIP Member
Guru
Hafnarfjörður IS

Posts
4,373
#7

My Computer

System One

  • OS
    Linux Centos 7, W8.1, W7, W2K3 Server W10
    Computer type
    PC/Desktop
    Monitor(s) Displays
    1 X LG 40 inch TV
    Hard Drives
    SSD's * 3 (Samsung 840 series) 250 GB
    2 X 3 TB sata
    5 X 1 TB sata
    Internet Speed
    0.12 GB/s (120Mb/s)

Baidukun

Member
Member
Posts
69
#8
That is really strange if I select use desktop language bar I get language bar just like in windows 7 not the new one.. (windows 7 style bar look at first screen shot posted in #5 and windows 8 style is second screen shot, both screen shots is from same pc)
that is different from the screen shot posted by davehc.
strange..

davehc in your screen shot I can see save button active (in my system save is not active if no changes are made) did you clicked save and still got same result?

My settings (same as davehc only different languages) and result is different note save and apply is inactive because its current setting.

Here I post language bar floating on desktop and docked and help topic about language bar. its like windows 7/vista etc. language bar, not new windows 8 thing (that is not language bar)
 

Attachments

Last edited:

My Computer

System One

  • OS
    Windows 7 uiltimate, Windows 8.1 pro 64bit, Windows server 2008R2, Windows 10 TP
    Computer type
    PC/Desktop

Users Who Are Viewing This Thread (Users: 0, Guests: 1)