What's new

Solved Keyboard layout?

brummyfan

Well-Known Member
VIP Member
Guru
How do I change the keyboard layout to UK layout? I have to use " key for @ and vice versa at the moment. Thanks.
 

My Computer

System One

  • OS
    Win 8.1
    Computer type
    Laptop
    System Manufacturer/Model
    Acer Aspire E1-571
    Gender
    Male
    CPU
    i5-3230m
    Motherboard
    Acer Type-2
    Memory
    8GB DDR3 1333MHz
    Graphics Card(s)
    Intel HD 4000
    Sound Card
    High Definiton Audio Device
    Monitor(s) Displays
    Generic
    Screen Resolution
    1366x768
    Hard Drives
    Samsung 850 Pro 256GB
    PSU
    Generic
    Occupation
    Retired
    Keyboard
    QWERTY
    Mouse
    ELANTECH Touchpad
    Internet Speed
    12.68Mbps
    Browser
    IE11
    Antivirus
    Windows Defender
    Country Flag
    UK
    State/Region Flag
    uk england

Kari

Old geek, new tricks
Team Member
VIP Member
Pro User
irst, seems we are doing this differently. I do not select Japanese > Add input language to add other keyboard layouts as it only shows Japanese like in your system. I do it in this windows selecting Add a language:

JPN_3.PNG

After that it is very simple. I select which input language (English, Finnish, German, Japanese) and if Japanese, the other switch to toggle between the Japanese and Latin characters.

Remember that English (UK), English (US) and English (US International) are three different layouts with some characters in different places.

Kari
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Name
    Kari The Finn
    Computer type
    Laptop
    System Manufacturer/Model
    HP ENVY 17-1150eg
    CPU
    1.6 GHz Intel Core i7-720QM Processor
    Memory
    6 GB
    Graphics Card(s)
    ATI Mobility Radeon HD 5850 Graphics
    Sound Card
    Beats sound system with integrated subwoofer
    Monitor(s) Displays
    17" laptop display, 22" LED and 32" Full HD TV through HDMI
    Screen Resolution
    1600*900 (1), 1920*1080 (2&3)
    Hard Drives
    Internal: 2 x 500 GB SATA Hard Disk Drive 7200 rpm
    External: 2TB for backups, 3TB USB3 network drive for media
    Occupation
    Back from retirement, IT consultant
    Cooling
    As Envy runs a bit warm, I have it on a Cooler Master pad
    Keyboard
    Logitech diNovo Media Desktop Laser (bluetooth)
    Mouse
    Logitech MX1000 Laser (Bluetooth)
    Internet Speed
    50 MB VDSL
    Browser
    Maxthon 3.5.2., IE11
    Antivirus
    Windows Defender 4.3.9431.0
    Other Info
    Windows in English, additional user accounts in Finnish, German and Swedish.
    Country Flag
    Finland
    State/Region Flag
    de saxony

greenzone758

Member
Member
I did the same thing here
IME2.png
That's why I was curious to know that if in your system, without changing to EN-UK or Finnish layout, you could get an ["] after pressing shift +2, which is the opposite I'm trying to do here.

Maybe I need to give a little more information here. The toggle switch is not the issue here.
While typing Japanese characters, I need to get an [@] after pressing shift +2.
That"s why I'm trying to add a different keyboard layout "under" the Japanese IME, which I was able to do on windows XP and probably Vista and 7, but I can"t test wright now.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    PC/Desktop
    CPU
    AMD FX-8350

Kari

Old geek, new tricks
Team Member
VIP Member
Pro User
When using Japanese Display and Input Languages if I click toggle (Japanese / Latin characters) shown in these screenshots,

20880d1366841207-keyboard-layout-japanese1.png 20881d1366841207-keyboard-layout-japanese2.png

... I get " or @ depending on which input language was last selected on that other switch. If I had English (UK) selected I get now ", if English (US) selected I get @.

This character then "remains" there so switching back to Japanese IME keyboard I get " or @ depending on which Latin set I had used prior to switching to Japanese.

Kari
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Name
    Kari The Finn
    Computer type
    Laptop
    System Manufacturer/Model
    HP ENVY 17-1150eg
    CPU
    1.6 GHz Intel Core i7-720QM Processor
    Memory
    6 GB
    Graphics Card(s)
    ATI Mobility Radeon HD 5850 Graphics
    Sound Card
    Beats sound system with integrated subwoofer
    Monitor(s) Displays
    17" laptop display, 22" LED and 32" Full HD TV through HDMI
    Screen Resolution
    1600*900 (1), 1920*1080 (2&3)
    Hard Drives
    Internal: 2 x 500 GB SATA Hard Disk Drive 7200 rpm
    External: 2TB for backups, 3TB USB3 network drive for media
    Occupation
    Back from retirement, IT consultant
    Cooling
    As Envy runs a bit warm, I have it on a Cooler Master pad
    Keyboard
    Logitech diNovo Media Desktop Laser (bluetooth)
    Mouse
    Logitech MX1000 Laser (Bluetooth)
    Internet Speed
    50 MB VDSL
    Browser
    Maxthon 3.5.2., IE11
    Antivirus
    Windows Defender 4.3.9431.0
    Other Info
    Windows in English, additional user accounts in Finnish, German and Swedish.
    Country Flag
    Finland
    State/Region Flag
    de saxony

greenzone758

Member
Member
Ok, but that is also not right, because since you probably have a [@] printed above the number 2 on your "physical keyboard", the ideal setting is that you always get a [@] after pressing shift + 2.

Lets say that you buy a Japanese keyboard with a ["] printed above the number 2. So now you need to change your system to always get a ["] after pressing shift + 2 instead of [@].
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    PC/Desktop
    CPU
    AMD FX-8350

Kari

Old geek, new tricks
Team Member
VIP Member
Pro User
Now I have to disagree with you, quite strongly.

The printed symbols on the physical keyboard have and also should have any significance only when you use the computer in the language of the country where you bought it, the language and market that PC was made for.

I try to clarify: Most of the time I am using Finnish as the Input Language, with Finnish keyboard layout, on my Windows PC with English as Display Language. Reason for this is simple: from the 4 languages I need to type on daily basis, I can do Finnish, Swedish and English using the same Finnish layout. I only need to swap to German for two letters, the double s "ß" and Ü which in German often substitutes the Y.

I buy my computers in Germany where I live. This means that the physical layout (what's printed on keys) on for instance this laptop I am using now is German, QWERTZ instead of QWERTY. I need to remember and luckily I do that the Z key gives me Y, the Y key gives Z, my Finnish and Swedish Å comes from a key which has German Ü, the @ sign is printed on the Q key as you press ALT Gr + Q to get it using German layout but I get it by ALT Gr + 2 and so on.

One of the first things a multilingual PC user has to learn is how to get certain characters from "wrong" keys. And, of course, accept this as a fact.

To achieve what you are saying, the only possibility for me would be to buy different external keyboards for German, English (US), English (UK), Finnish and Swedish and then change the physical keyboard each time I change the input language.

Kari
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Name
    Kari The Finn
    Computer type
    Laptop
    System Manufacturer/Model
    HP ENVY 17-1150eg
    CPU
    1.6 GHz Intel Core i7-720QM Processor
    Memory
    6 GB
    Graphics Card(s)
    ATI Mobility Radeon HD 5850 Graphics
    Sound Card
    Beats sound system with integrated subwoofer
    Monitor(s) Displays
    17" laptop display, 22" LED and 32" Full HD TV through HDMI
    Screen Resolution
    1600*900 (1), 1920*1080 (2&3)
    Hard Drives
    Internal: 2 x 500 GB SATA Hard Disk Drive 7200 rpm
    External: 2TB for backups, 3TB USB3 network drive for media
    Occupation
    Back from retirement, IT consultant
    Cooling
    As Envy runs a bit warm, I have it on a Cooler Master pad
    Keyboard
    Logitech diNovo Media Desktop Laser (bluetooth)
    Mouse
    Logitech MX1000 Laser (Bluetooth)
    Internet Speed
    50 MB VDSL
    Browser
    Maxthon 3.5.2., IE11
    Antivirus
    Windows Defender 4.3.9431.0
    Other Info
    Windows in English, additional user accounts in Finnish, German and Swedish.
    Country Flag
    Finland
    State/Region Flag
    de saxony

greenzone758

Member
Member
Issue Solved

Ok, I made the wrong assumption that you had an English US keyboard connected to your PC. My mistake.

And I totally understand your comments regarding the differences between each local keyboard variant.
My native language is Portuguese actually, and I used to do a lot of typing in Spanish and also French.
So I understand the problems you encounter when you need to type accented letters and you don't have them printed on your keyboard. There was a time when I had a French AZERT keyboard connected to my PC, just for fun.
If I need to type in Portuguese now, I just select Portuguese as the input language and ignore the printed letters on my physical keyboard.

But my issue now was something completely different.
Japanese language doesn't have accents the same way European languages do. So as long as your keyboard has all the usual 26 Latin characters, you should be OK.
Some PCs and Macs here in Japan are sold with and English US keyboard, correctly configured of course, so when you type you get the exact the same character that is printed on your keyboard.
And changing my keyboard layout to English US while still being able to type in Japanese is nothing new to me. I do that all the time with my Macs and Linux boxes. And as far as I can remember, I used to do the same thing on my windows XP (I skipped Vista and windows 7). So naturally I thought I was going to be able to do the same thing on my new windows 8. Big mistake.

I found two solutions to my problem on the internet. Both worked fine.
The first one, as I mentioned before, was to change some values on the registry.
the second solution is:
1. Control Panel
2. Device Manager
3. Keyboards
4. Driver
5. Update driver
6. Browse my computer for driver software
7. Let me pick from a list of device drivers on my computer
8. uncheck "Show compatible hardware"
9. under "Model", I selected "Standard PS keyboard", but I believe other models should work too.

So now I have my system configured to Japanese Input, with an English keyboard layout, meaning when I type, I get the exact the same characters as printed on my keyboard.
My problem was specific to the combination Japanese input/English keyboard, and of course doesn't apply to other languages.

Hope I didn't bore you to death with all this and thank you for all the help.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    PC/Desktop
    CPU
    AMD FX-8350

XweAponX

New Member
VIP Member
Pro User
I'm sure I'll come across all of the scenarios from this thread at some time or other, so it's no boredom at all! That last solution should work fine for a multitude of problems. Usually I only deal with Spanish and English Dual Language systems which can use the same keyboard. Once I had to install Hebrew, that was a pain, I actually had to LEARN it a little just to be able to move around.
 

My Computer

System One

  • OS
    Windows 8 Pro with Media Center/Windows 7
    Name
    Jon William Vitas
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Asus M2N-MX SE Plus § DualCore AMD Athlon 64 X2, 2300 MHz (11.5 x 200) 4400+ § Corsair Value Select
    CPU
    AMD 4400+/4200+
    Motherboard
    Asus M2N-MX SE Plus/Asus A8M2N-LA (NodusM)
    Memory
    2 GB/3GB
    Graphics Card(s)
    GeForce 8400 GS/GeForce 210
    Sound Card
    nVIDIA GT218 - High Definition Audio Controller
    Monitor(s) Displays
    Hitachi 40" LCD HDTV
    Screen Resolution
    "1842 x 1036"
    Hard Drives
    WDC WD50 00AAKS-007AA SCSI Disk Device
    ST1000DL 002-9TT153 SCSI Disk Device
    WDC WD3200AAJB-00J3A0 ATA Device
    WDC WD32 WD-WCAPZ2942630 USB Device
    WD My Book 1140 USB Device
    PSU
    Works 550w
    Occupation
    Retired
    Case
    MSI "M-Box"
    Cooling
    Water Cooled
    Keyboard
    Dell Keyboard
    Mouse
    Microsoft Intellimouse
    Internet Speed
    Cable Medium Speed
    Browser
    Chrome/IE 10
    Antivirus
    Eset NOD32 6.x/Win Defend
    Other Info
    Recently lost my Windows 8 on my main PC, had to go back to Windows 7.
    Country Flag
    USA
    State/Region Flag
    us california

tomuo

New Member
Registered to say thanks for the info in this thread. I have US English Win 8, but a Japanese layout keyboard, and was having the same problems.

The registry change noted only solved half the problem for me, that let the keyboard work correctly in IME mode, but not when typing English natively.

The final trick came from another thread I found in Japanese - if the computer has a ACPI BIOS with Fast Boot set to ON, it basically hard codes the USB Keyboard to be a 101 layout, and no amount of overriding it in the registry works.
Turning Fast Boot to OFF lets the OS see the keyboard directly, and it correctly identifies the layout and type.
Finally I have the " and @ where I need them.

Windows 8

Note for reference : on my work machine, the "@" key did nothing - there was a shortcut to flipping the language that was set to "grave" key, which is on the "@" key. Resetting that setting cleared that up. Didn't need to do that for this home computer.

Tom.
 

My Computer

System One

  • OS
    Win 8 Pro
    Computer type
    PC/Desktop
    CPU
    Intel i5

aliakber

New Member
Hope This Helps

How do I change the keyboard layout to UK layout? I have to use " key for @ and vice versa at the moment. Thanks
I went to the language settings in the control panel where Change your language preferences are mentioned, and removed all the Languages from it,The default Keyboard layout was English (United Kingdom), then Enabled in the keyboard layout English (India).

It worked for me
 

My Computer

System One

  • OS
    WINDOWS 8.4
    Computer type
    PC/Desktop

timtak

New Member
Just use PC Settings, its right down there at the right hand corner: Because I use UK Language but US Keyboard. That was one of the first things I had to tackle, I had installed UK language, it gave me UK Keyboard, I had restart the install and choose the US kb.

View attachment 20803
Thank you! Now my keyboard settings match the markings on my Japanese keyboard. Shift 2 gives " and the @ key prints an @! It was driving me around the bend.

By the way, to others with this problem, one can get to the "PC Settings" by Windows Key C > Settings
 

My Computer

System One

  • OS
    windows 8
    Computer type
    Laptop
    System Manufacturer/Model
    Panny Let&
    CPU
    core i5
    Country Flag
    Japan

timtak

New Member
Oh dear. My keyboard died. I connected another keyboard and again my Japanese keyboard seems to being recognised as an English keyboard so that the things printed on my keyboard (and my typing skills) do not match the characters that are produced. E.g. shift 2 produces an @ mark rather than the expected quotation mark.

I googled my nickname and Japanese keyboard, found this thread, found how I had solved the issue in the past, just press Windows Key plus C, settings, keyboard, and Japanese keyboard, but this time nothing has changed. Do I need to reboot?
 

My Computer

System One

  • OS
    windows 8
    Computer type
    Laptop
    System Manufacturer/Model
    Panny Let&
    CPU
    core i5
    Country Flag
    Japan

timtak

New Member
Rebooting did not work but changing the "ENG" in the taskbar (the bar that is usually along the bottom of the screen in windows) to "Japnaese Microsoft IME" did. Phew.
 

My Computer

System One

  • OS
    windows 8
    Computer type
    Laptop
    System Manufacturer/Model
    Panny Let&
    CPU
    core i5
    Country Flag
    Japan

timtak

New Member
Oh dear! I unplugged and replugged my keyboard and the same problem appears.

Now I have set the language to Japanese in the task bar and also the keyboard to Japanese in settings,
Windows C Settings Japanese IME, and it seems that these two settings are the same since changing one affects the other.

Nonetheless I am still getting an ampersand sing for shift 7 when it should be a an apostrophe. I am at a loss what to do. I can&t type in this situation!
 
Last edited:

My Computer

System One

  • OS
    windows 8
    Computer type
    Laptop
    System Manufacturer/Model
    Panny Let&
    CPU
    core i5
    Country Flag
    Japan

timtak

New Member
I have worked out why the problem is intermittent.

If I start up Windows 8 (which I have in English display mode) and use my Japanese keyboard, then
windows assumes that the keyboard is an English keyboard, and changing to Japanese will not change
this assumption.

But if I start up Windows and immediately change the language to Japanese (from any of the places
than one can do either the task bar icon or Windows Key plus C, settings, keyboard, and Japanese keyboard,
then windows assumes the keyboard is Japanese, and all is well.

VERY annoying
 
Last edited:

My Computer

System One

  • OS
    windows 8
    Computer type
    Laptop
    System Manufacturer/Model
    Panny Let&
    CPU
    core i5
    Country Flag
    Japan

timtak

New Member
I would like to set the default input language to Japanes

I would like therefore to change the default input language to Japanese, or set up a task to change it to Japanese immediately on boot, since I keep forgetting to do so, Windows assumes I am using an English keyboard and I am stymied till I reboot.

In control panel > language there does not seem to be a way of leaving the display language as English (I am an English speaker) while changing the keyboard input language to Japanese (since my keyboard is Japanese, and I write Japanese too). They seem to move in tandem. I want a default display language of English but a default keyboard language as Japanese.

It was explained here by an or the Administrator, Brink, that one can use the advanced settings in the control panel language list to override the input language of the default display language such that the display language is English but the default input language is now overridden to Japanese to match my keyboard on boot.
Input Method - Set Default Language in Windows 8

By the way, when I paste into these forums on Firefox the pasted text is not displayed until I post.
 
Last edited:

My Computer

System One

  • OS
    windows 8
    Computer type
    Laptop
    System Manufacturer/Model
    Panny Let&
    CPU
    core i5
    Country Flag
    Japan

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top