• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Java not working in x64 Windows 8 Pro


Burgurne

Member
Member
Denmark

Posts
222
#1
Newinstalled (clean install) Windows 8 Pro x64.
Installed x86 and x64 versions of java. After install reboot the PC. Can't complete the "do I have java"-test on Verify Java Version

On this test How do I test whether Java is working on my computer? I get an error saying "Error. Click for details", and when I do, there opens a little window with this text:

ClassNotFoundException

I then click on "Details", and this pops up

Java Plug-in 10.9.2.05
Using JRE version 1.7.0_09-b05 Java HotSpot(TM) Client VM
User home directory = C:\Users\<my name>
----------------------------------------------------
c: clear console window
f: finalize objects on finalization queue
g: garbage collect
h: display this help message
l: dump classloader list
m: print memory usage
o: trigger logging
q: hide console
r: reload policy configuration
s: dump system and deployment properties
t: dump thread list
v: dump thread stack
x: clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------

I have looked in Control Panel, and there is a Java plugin there. Can't find any errors in this, but I don't know what I am looking after :eek:. I have checked the "java"tab and clicked on "view" to see both "user" and "system" is enabled, and they are. What more can be checked?

It is the same error nomatter if I use IE10 or Chrome-browser (both in desktop-mode).

I _need_ java for my home banking system, so please help :cry:

EDIT: I have found this thread http://www.eightforums.com/software-apps/10507-java-not-working-windows-8-a.html about same problem as mine. I'm not the only one it seems.​
 

My Computer

System One

  • OS
    Windows 8.1 64bit Pro
    Computer type
    PC/Desktop
    CPU
    Intel Core i5 3570K @4,4Ghz
    Motherboard
    MSI Z77A GD65
    Memory
    16Gbyte DDR3 1866Mhz
    Graphics Card(s)
    GTX770 lightning
    Sound Card
    Auzentech X-Fi Forte 7.1
    Monitor(s) Displays
    BenQ BL2411
    Screen Resolution
    1920*1200
    Hard Drives
    Samsung 840EVO 240Gbyte, Samsung 830 256Gbyte SSD, Seagate 4TB , Western Digital black edition 1,5Tbyte
    PSU
    Zalman ZM850 HP
    Case
    Corsair Carbide 500R
    Cooling
    air
    Keyboard
    Logitech G15
    Mouse
    Logitech G5
    Internet Speed
    60/60mbit fiber
    Browser
    Chrome
    Antivirus
    BitDefender total security

Burgurne

Member
Member
Denmark

Posts
222
#2
OK, I now is somewhat closer to the problem.
It seems it is KIS 2013 that is the problem. If I deactivate it, java runs fine. If I only activate 1 of KIS secure-settings java runs fine, but if 2 or more secure-settings are active, java is blocked. Maybe I have to go to Kaspersky to get the solution? Or is here a clever "Kaspersky"-supporter that can do the magic?
 

My Computer

System One

  • OS
    Windows 8.1 64bit Pro
    Computer type
    PC/Desktop
    CPU
    Intel Core i5 3570K @4,4Ghz
    Motherboard
    MSI Z77A GD65
    Memory
    16Gbyte DDR3 1866Mhz
    Graphics Card(s)
    GTX770 lightning
    Sound Card
    Auzentech X-Fi Forte 7.1
    Monitor(s) Displays
    BenQ BL2411
    Screen Resolution
    1920*1200
    Hard Drives
    Samsung 840EVO 240Gbyte, Samsung 830 256Gbyte SSD, Seagate 4TB , Western Digital black edition 1,5Tbyte
    PSU
    Zalman ZM850 HP
    Case
    Corsair Carbide 500R
    Cooling
    air
    Keyboard
    Logitech G15
    Mouse
    Logitech G5
    Internet Speed
    60/60mbit fiber
    Browser
    Chrome
    Antivirus
    BitDefender total security

R0bR

New Member
Member
Posts
534
#3
In your Kaspersky settings you have the ability to exclude programs or even directories, I no longer have KIS 2013 installed to screen cap it for you but this should help:

How to manage exclusion rules in Kaspersky Internet Security?

Don't bother with the "Threat Type" from their example, just check Object and use the path example by pointing to where your Java is installed and include subfolders. You can also try the Trusted Applications by choosing the main java runtime file but the folder method is usually easier. Also, don't forget to choose which protection components you want to exclude them from.
 

My Computer

System One

  • OS
    Windows 7, Windows 8 RP

akacross

New Member
Posts
2
#4
I know this is a old topic but i need help, i am having the same problem with my KIS 2013 blocking Java

I've noticed that VNCViewer does not load, Minecraft will work fine, Spoutcraft won't launch.

But if i disable Kaspersky, java will load everything fine!
 

My Computer

System One

  • OS
    Windows 8 Pro 64-bit (6.2, Build 9200) (9200.win8_gdr.121119-1606)
    System Manufacturer/Model
    Custom Built
    CPU
    AMD Phenom(tm) II X4 965 Processor (4 CPUs), ~3.4GHz
    Motherboard
    MSI K9N2 SLI Platinum
    Memory
    OCZ SLI Edition DDR2 8192MB RAM (4 x 2GB)
    Graphics Card(s)
    NVIDIA GeForce GTX 275 OC
    Sound Card
    Realtek High Definition Audio/SB Live! 24-bit
    Monitor(s) Displays
    Gateway HD2201 22in HDMI
    Screen Resolution
    1680x1050
    Hard Drives
    Seagate Barracuda ST1000DM003 1TB/Seagate Barracuda ST3750640AS 750GB
    PSU
    Cooler Master HAF 932 Full Tower Black Case
    Case
    Ultra 700watt PSU
    Cooling
    Air Cooling
    Internet Speed
    10mbits

cicmildjordje

Member
Member
Posts
18
#5
Open kaspersky settings/application control then click on Application and find Oracle America folder in Trusted folder. Open every file with double click, choose exclusions and check "do not scen network traffic".
 

My Computer

System One

  • OS
    Windows 8

akacross

New Member
Posts
2
#6
Open kaspersky settings/application control then click on Application and find Oracle America folder in Trusted folder. Open every file with double click, choose exclusions and check "do not scen network traffic".
Thank you!!!! its working now!
 

My Computer

System One

  • OS
    Windows 8 Pro 64-bit (6.2, Build 9200) (9200.win8_gdr.121119-1606)
    System Manufacturer/Model
    Custom Built
    CPU
    AMD Phenom(tm) II X4 965 Processor (4 CPUs), ~3.4GHz
    Motherboard
    MSI K9N2 SLI Platinum
    Memory
    OCZ SLI Edition DDR2 8192MB RAM (4 x 2GB)
    Graphics Card(s)
    NVIDIA GeForce GTX 275 OC
    Sound Card
    Realtek High Definition Audio/SB Live! 24-bit
    Monitor(s) Displays
    Gateway HD2201 22in HDMI
    Screen Resolution
    1680x1050
    Hard Drives
    Seagate Barracuda ST1000DM003 1TB/Seagate Barracuda ST3750640AS 750GB
    PSU
    Cooler Master HAF 932 Full Tower Black Case
    Case
    Ultra 700watt PSU
    Cooling
    Air Cooling
    Internet Speed
    10mbits

Grafula

New Member
Posts
1
#7
Open kaspersky settings/application control then click on Application and find Oracle America folder in Trusted folder. Open every file with double click, choose exclusions and check "do not scen network traffic".
Thank you very much. This did it.

Actually you only have to disable scan for all Java(TM) Platform SE Binaries.
 

My Computer

System One

  • OS
    Win 8 Pro 64bit
    CPU
    Duo T9400
    Memory
    4GB
    Graphics Card(s)
    Nvidia GeForce 9800m 512MB
    Monitor(s) Displays
    LED (Laptop)
    Screen Resolution
    1680 x 1050
    Hard Drives
    2 x 500 GB
    Internet Speed
    Could be better... :)

Users Who Are Viewing This Thread (Users: 0, Guests: 1)