• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

iTunes Issues


Legind

New Member
Posts
1
#1
Apparently, my iTunes has been acting up since I installed windows 8. Whenever I open it up, I try to play a song and it pauses for 5 minutes, and then after the 5 minutes it plays the song finally. the program itself isn't in "Not Responding" mode, but the program just freezes whenever I attempt to play a song. Anyone else have this problem?
 

My Computer

System One

  • OS
    Windows 8

Cluster

New Member
Posts
9
#2
This happens to me too in iTunes. I find it happens in Windows Media Player at the same time but if you open the song you're trying to listen to in foobar2000 or Media Player Classic playback in iTunes will unlock and resume normally. I've done my best to diagnose it and I'm running a blank. I've tried changing/updating drivers (between Microsoft's and Realtek's - doesn't make a difference), re-registering the iTunes COM interface, uninstalling and reinstalling iTunes, disabling exclusive control, disabling all sound enhancements, etc. Nothing works but there's the workaround to make it work again. I don't believe it's iTunes-specific either, I think it's some kind of Windows 8 bug because it happens with Windows Media Player too.

Real weird issue.
 
Last edited:

My Computer

System One

  • OS
    Windows 8 Consumer Preview
#3
I haven't experienced this yet. iTunes seems to be doing as well in Win8 for me as it was in XP.
 

My Computer

System One

  • OS
    Win8 Consumer Preview
    System Manufacturer/Model
    Toshiba Satellite A105-S4397
    CPU
    Intel Centrino Duo 1.73 GHz T2250 2MB L2, 533MHz FSB
    Motherboard
    Mobile Intel 945GM Express
    Memory
    4GB PC4200
    Graphics Card(s)
    Intel GMA 950
    Sound Card
    On-board
    Monitor(s) Displays
    15.4" built-in
    Screen Resolution
    1280x800
    Hard Drives
    160GB 5400RPM Hitachi
    PSU
    [email protected] or 12VDC at 6600MaH Li
    Case
    Plastic
    Cooling
    Smallest fan on the planet
    Keyboard
    Querty Eng/German
    Mouse
    Yes, but I've set traps
    Internet Speed
    10M
    Other Info
    Clean install from a corrupted and virus laden Vista original factory install on this ancient laptop.

    Runs like it was at Indy!

Cluster

New Member
Posts
9
#4
I'm guessing it's something to do with the Windows 8 audio mixer. If you play a song in iTunes then play a YouTube video or something the issue will happen.
 

My Computer

System One

  • OS
    Windows 8 Consumer Preview
#5
I don't see where anyone reported a problem connecting to the iTunes store.
 

My Computer

System One

  • OS
    Win8 Consumer Preview
    System Manufacturer/Model
    Toshiba Satellite A105-S4397
    CPU
    Intel Centrino Duo 1.73 GHz T2250 2MB L2, 533MHz FSB
    Motherboard
    Mobile Intel 945GM Express
    Memory
    4GB PC4200
    Graphics Card(s)
    Intel GMA 950
    Sound Card
    On-board
    Monitor(s) Displays
    15.4" built-in
    Screen Resolution
    1280x800
    Hard Drives
    160GB 5400RPM Hitachi
    PSU
    [email protected] or 12VDC at 6600MaH Li
    Case
    Plastic
    Cooling
    Smallest fan on the planet
    Keyboard
    Querty Eng/German
    Mouse
    Yes, but I've set traps
    Internet Speed
    10M
    Other Info
    Clean install from a corrupted and virus laden Vista original factory install on this ancient laptop.

    Runs like it was at Indy!

rjcola27

New Member
Posts
5
#6
I'm having the same problem. Click on a song or album to play and there is no response. Itunes is not locked up but the song will not play. If I click on the hard drive that contains the music I'm trying to listen to, the song will start right away. I do remember that this did not happen when I first installed Windows 8. However, I did install the latest version of iTunes a couple of days ago (10.6) and maybe the latest version of iTunes is part of this problem.
 

My Computer

System One

  • OS
    Windows 8 Consumer Preview
#9
Mine now too is doing the same as everyone elses. iTunes will play music if started and advance to the next song, but if stopped, it takes minutes to restart.

Could this be some sort of a buffer issue??
 

My Computer

System One

  • OS
    Win8 Consumer Preview
    System Manufacturer/Model
    Toshiba Satellite A105-S4397
    CPU
    Intel Centrino Duo 1.73 GHz T2250 2MB L2, 533MHz FSB
    Motherboard
    Mobile Intel 945GM Express
    Memory
    4GB PC4200
    Graphics Card(s)
    Intel GMA 950
    Sound Card
    On-board
    Monitor(s) Displays
    15.4" built-in
    Screen Resolution
    1280x800
    Hard Drives
    160GB 5400RPM Hitachi
    PSU
    [email protected] or 12VDC at 6600MaH Li
    Case
    Plastic
    Cooling
    Smallest fan on the planet
    Keyboard
    Querty Eng/German
    Mouse
    Yes, but I've set traps
    Internet Speed
    10M
    Other Info
    Clean install from a corrupted and virus laden Vista original factory install on this ancient laptop.

    Runs like it was at Indy!
Posts
1,851
#10
I don't have or use iTunes but I can offer something that might cause this. If you have any network drives mapped that are currently not available, such as to a laptop offline or a desktop that is powered off, this could be a reason.

Another thing to try is to completely disable UAC then reboot to test it.
 

My Computer

System One

  • OS
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86
    CPU
    P4 3.4 GHz HT
    Motherboard
    MSI-7211
    Memory
    OCZ 2 GB DDR @ 400 MHz
    Graphics Card(s)
    HIS AGP HD 3850 Turbo Ice-Q
    Sound Card
    MOTU Traveler firewire interface
    Monitor(s) Displays
    Acer x223w
    Screen Resolution
    1680x1050
    Hard Drives
    WD Caviar Black 1 TB Sata II, WD 400 GB Sata I, WD 120 GB Sata I
    PSU
    300W generic
    Case
    Cybertron
    Keyboard
    Logitech Classic Keyboard 200, Dell RT7D20
    Mouse
    Logitech M510
    Internet Speed
    2 MByte/sec Down, 250 KByte/sec Up

Cluster

New Member
Posts
9
#11
Nope, I don't have network drives but just in case I've disabled network discovery and file sharing. We'll see what happens but I suspect it might not make any difference.

Regarding UAC, I've tried it on the normal setting, on the don't notify setting and completely disabled via the registry and it still does it. Also does it regardless of SmartScreen setting as well.

I can reproduce it easily. Play a song in iTunes normally, then watch a YouTube video then try to play a song in iTunes again.
 

My Computer

System One

  • OS
    Windows 8 Consumer Preview
Posts
1,851
#12
Does iTunes have the ability to select the output device on the system to use? If so, do not let it stay as default device. Actually choose the output device manually. For example, if you have Realtek HD Audio controller, choose that as opposed to default device.

I dunno. Another one of my "can't hurt to try but unlikely to help" suggestions. lol
 

My Computer

System One

  • OS
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86
    CPU
    P4 3.4 GHz HT
    Motherboard
    MSI-7211
    Memory
    OCZ 2 GB DDR @ 400 MHz
    Graphics Card(s)
    HIS AGP HD 3850 Turbo Ice-Q
    Sound Card
    MOTU Traveler firewire interface
    Monitor(s) Displays
    Acer x223w
    Screen Resolution
    1680x1050
    Hard Drives
    WD Caviar Black 1 TB Sata II, WD 400 GB Sata I, WD 120 GB Sata I
    PSU
    300W generic
    Case
    Cybertron
    Keyboard
    Logitech Classic Keyboard 200, Dell RT7D20
    Mouse
    Logitech M510
    Internet Speed
    2 MByte/sec Down, 250 KByte/sec Up

Cluster

New Member
Posts
9
#13
I'm pondering something. Is anyone else with this issue using the AMD Catalyst drivers for the Windows 8 Consumer Preview too?

EDIT: Nevermind, tried without the drivers installed and other drivers and no-go.
 
Last edited:

My Computer

System One

  • OS
    Windows 8 Consumer Preview

rsmithlal

New Member
Posts
6
#14
I have the same issue actually. Whenever I pause itunes for an extended period and press play, the audio just won't work. Itunes is not frozen: I can skip songs and it skips, but still will not play. However, I found that causing any sound to play will unlock itunes and start it working again. That means a youtube video, google play, VLC or even testing a sound in the sounds tab of the audio properties panel (Right click on the speaker icon, sounds). Its weird, ANY sound will unlock itunes.
 

My Computer

System One

  • OS
    Windows 8 CP x86 and x64
    CPU
    AMD Phenom 2 2.4gHz Quad
    Memory
    8GB
    Graphics Card(s)
    AMD radeon 3300 integrated

Cluster

New Member
Posts
9
#15
Well, I'm starting to lean towards it being indeed an iTunes issue at this point. We should report this on Apple's community in the iTunes for Windows section. Maybe they'll fix it?
 

My Computer

System One

  • OS
    Windows 8 Consumer Preview

rsmithlal

New Member
Posts
6
#16
Well, I'm starting to lean towards it being indeed an iTunes issue at this point. We should report this on Apple's community in the iTunes for Windows section. Maybe they'll fix it?
Yeah that's a good idea, we should all report it. Can you link us to the page?
 

My Computer

System One

  • OS
    Windows 8 CP x86 and x64
    CPU
    AMD Phenom 2 2.4gHz Quad
    Memory
    8GB
    Graphics Card(s)
    AMD radeon 3300 integrated

Users Who Are Viewing This Thread (Users: 0, Guests: 1)