What's new

[Issue] Windows 8 on Dual Monitor & Gaming

illutian

Member
Member
Currently, I'm trying to play some of the various games I have. One in particular is Ghost Recon: Future Soldier. The issue is it keeps opening up on the second monitor off to my right. Even though I have the one sitting in front of me designated the 'Primary'.

Can't run the game in windowed mode as it doesn't actually support it, even though there is a field for 'Fullscreen' in the default.cfg

Anyone else having this sort of issue?

Note: This game was installed using Steam
 

My Computer

System One

  • OS
    Windows 8.1 Pro w/ Media Center
    Computer type
    PC/Desktop

area 66

Banned
Unplug your second monitor and start the game, it will start on the primary and start there again when you re connect your second monitor
 

My Computer

System One

  • OS
    Windows 8 enterprise x64
    System Manufacturer/Model
    Pc-Quebec / Area 66
    CPU
    i7-3960X Extreme Edition
    Motherboard
    Rampage IV Extreme
    Memory
    Gskill 4x4 GB
    Graphics Card(s)
    4 x HD 7970
    Sound Card
    onboard
    Screen Resolution
    2560*1600
    Hard Drives
    C:\Intel series 520 SSD , 250 GB
    D:\ WD 750 black with Intel 40gb SSD cache Intel RST
    E:\ WD 2TB Black
    PSU
    Corsair AX 1200
    Case
    TT Mozart TX
    Cooling
    Water Cooled
    Keyboard
    Logitech G-15
    Other Info
    Windows 8 VM is install on his own SSD.

illutian

Member
Member
Did that before making this topic. The game always starts on the second monitor...so that won't work. It appears to be the only one of the 47 games that i play that does this.
 

My Computer

System One

  • OS
    Windows 8.1 Pro w/ Media Center
    Computer type
    PC/Desktop

Justin121

New Member
That's odd... I've tried to get my games to open up on my Secondary monitor (works better for me to have the main desktop open when in-game), but I've had no luck. I've tried switching them around (primary on the right, secondary on the left), and also messed with some other settings, but I haven't gotten anything to work yet.
 

My Computer

System One

  • OS
    Windows 8 Pro
    System Manufacturer/Model
    Home-Built
    CPU
    Intel i7-2700k
    Motherboard
    Asus SABERTOOTH Z77
    Memory
    16 Gb Corsair Vengeance LP (2x8GB, 2 more on the way)
    Graphics Card(s)
    2x NVidia GTX 560 Ti Fermi in SLI Configuration

illutian

Member
Member
That's odd... I've tried to get my games to open up on my Secondary monitor (works better for me to have the main desktop open when in-game), but I've had no luck. I've tried switching them around (primary on the right, secondary on the left), and also messed with some other settings, but I haven't gotten anything to work yet.


For that instance, you usually have to set the "game monitor" as the Primary monitor:
Screen Resolution [window] -> Select the monitor you want to game on -> check 'Make this my main display'

You can also try, since I see you have Windows 8, 'Project to second screen'. Tough I would recommend close all programs that you don't want their window-frames moving around (ie Winamp's player in 'bar format'). Because Windows will take your entire desktop landscape and send it to the 'second screen'.
 

My Computer

System One

  • OS
    Windows 8.1 Pro w/ Media Center
    Computer type
    PC/Desktop

dirtyvu

New Member
Power User
do you have an Nvidia card? I remember for mine, there are 2 DVI ports on the back and it actually matters which monitor is plugged into which port (and it kind of ignored the Windows settings in some situations). so i just switched the cables around.
 

My Computer

System One

  • OS
    Windows 8.1 Pro

illutian

Member
Member
do you have an Nvidia card? I remember for mine, there are 2 DVI ports on the back and it actually matters which monitor is plugged into which port (and it kind of ignored the Windows settings in some situations). so i just switched the cables around.

Twin EVGA GTX 670.
When mounted in the case the DVI-I is above the DVI-D.

As it stands now:
HDMI Port: Onkyo A/V Receiver*
DVI-I Port: HP w2207h (Main Display)
DVI-D Port: Benq G2420HDBL (Second Display)

Display Options:

Onkyo and Benq merged ( 1|3 @ 1920x1080). This was done because I had to replace my original HP w2207h due to it failing. This one appears to have older firmware and trying to run Video Card -> Onkyo -> Monitor now longer works....hopefully Newegg will have some deals on monitors around the holiday :D

As far as I know DVI-I is Port 1, and DVI-D is port 2. However, HDMI overrides Port 1...and I assume the same would be true for the DisplayPort


...FTMFL.
Ya, that's what's wrong. In Screen Resolution the list is like so:

Onkyo: Display 1
Benq: Display 3
HP: Display 2

But since I told it to merge 1 & 3....display 3 is just displaying what would be on display 1.

Questions is, this setup was like this under Windows 7 and Ghost Recon "listened" to Windows for which display was marked as 'Primary Display'. So what changed in Windows 8, that it's now listening to the hardware...and not the software.
 

My Computer

System One

  • OS
    Windows 8.1 Pro w/ Media Center
    Computer type
    PC/Desktop

dirtyvu

New Member
Power User
this behavior was in Windows 7 as well with Nvidia cards. I encountered it when I had Windows 7. Just switch the ports.

Didn't have it with my ATI card on my other PC. The ATI is truly port agnostic and totally determined by software.
 

My Computer

System One

  • OS
    Windows 8.1 Pro

illutian

Member
Member
this behavior was in Windows 7 as well with Nvidia cards. I encountered it when I had Windows 7. Just switch the ports.

Didn't have it with my ATI card on my other PC. The ATI is truly port agnostic and totally determined by software.

Nope, still shows up on the other monitor...

As I said, this didn't happen at all in Windows 7 and I'm even running the same Driver Set (306.97). It's clearly something in Windows 8.

So far I've:
-Merged Benq and Onkyo
-Merged HP and Onkyo
-Switched Cables
*Note: I can't merge HP and Benq as Windows sees the Onkyo as a display and will 'put' programs to that display....which I can't see since it doesn't have a monitor hooked to it. And if you disable it, then the audio portion is also disabled.

In all instances Ghost Recon will run only on the Benq.
 

My Computer

System One

  • OS
    Windows 8.1 Pro w/ Media Center
    Computer type
    PC/Desktop

dirtyvu

New Member
Power User
can you replace the dvi-i cable with a dvi-d cable and try again on the hp? dvi-i is a combo analog/digital cable which is because it provides support for a VGA signal (that's what allows for the vga/dvi-i gender converter) whereas dvi-d is only digital.

maybe the card/system is prioritizing the dvi-d connected monitor. just like some systems where if you plug in hdmi and component simultaneously, it'll default to the hdmi output and completely turn off the component output.
 

My Computer

System One

  • OS
    Windows 8.1 Pro

illutian

Member
Member
HP w2207h comes with a HDMI port and a VGA port. The Benq comes with a DVI port and a VGA port. And I don't have extra adapters.

...I'd really like to know what the hell Microsoft changed

I'll also ask Ubi...maybe they got a patch being worked on or something :\
 

My Computer

System One

  • OS
    Windows 8.1 Pro w/ Media Center
    Computer type
    PC/Desktop

illutian

Member
Member
HP: HDMI to DVI (adapter)
Benq: DVI to DVI (straight)
Onkyo: HDMI to HDMI (for 8 channel audio only, no video) (straight)

Surprisingly, the HP shipped with a VGA and HDMI cable. You have to remember this was back when everything was shipping with just VGA cables or no cables. So to have them provide a high-end cable...was "whooaa".

Unlike my first HP, I can't get this one to work through the Onkyo (monitor goes into sleep mode immediately). I think the firmware is older so it doesn't work with the A/V Receiver...I can't even get the Receiver's menu to come up on the HP.

*HP Model w2207h (original and replacement)

EDIT:

It appears the issue is Windows 8's "Project to second screen". The way Windows 8 handles multi-monitor setups is:
Primary: Metro UI
Rest: Desktop "UI"

This means anything that is coded, WRONGLY I MIGHT ADD, to feed its video to the desktop will display on the Desktop Monitor(s). And will completely ignore the monitor settings of "Make this my main [..]".

If I select "PC Screen Only" from Devices -> Second Screen, the game works as it should, if I have 'Extended' it will display on the Desktop Monitor with issues (mouse cursor stuck in an invisible 'fenced-in area' on the Metro Monitor).

It's annoying, but maybe as people upgrade to Win8 Ubi will get more handsome frog-complaints and fix the game.
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1 Pro w/ Media Center
    Computer type
    PC/Desktop

NightHawk13

New Member
illutin: Could you walk me through how you got it to work, I'm in the same situation. Don't understand pc screen only from devices. cant see wher that is. I'd be really gratful if you could assist. Thanks in advance
 

My Computer

System One

  • OS
    NightHawk13
    System Manufacturer/Model
    self Buld
    CPU
    i7 2600k
    Motherboard
    Asus Maximux V extreme
    Memory
    16Gb
    Graphics Card(s)
    2x gtx 680 sli

illutian

Member
Member
illutin: Could you walk me through how you got it to work, I'm in the same situation. Don't understand pc screen only from devices. cant see wher that is. I'd be really gratful if you could assist. Thanks in advance


I assume you're running Windows 8? I didn't have this issue with Windows 7 and the same hardware.

If it's happening on Windows 7, you'll have to unplug the monitor you DO NOT want the software to display on). I say unplug because the mouse cursor will be locked to the 'Primary Monitor' so duplicating the desktop isn't really an option.

Step:
1) Bring up the 'Charms Bar' (Window Key + C is the hotkey)
2) Click 'Devices'
3) You may have other devices, so look for 'Second Screen'
4) If you're running a multi-monitor setup, 'Extend' should be selected
5) Select 'PC Screen only'

This will "unplug" your other monitor through software. When you want to go back to mult-monitor format, just repeat the above but select 'Extend'.

Or you can do like with Windows 7 and physically unplug...you can't just turn it off. Windows must see that there is no monitor. So either the DVI,VGA,HDMI, or DisplayPort. Or the power plug must be pulled.

And as I said in a previous post..
[Issue] Ghost Recon and Dual Monitor | Forums
More people are now getting the issue
 

My Computer

System One

  • OS
    Windows 8.1 Pro w/ Media Center
    Computer type
    PC/Desktop

NightHawk13

New Member
illutin: Could you walk me through how you got it to work, I'm in the same situation. Don't understand pc screen only from devices. cant see wher that is. I'd be really gratful if you could assist. Thanks in advance


I assume you're running Windows 8? I didn't have this issue with Windows 7 and the same hardware.

If it's happening on Windows 7, you'll have to unplug the monitor you DO NOT want the software to display on). I say unplug because the mouse cursor will be locked to the 'Primary Monitor' so duplicating the desktop isn't really an option.

Step:
1) Bring up the 'Charms Bar' (Window Key + C is the hotkey)
2) Click 'Devices'
3) You may have other devices, so look for 'Second Screen'
4) If you're running a multi-monitor setup, 'Extend' should be selected
5) Select 'PC Screen only'

This will "unplug" your other monitor through software. When you want to go back to mult-monitor format, just repeat the above but select 'Extend'.

Or you can do like with Windows 7 and physically unplug...you can't just turn it off. Windows must see that there is no monitor. So either the DVI,VGA,HDMI, or DisplayPort. Or the power plug must be pulled.

And as I said in a previous post..
[Issue] Ghost Recon and Dual Monitor | Forums
More people are now getting the issue

thnx for that. Been following you on the ubi fotum too (stackoverflow20) trouble is like you too i have temp & other monitors on second screen plus that will screw up desktop layout. But im grateful to you for coming back & explaining
 

My Computer

System One

  • OS
    NightHawk13
    System Manufacturer/Model
    self Buld
    CPU
    i7 2600k
    Motherboard
    Asus Maximux V extreme
    Memory
    16Gb
    Graphics Card(s)
    2x gtx 680 sli

Allord

New Member
I have a slightly similar issue. I have a dual set-up, one a 23" Hanns-G on the left and the other a 20" Samsung on the right. Set up in extended mode. My problem is this: I want to play a game on monitor A (23" set as primary), and have a chrome window (such as my music site) on monitor B.

But when I open the game, it defaults to full screen (normally not a problem full screen games are fun:)) and the window on monitor B shuffles halfway off of monitor B's right hand side. when I click monitor B to retrieve the window, the game in monitor A minimizes, showing the background, and the chrome window is back where it is supposed to be. clicking the taskbar icon for the game puts the game back, but again, the chrome window is skewed. Any ideas?
 

My Computer

System One

  • OS
    Windows 8

illutian

Member
Member
I have a slightly similar issue. I have a dual set-up, one a 23" Hanns-G on the left and the other a 20" Samsung on the right. Set up in extended mode. My problem is this: I want to play a game on monitor A (23" set as primary), and have a chrome window (such as my music site) on monitor B.

But when I open the game, it defaults to full screen (normally not a problem full screen games are fun:)) and the window on monitor B shuffles halfway off of monitor B's right hand side. when I click monitor B to retrieve the window, the game in monitor A minimizes, showing the background, and the chrome window is back where it is supposed to be. clicking the taskbar icon for the game puts the game back, but again, the chrome window is skewed. Any ideas?


Sounds like the game is not detecting the native screen resolution and defaulting to a default (usually 1280x768 [or there abouts] or 1024x768).

The simply solution, if you're describing what often happens to me upon playing a freshly installed game, is to go and set the game to use the native screen resolution (these days 1920x1080). It should shift everything back into place.

Alternatively, if the game doesn't support the resolution you run is to run it Windowed. I have to do this with Dishonoured because I don't trust games running in Fullscreen...far to often in the past I would have to do a hard reboot because the game locked up and I couldn't get to Task Manager (Win XP era). So now I just Window the games..most have Borderless/Maximized.

But some games, like Dishonoured, do not support Borderless/Maximized so at 1680x1050 (Windowed) I get a lovely Windows program border (minimize, maximize, close buttons) that shifts the game down so that part of the UI is 'off screen'. With those I usually run 1600x900 [Windowed] and just deal with the fact that I have part of the Desktop in view while playing.
 

My Computer

System One

  • OS
    Windows 8.1 Pro w/ Media Center
    Computer type
    PC/Desktop

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top