• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Internet Options Proxy Server setting won't stay off.


Wojo

New Member
Posts
1
#1
Hello,

I have strange issue with Windows 8.1 x64 Pro with Media Center. Since it was upgraded from 8, there have been issues with Software Store. Despite internet connection working fine with Firefox and other applications, Store would not connect to the internet. After long investigation I found out that Proxy server setting in Control Panel -> Internet Options -> Connections -> LAN Settings must be disabled in order to get Store working again. For some reason proxy server only stays disabled for the current session, which means when the windows is rebooted it comes back enabled again. My question is how to make it stay permanently disabled, as I don't use any proxy. Thanks.
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center x64
    Computer type
    PC/Desktop
#2

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

r4z0r84

New Member
Posts
1
#3
Fix lan settings windows 8.1

Hello,

I have strange issue with Windows 8.1 x64 Pro with Media Center. Since it was upgraded from 8, there have been issues with Software Store. Despite internet connection working fine with Firefox and other applications, Store would not connect to the internet. After long investigation I found out that Proxy server setting in Control Panel -> Internet Options -> Connections -> LAN Settings must be disabled in order to get Store working again. For some reason proxy server only stays disabled for the current session, which means when the windows is rebooted it comes back enabled again. My question is how to make it stay permanently disabled, as I don't use any proxy. Thanks.
Encounted the exact same issues when trying to change from my proxy server to use a proxy.pac file, or to just turn proxy server settings off completely.

By default it will keep proxy lan settings enabled like this: 1.jpg

If you want to disable the proxy server its usually as simple as unticking the "use proxy server" box. in windows 8.1 this is not the case, upon closing that dialogue box it will reset back to being enabled again. The only way i have found around this is as follows.
2.jpg

The proxy.pac address must use // and not \\ as for some reason if you use the lan address it automatically changes it back to using the lan proxy. dont worry if you do not have a proxy.pac file if you have "automatically detect settings" selected it should default to no proxy. but stupidly enough this is the only way to disable a proxy server in windows 8.1

(this has happend a few times randomly with windows 7 enterprise and resetting internet explorer to defaults fixes this, in windows 8.1 however that does not help at all)


You can also manually set it through registry editing if your an advanced user
Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
"MigrateProxy"=dword:00000001
"ProxyEnable"=dword:00000001
"ProxyHttp1.1"=dword:00000000
"ProxyServer"="http://server:port"

1 for enable and 0 for disable.

I started using windows 8.1 today in an enterprise environment and this was the first issue i ran into.
 
Last edited:

My Computer

System One

  • OS
    Windows Server 2012 R2, Windows 8.1, Windows 7 Enterprise
#4

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps
#6

Attachments

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

JHough

New Member
Member
Pittsburgh

Posts
103
#8
ProxyServer1.png

Internet Options-> Connections has "Some settings are managed by your system administrator."

ProxyServer2.png

Right clicking on the Internet Explorer icon and running as administrator, and selecting only “Automatically detect settings” fixed the problem for me. The problem may have originated with the conduit malware.
 

My Computer

System One

  • OS
    Microsoft Windows 8.1 64 Bit
    Computer type
    Laptop
    System Manufacturer/Model Number
    Toshiba C55Dt-A5106
    CPU
    Processor AMD A6-5200 APU with Radeon(TM) HD Graphics, 2 Ghz, 4 Core(s), 4 Logical Processor(s)
    Motherboard
    Toshiba PSCFWU-02C031
    Memory
    4GB
    Graphics Card(s)
    AMD Radeon HD 8400
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    Laptop and DELL E193FP
    Screen Resolution
    1366x768 1280x1024
    Hard Drives
    Toshiba MQ01ABD075
    DVD Writer TSSTcorp CDDVDW SU-208FB
    Keyboard
    Logitech Wave 2.4 Cordless or Laptop Standard PS/2 Keyboard Enhanced
    Mouse
    Logitech M1100 Performance Laser Cordless Combo or Logitech G500
    Internet Speed
    Upload/Download 91/11Mbps
    Browser
    IE 11
    Antivirus
    Norton
    Other Info
    Toshiba System Settings V1.1.2.32001
    BIOS Version Inside Corp., 1.60, 11/15/2013
    EC (Embedded Controller) Version 1.20
    Hardware Abstraction Layer 6.3.9600.16500

drl747

New Member
Posts
1
#9
I had this same problem, i.e. "proxy server only stays disabled for the current session". I tried just about every solution suggested on this any many other forums, with no success.

Someone mentioned that malware could be causing the problem, so I downloaded and ran Microsoft's malware tool which found nothing.

Then I downloaded and ran the free version of Malwarebytes: Malwarebytes Anti-Malware - Protect, Detect & Remove Malware From Your PC

I was surprised to find a number of malware files infecting my laptop (one week old Dell XPS 12-9Q33). After quarantining these files, my computer works perfectly. I can now access the Microsoft Store app (my original problem).
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model Number
    Dell XPS 12-9Q33
Posts
1
#10
I am having similar problems as the people here. I have run Malwarebytes and CCleaner and removed tons of bad junk. The problem still persists. Based on previous comments from Samarai I have ran minitoolbox. I am hoping someone can identify this. Looking at the log file it seems to be centering around a program called backgroundtaskhost.exe. Can anyone help me with this?


View attachment Result.txt
 

My Computer

System One

  • OS
    Windows 8.1

greylost

New Member
Posts
1
#11
Log in with SAFE_MODE
goto help and find out how you log in to safe_mode with win8.1

run -> REGEDIT

goto (in registry)

HKEY_CURRENT_USER -> Software -> Microsoft -> CurrentVersion -> Internet Settings

Change the value of 'Proxy_enable' to 0 (zero)

DELETE the setting called 'proxy_server'

Nowyou can close the REGEDIT

start TaskManager

deactivate all unfamiliar startups

restart your computer and it schould be fine :)
 

My Computer

System One

  • OS
    8.1

kylekek

New Member
Posts
1
#12
for windows 8 try this its what works best for me on keyboard push the win logo key + x scroll down to comand prompt run as administrator
in command line type
ipconfig/flushdns
and press enter
next
ipconfig/release
press enter
next
ipconfig/renew
press enter
exit restart internet explorer and you should be ok... You should go to internet options and push the reset button in reset the advanced tab and repeat the first three steps
 

My Computer

System One

  • OS
    Windows 8.1 64bit

Dondram

New Member
Posts
3
#13
Hello, I use Google chrome and seem to be having the same issue, but i do not have windows 8.1. I un-check the proxy settings box and randomly it'll come back on multiple times throughout the day. If someone could please help me solve this issue it would be greatly appreciated.
 

My Computer

System One

  • OS
    Windows 7

Ztruker

Well-Known Member
VIP Member
Guru
#14

My Computer

System One

  • OS
    Windows 10 Pro X64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Lenovo IdeaCenter K450
    CPU
    Intel Quad Core i7-4770 @ 3.4Ghz
    Motherboard
    Lenovo
    Memory
    16.0GB PC3-12800 DDR3 SDRAM 1600 MHz
    Graphics Card(s)
    Intel Integrated HD Graphics
    Sound Card
    Realtek HD Audio
    Monitor(s) Displays
    HP h2207
    Screen Resolution
    [email protected]
    Hard Drives
    250GB Samsung EVO SATA-3 SSD;
    2TB Seagate ST2000DM001 SATA-2;
    1.5TB Seagate ST3150041AS SATA
    PSU
    500W
    Keyboard
    Wired USB
    Mouse
    Wired USB
    Internet Speed
    3GB Up, 30GB Down
    Browser
    SeaMonkey
    Antivirus
    Windows Defender; MBAM Pro
    Other Info
    UEFI/GPT
    PLDS DVD-RW DH16AERSH

Sunnyjay

New Member
Posts
3
#16
I have just started having the same issue with Google Chrome. It is inconsistent, but requires my going into advanced settings>Network,>proxy server, and deselect "use a proxy server..." under LAN, every time, and some how it keep getting re selected. :mad:
 

My Computer

System One

  • OS
    Windows 8.1 64bit

Ztruker

Well-Known Member
VIP Member
Guru
#17

My Computer

System One

  • OS
    Windows 10 Pro X64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Lenovo IdeaCenter K450
    CPU
    Intel Quad Core i7-4770 @ 3.4Ghz
    Motherboard
    Lenovo
    Memory
    16.0GB PC3-12800 DDR3 SDRAM 1600 MHz
    Graphics Card(s)
    Intel Integrated HD Graphics
    Sound Card
    Realtek HD Audio
    Monitor(s) Displays
    HP h2207
    Screen Resolution
    [email protected]
    Hard Drives
    250GB Samsung EVO SATA-3 SSD;
    2TB Seagate ST2000DM001 SATA-2;
    1.5TB Seagate ST3150041AS SATA
    PSU
    500W
    Keyboard
    Wired USB
    Mouse
    Wired USB
    Internet Speed
    3GB Up, 30GB Down
    Browser
    SeaMonkey
    Antivirus
    Windows Defender; MBAM Pro
    Other Info
    UEFI/GPT
    PLDS DVD-RW DH16AERSH