• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Insert a Smartcard option logon screen Remote Desktop


Wienen

New Member
Posts
11
#1
Hello All,

I have had to reinstall my laptop and now i'm having some trouble finding the tweak to remove the "insert a smartcard" option from my logon box when i try to connect to an external computer with the remote desktop client.

remote-desktop-rdc1.png

I know it's there because i once found it. Only forgot to write down what the solution was.

Can someone help me out?
 

My Computer

System One

  • OS
    Windows 8
#2
You should be able to find it in Device Manger, it may be under "Other Devices" but not sure, It may help to click on the view tab in Device manger then choose the "Show all Devices" once you find it I would think that disabling the device would prevent the option from showing up.
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

Wienen

New Member
Posts
11
#3
Thanks Chev65 but unfortunately this does not work :(

For what i remember there should be a setting in the gpedit.msc (local GPO) the problem is which one?
 

My Computer

System One

  • OS
    Windows 8
#4
It's there in Device Manager if you look for it, should be called Smart Card Manager but it may require that a card be inserted before you can see it, installing the Smart Card driver might also make it show up in Device Manager. If this isn't working then read on.

The registry setting to delete the Smart Card is at the following location> "HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\system" folder as shown in the first picture. You need to right click the scforceoption key and delete it.

There are plenty of options for this in Group Policy though I'm not completely sure which setting will have the desired effect.

Here is a link explaining all the GPO and registry settings which relate to the Smart Card reader.
Smart Card Group Policy and Registry Settings

The Group Policy settings are located in Computer Configuration\Administrative Templates\Windows Components\Smart Card. Second picture shows this location.
 

Attachments

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

Wienen

New Member
Posts
11
#5
Thanks again for your great support!

I've found the "scforceoption" key in the registry and deleting it isn't removing the "Insert a Smartcard" option. :(

Also the options in the GPO don't have affect.

I'm using Windows 8.1 Enterprise (x64) by the way.

I've tried rebooting to make sure the changes were applied but without succes :(
 

My Computer

System One

  • OS
    Windows 8
#6
I didn't realize it was Enterprise.

If it's part of a Domain then the Group Policy of the Domain may not allow for any changes.
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

Wienen

New Member
Posts
11
#7
I didn't realize it was Enterprise.

If it's part of a Domain then the Group Policy of the Domain may not allow for any changes.
The laptop is not part of a domain. i've got admin rights.

I'm using the Enterprise release because we have a MSDN license.
 

My Computer

System One

  • OS
    Windows 8
#8

Attachments

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

Wienen

New Member
Posts
11
#9
Have you tried to disable the Smart Card Device Enumeration Service at services.msc

Apparently you aren't the only with this problem. The following link talks about someone else with the same problem and shows various solutions and work around that may help.

remote desktop - When RDP as a Domain User, Smart Card Requested - Super User
Thanks again for your willingness with helping me to find the right solution!!

And because of that i've found the solution :D

I've also found a site pointing me to the "Smart Card Device Enumeration Service" and tried to stop it and then tried to connect with RDP. The "Insert a Smart Card" was still present.

After reading your post i tried again and stopped the service, set it to disable and rebooted.

This did the trick!! :D

Problem Solved!
 

My Computer

System One

  • OS
    Windows 8
#10
Good deal then, I was hoping that would work for you as I was running out of options. :)
 

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

Users Who Are Viewing This Thread (Users: 0, Guests: 2)