• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Input language settings problem


Posts
6
#1
Hi.
I need to be able to input text using three different languages: English (US), Russian, Ukrainian.
To that end I have prepared the following:
set1.png
As you see, UI is being overridden to Ukrainian too, which is also desired.
I also need to be able to switch input languages NOT using any cyclic shortcut like Ctrl+Shift or Alt+Shift, but by language-specific shortcut, namely Ctrl+1 for English, Ctrl+2 for Ukrainian, Ctrl+3 for Russian. It has been so for years for me and I got used to it.
To that end I found the following setup
set2.png
There you see two Ukrainian layouts (I made one myself, another one is built-in).

The problem is that Ctrl+1 for English works, Ctrl+3 for Russian works too, but BOTH shortcuts for Ukrainian layots do NOT work. When I press Ctrl+2 or Ctrl+4 just nothing happens. I tried to change the Ukrainian shortcuts to no avail.

What should I do?

UPD. What's more interesting thing I just discovered, is that these Ukrainian shortcuts do work selectively.
In Notepad and MS Word -- don't work
In Mozilla Thunderbird and Firefox, also Skype -- does work.

UPD2. Shortcuts seem to be working everywhere EXCEPT the software written by Microsoft. What an irony :(
 
Last edited:

My Computer

System One

  • OS
    Windows 8 x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    self-assembled
    CPU
    AMD K10
    Motherboard
    ASUS F2A85-M
    Memory
    4x2 DDR3
    Graphics Card(s)
    ATI Radeon 58xx
    Browser
    Mozilla Firefox
    Antivirus
    Windows Defender

Vadikan

(*.*)
Power User
Posts
480
#2
Hi,

Did Ukrainian keyboard layouts come with Windows or were installed separately (e.g. had been created with the keyboard layout creator)?

In the latter case, try to remove them and replace with the standard Ukrainian layout, then assign the same shortcut. Does the shortcut work?
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    Computer type
    Laptop
    System Manufacturer/Model Number
    HP Pavilion dv7t (17.3'', i7-2630QM, HD 6770M 1Gb, 8Gb RAM, 2 [email protected] + 1 [email protected])
#3

My Computer

System One

  • OS
    Windows 8.1.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Gateway
    CPU
    AMD K140 Cores 2 Threads 2 Name AMD K140 Package Socket FT1 BGA Technology 40nm
    Motherboard
    Manufacturer Gateway Model SX2110G (P0)
    Memory
    Type DDR3 Size 8192 MBytes DRAM Frequency 532.3 MHz
    Graphics Card(s)
    ATI AMD Radeon HD 7310 Graphics
    Sound Card
    AMD High Definition Audio Device Realtek High Definition Audio USB Audio Device
    Monitor(s) Displays
    Name 1950W on AMD Radeon HD 7310 Graphics Current Resolution 1366x768 pixels Work Resolution 1366x76
    Screen Resolution
    Current Resolution 1366x768 pixels Work Resolution 1366x768 pixels
    Hard Drives
    AMD K140
    Cores 2
    Threads 2
    Name AMD K140
    Package Socket FT1 BGA
    Technology 40nm
    Specification AMD E1-1200 APU with Radeon HD Graphics
    Family F
    Extended Family 14
    Model 2
    Extended Model 2
    Stepping 0
    Revision ON-C0
    Instruction
    Browser
    Opera 24.0
    Antivirus
    Avast Internet Security
Posts
6
#4
Hi,
Did Ukrainian keyboard layouts come with Windows or were installed separately (e.g. had been created with the keyboard layout creator)?
As I said
I made one myself, another one is built-in
This means one Ukrainian layout came in with Windows, another one I made with MSKLC. Deleting either one does not solve the issue.

In the latter case, try to remove them and replace with the standard Ukrainian layout, then assign the same shortcut. Does the shortcut work?
No. MS Word and notepad still refuse to switch to Ukrainian when I press Ctrl+2. Other software works though.
 

My Computer

System One

  • OS
    Windows 8 x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    self-assembled
    CPU
    AMD K10
    Motherboard
    ASUS F2A85-M
    Memory
    4x2 DDR3
    Graphics Card(s)
    ATI Radeon 58xx
    Browser
    Mozilla Firefox
    Antivirus
    Windows Defender
Posts
6
#5

My Computer

System One

  • OS
    Windows 8 x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    self-assembled
    CPU
    AMD K10
    Motherboard
    ASUS F2A85-M
    Memory
    4x2 DDR3
    Graphics Card(s)
    ATI Radeon 58xx
    Browser
    Mozilla Firefox
    Antivirus
    Windows Defender

Vadikan

(*.*)
Power User
Posts
480
#6
Sorry, I missed the built-in part. What happens in safe mode?

Another question. Switch with Win+Space to the built-in Ukrainian layout. Does the shortcut work with switching to another Ukrainian layout?
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    Computer type
    Laptop
    System Manufacturer/Model Number
    HP Pavilion dv7t (17.3'', i7-2630QM, HD 6770M 1Gb, 8Gb RAM, 2 [email protected] + 1 [email protected])
#7
I have a built in hot key utility.
It works good :
I'm sorry, how is that supposed to help in my problem?
I thought you might look on the internet & find a free hot key utility that would solve your problem.
I assumed you did not have a hot key program.
I assumed you were using Properties to set up hot keys that wouldn't work.

There are some good free hot key programs available that might help you with your issue.
 

My Computer

System One

  • OS
    Windows 8.1.1 Pro with Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Gateway
    CPU
    AMD K140 Cores 2 Threads 2 Name AMD K140 Package Socket FT1 BGA Technology 40nm
    Motherboard
    Manufacturer Gateway Model SX2110G (P0)
    Memory
    Type DDR3 Size 8192 MBytes DRAM Frequency 532.3 MHz
    Graphics Card(s)
    ATI AMD Radeon HD 7310 Graphics
    Sound Card
    AMD High Definition Audio Device Realtek High Definition Audio USB Audio Device
    Monitor(s) Displays
    Name 1950W on AMD Radeon HD 7310 Graphics Current Resolution 1366x768 pixels Work Resolution 1366x76
    Screen Resolution
    Current Resolution 1366x768 pixels Work Resolution 1366x768 pixels
    Hard Drives
    AMD K140
    Cores 2
    Threads 2
    Name AMD K140
    Package Socket FT1 BGA
    Technology 40nm
    Specification AMD E1-1200 APU with Radeon HD Graphics
    Family F
    Extended Family 14
    Model 2
    Extended Model 2
    Stepping 0
    Revision ON-C0
    Instruction
    Browser
    Opera 24.0
    Antivirus
    Avast Internet Security
Posts
6
#8
Sorry, I missed the built-in part. What happens in safe mode?
The same.

Another question. Switch with Win+Space to the built-in Ukrainian layout. Does the shortcut work with switching to another Ukrainian layout?
No it doesn't. Both ways: no switch from mine to builtin and from builtin to mine using Ctrl+digit shortcut.

The only viable workaround I can use is to stuff all keyboard layouts (en+rus+ukr) under single input language (ukrainian). This way it works through Ctrl+digit shortcuts everywhere, but this poses another problem with programs who pay respect to input language. Say, I want to enter english text in MS Word and it thinks it's Ukrainian because, indeed, it is selected as an English layout under Ukrainian language. This is not acceptable.

I wonder why on earth keyboard layout should ever be allowed to be different from input language? Aren't they the same thing essentially?
 

My Computer

System One

  • OS
    Windows 8 x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    self-assembled
    CPU
    AMD K10
    Motherboard
    ASUS F2A85-M
    Memory
    4x2 DDR3
    Graphics Card(s)
    ATI Radeon 58xx
    Browser
    Mozilla Firefox
    Antivirus
    Windows Defender
Posts
6
#9
I have a built in hot key utility.
It works good :
I'm sorry, how is that supposed to help in my problem?
I thought you might look on the internet & find a free hot key utility that would solve your problem.
If need be, I can write the hotkey utility myself.
The essence of my problem is not the inability to setup a hotkey for an arbitrary action, but the fact that builtin Windows language switcher is not working as it is supposed to.
 

My Computer

System One

  • OS
    Windows 8 x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    self-assembled
    CPU
    AMD K10
    Motherboard
    ASUS F2A85-M
    Memory
    4x2 DDR3
    Graphics Card(s)
    ATI Radeon 58xx
    Browser
    Mozilla Firefox
    Antivirus
    Windows Defender

Vadikan

(*.*)
Power User
Posts
480
#10
Sorry, I missed the built-in part. What happens in safe mode?
That rules out any third party interference.

I wonder why on earth keyboard layout should ever be allowed to be different from input language? Aren't they the same thing essentially?
They are not. An input language may have multiple keyboard layouts. In your case you have one input language (UA) and several layouts. Actually, i's not a new concept for Windows.

I'll see if I can reproduce your problem over the weekend. That way we can at least establish whether this behavior is not restricted to your system :)
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    Computer type
    Laptop
    System Manufacturer/Model Number
    HP Pavilion dv7t (17.3'', i7-2630QM, HD 6770M 1Gb, 8Gb RAM, 2 [email protected] + 1 [email protected])

Vadikan

(*.*)
Power User
Posts
480
#11
Yeah, I confirm the problem, and it doesn't look like it's specific to Ctrl+ shortcuts, as Ctrl+Shift+ won't work either. I guess you'd have to live with cycling through Win+Space.
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    Computer type
    Laptop
    System Manufacturer/Model Number
    HP Pavilion dv7t (17.3'', i7-2630QM, HD 6770M 1Gb, 8Gb RAM, 2 [email protected] + 1 [email protected])
Posts
1
#12
Same problem here, but I found the solution.
I'm not really sure about English titles, but it seems to be Region and Language, tab Administrative, Language for non-Unicode programs, set Ukrainian.
Now I am able to switch to Ukrainian language with hot keys in all MS applications.
LoremIpsum, should work for you too.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop

LoremIpsum

New Member
Posts
6
#13
Well I did that too, from the beginning. Just didn't mention it.

On the problem: Now I'm using Windows 8.1 and it has exactly the same issue; but I'm using the different workaround.

First, after setting Ctrl+digit shortcuts for all three input languages, they are displayed properly in the shortcut settings dialog but they DO NOT work until I logout and login again. Then they work fine but are NOT displayed properly -- at least one is missing (marked as "none") even though it works.

That's weird but viable. Windows way, damn.
 

My Computer

System One

  • OS
    Windows 8 x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    self-assembled
    CPU
    AMD K10
    Motherboard
    ASUS F2A85-M
    Memory
    4x2 DDR3
    Graphics Card(s)
    ATI Radeon 58xx
    Browser
    Mozilla Firefox
    Antivirus
    Windows Defender

andrad

New Member
Posts
1
#14
It's 2018 now. I have my brand new Microsoft Surface Book 2 with Windows 10, and the same problem. I had this problem in my Lenovo Yoga, but I was sure it was because of some Lenovo driver. But now it's Microfost Surface and I figured out that hot keys just don't work for any Ukrainian keyboard. They work for any keyboard except Ukrainian. I've tried Belorussian that is pretty similar - it works. Ukrainian - doesn't work!!!! Very stupid situation ((((
 

My Computer

System One

  • OS
    Windows 10
    Computer type
    Laptop
    System Manufacturer/Model Number
    Microsoft
    CPU
    Core i7