What's new

HyperX Cloud Alpha S headphones on Windows 8.1

belveder

New Member
I just bought these headphones but have an issue with them on Windows 8.1 which I am running.

The software for it HyperX NGENUITY won't run to even install it.

Any help would be really appreciated please
 

My Computer

System One

  • OS
    7 & 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    home made
    Antivirus
    ESET

Teeotsa

Member
Try older versions of the program. They were working decent enough for me and later messed up my mouse. You can get it from web archive. Tried new versions with no luck
 

My Computer

System One

  • OS
    Windows 8.1 Professional x64
    Computer type
    PC/Desktop
    CPU
    3rd Gen Intel CPU
    Memory
    HyperX Fury DDR3 2x4GB 1866MHz
    Graphics Card(s)
    Intel HD 2500
    Screen Resolution
    1920x1080
    Hard Drives
    Kingston A400 240GB
    1TB SEAGATE HDD
    Internet Speed
    ~ 6 Mb/s (Enough for me)
    Browser
    Google Chrome 96, Internet Explorer 11, Firefox 93.0
    Antivirus
    No third-party Antivirus software is installed on my system.
    Other Info
    I don't update my installation of Windows. I find it unnecessary.
    Also, i've disabled Windows Defender and Windows Firewall because i don't need them!😂

belveder

New Member
Thanks, I have but the older versions don't pick up the current headphones
 

My Computer

System One

  • OS
    7 & 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    home made
    Antivirus
    ESET

Teeotsa

Member
Thanks, I have but the older versions don't pick up the current headphones
Restart your computer and replug your headphones? Worked with my mouse 😂
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1 Professional x64
    Computer type
    PC/Desktop
    CPU
    3rd Gen Intel CPU
    Memory
    HyperX Fury DDR3 2x4GB 1866MHz
    Graphics Card(s)
    Intel HD 2500
    Screen Resolution
    1920x1080
    Hard Drives
    Kingston A400 240GB
    1TB SEAGATE HDD
    Internet Speed
    ~ 6 Mb/s (Enough for me)
    Browser
    Google Chrome 96, Internet Explorer 11, Firefox 93.0
    Antivirus
    No third-party Antivirus software is installed on my system.
    Other Info
    I don't update my installation of Windows. I find it unnecessary.
    Also, i've disabled Windows Defender and Windows Firewall because i don't need them!😂

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top