What's new

Solved How to run a program as administrator in a user account ?

ecevit

Member
Member
How can I run a program as administrator in a user account that isn't administrator? I need this since I can't update chrome on a non administrator account . Windows 8 gives me an error but I can't find a way to start chrome as administrator. Thanks in advance.
 

My Computer

System One

  • OS
    windows 8 pro x64
    CPU
    Q9300
    Motherboard
    Gigabyte P43 Es3g
    Memory
    8 GB of ddr 2
    Graphics Card(s)
    sapphire hd 6850
    Sound Card
    sound blaster titanium x-fi pci-e
    Monitor(s) Displays
    22 inches
    Screen Resolution
    1680x1050
    Hard Drives
    Seagate 2 TB st20001dm001
    Samsung 2 tb sata 2
    Hitachi 500 gb sata
    PSU
    fatality 550 w
    Case
    spike
    Cooling
    air
    Mouse
    wired A4
    Internet Speed
    ADSL 8 MB / 1 MB

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom build
    CPU
    AMD Phenom II X 4 965 BE
    Motherboard
    Gigabyte GA-MA790X-DS4
    Memory
    G-Skill 8 GB PC 8500
    Graphics Card(s)
    AMD XFX HD Radeon 6790D
    Sound Card
    Realtek HD onboard
    Monitor(s) Displays
    2l Samsung SyncMaster S20B300
    Screen Resolution
    1600 X 900
    Hard Drives
    Seagate Barracuda 320 GB w/OS
    Seagate Barracuda 1 TB data storage
    PSU
    Ultra X4 750 watt fully modular
    Case
    Thermaltake OverSeer RX 1 fulltower
    Cooling
    Cooler Master Hyper212 120mm
    Keyboard
    Logitech G510
    Mouse
    Razor DeathAdder 3.5

Brink

Administrator
Administrator
mvp
Hello ecevit,

In addition, when you use "Run as administrator" on the program, you will be prompted by UAC to enter an administrator's password first before being allowed to do so since you are signed in to a standard user account.

If you do not know the password, then you will need to have the administrator update the program in their account.
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

ecevit

Member
Member
That way won't work , gives me error.
 

My Computer

System One

  • OS
    windows 8 pro x64
    CPU
    Q9300
    Motherboard
    Gigabyte P43 Es3g
    Memory
    8 GB of ddr 2
    Graphics Card(s)
    sapphire hd 6850
    Sound Card
    sound blaster titanium x-fi pci-e
    Monitor(s) Displays
    22 inches
    Screen Resolution
    1680x1050
    Hard Drives
    Seagate 2 TB st20001dm001
    Samsung 2 tb sata 2
    Hitachi 500 gb sata
    PSU
    fatality 550 w
    Case
    spike
    Cooling
    air
    Mouse
    wired A4
    Internet Speed
    ADSL 8 MB / 1 MB

ecevit

Member
Member
I don't get any dialog box prompting me administrator password. An error message shows up just for a second then disappears.

Also, I didn't set up a password for built in administrator account. I just use my administrator account.
 

My Computer

System One

  • OS
    windows 8 pro x64
    CPU
    Q9300
    Motherboard
    Gigabyte P43 Es3g
    Memory
    8 GB of ddr 2
    Graphics Card(s)
    sapphire hd 6850
    Sound Card
    sound blaster titanium x-fi pci-e
    Monitor(s) Displays
    22 inches
    Screen Resolution
    1680x1050
    Hard Drives
    Seagate 2 TB st20001dm001
    Samsung 2 tb sata 2
    Hitachi 500 gb sata
    PSU
    fatality 550 w
    Case
    spike
    Cooling
    air
    Mouse
    wired A4
    Internet Speed
    ADSL 8 MB / 1 MB

ecevit

Member
Member
Oh , I disabled uac . Hmm let me see if it works when enabling uac.
 

My Computer

System One

  • OS
    windows 8 pro x64
    CPU
    Q9300
    Motherboard
    Gigabyte P43 Es3g
    Memory
    8 GB of ddr 2
    Graphics Card(s)
    sapphire hd 6850
    Sound Card
    sound blaster titanium x-fi pci-e
    Monitor(s) Displays
    22 inches
    Screen Resolution
    1680x1050
    Hard Drives
    Seagate 2 TB st20001dm001
    Samsung 2 tb sata 2
    Hitachi 500 gb sata
    PSU
    fatality 550 w
    Case
    spike
    Cooling
    air
    Mouse
    wired A4
    Internet Speed
    ADSL 8 MB / 1 MB

ecevit

Member
Member
Didn't work. Interesting.
 

My Computer

System One

  • OS
    windows 8 pro x64
    CPU
    Q9300
    Motherboard
    Gigabyte P43 Es3g
    Memory
    8 GB of ddr 2
    Graphics Card(s)
    sapphire hd 6850
    Sound Card
    sound blaster titanium x-fi pci-e
    Monitor(s) Displays
    22 inches
    Screen Resolution
    1680x1050
    Hard Drives
    Seagate 2 TB st20001dm001
    Samsung 2 tb sata 2
    Hitachi 500 gb sata
    PSU
    fatality 550 w
    Case
    spike
    Cooling
    air
    Mouse
    wired A4
    Internet Speed
    ADSL 8 MB / 1 MB

Brink

Administrator
Administrator
mvp
Are you able to sign in to an administrator account to update Chrome?
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

ecevit

Member
Member
My account has administrator rigths and I updated chrome in my account but my brother's account is no admin( he has power user priviliges but not admin ) so I cannot update chrome in his account.
 

My Computer

System One

  • OS
    windows 8 pro x64
    CPU
    Q9300
    Motherboard
    Gigabyte P43 Es3g
    Memory
    8 GB of ddr 2
    Graphics Card(s)
    sapphire hd 6850
    Sound Card
    sound blaster titanium x-fi pci-e
    Monitor(s) Displays
    22 inches
    Screen Resolution
    1680x1050
    Hard Drives
    Seagate 2 TB st20001dm001
    Samsung 2 tb sata 2
    Hitachi 500 gb sata
    PSU
    fatality 550 w
    Case
    spike
    Cooling
    air
    Mouse
    wired A4
    Internet Speed
    ADSL 8 MB / 1 MB

Brink

Administrator
Administrator
mvp
If you update Chrome in your administrator account, it should update it for all accounts since all accounts use the same installed Chrome. Only the personal settings in Chrome are separate per account.
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

ecevit

Member
Member
You're right. The same version on both accounts. The error was about not being able to perform version check but chrome is updated anyway. Thanks.
 

My Computer

System One

  • OS
    windows 8 pro x64
    CPU
    Q9300
    Motherboard
    Gigabyte P43 Es3g
    Memory
    8 GB of ddr 2
    Graphics Card(s)
    sapphire hd 6850
    Sound Card
    sound blaster titanium x-fi pci-e
    Monitor(s) Displays
    22 inches
    Screen Resolution
    1680x1050
    Hard Drives
    Seagate 2 TB st20001dm001
    Samsung 2 tb sata 2
    Hitachi 500 gb sata
    PSU
    fatality 550 w
    Case
    spike
    Cooling
    air
    Mouse
    wired A4
    Internet Speed
    ADSL 8 MB / 1 MB

Brink

Administrator
Administrator
mvp
Great news.

Yeah, the error was just from not having administrator rights.
 

My Computer

System One

  • OS
    64-bit Windows 10
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom self built
    CPU
    Intel i7-8700K OC'd to 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    OCZ Series Gold OCZZ1000M 1000W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Browser
    Internet Explorer 11
    Antivirus
    Malwarebyte Anti-Malware Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top