• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

How to reinstate WinMail onto Windows 8 or Windows 10


endeavor

Power User
VIP Member
Power User
Posts
133
I said I wasn't done yet but why when I asked a question you don't answer but then you post another question - wth <g>
Since it was not working looking for the right way to associate for mapimail is why I put it in there to see what happens, leaving nothing to chance.

..need to get mapi fixed/associated, more to go till it works; the rest will be done under the hood though.
.
And so again I'm asking what specific is it about WinMail why you posted?
What specifically is not working for you?
 
Last edited:

My Computer

System One

  • OS
    Vista/Win7/Win8/Win10 (x86/x64)
    System Manufacturer/Model Number
    ..all towers built from scratch
    CPU
    i7's
    Other Info
    ..including W98SE/WXP
    No VM's ..all OS's are live

yako2k3

Member
Member
Istanbul

Posts
21
wm_109_prot0.png

wm_109_prot1.png

When i click to news:... links, Thunderbird starting :)

This is my problem. for now. That's it. (Also 'Microsoft Communities' appears every time but it's ignorable)
 

My Computer

System One

  • OS
    Win10 pro
    Computer type
    Laptop
    System Manufacturer/Model Number
    Thinkpad E470
    CPU
    i5 4th gen
    Memory
    8 gb
    Graphics Card(s)
    Nvidia onboard
    Sound Card
    onboard
    Monitor(s) Displays
    14' built in, 22' vga external
    Screen Resolution
    1920
    Hard Drives
    256GB SSD
    Mouse
    Thinkpad TrackBall
    Browser
    Firefox of course ;)

endeavor

Power User
VIP Member
Power User
Posts
133
When i click to news:... links, Thunderbird starting :)

This is my problem. for now. That's it. (Also 'Microsoft Communities' appears every time but it's ignorable)
I don't have Thunderbird installed on the 1709 install right now and at the moment, because for me that just adds many too many more things into the mix in order for me to properly research the current problems that exist. I'm sure you understand that.

When MS removed the OE legacy code of WinMail the results were substantial. I tracked every file/registry change made between 1607 and the latest 1709 and have them all for reference. Thousands of registry changes and many file changes just related just to WinMail itself. I can see and interact with it all. I have to meticulously go back and go over the related changes and see if I can re-instate some of what was done to the MAPI sections, and whatever else is related, to see if I can get it back. The problem is they have tied a lot of it over Default to the built in 1709 Mail client now, and I'm not going to break that just to get WinMail going. WinMail needs to be self-sufficient.

fwiw I had already seen and restored those same registry entries previously that orgi suggested, and more, but I had not restored those few files at that point, and that's why I did not succeed at first. Out of thousands of file changes to the whole upgrade, it's a little hard to decipher what goes to what feature unless you're the original programmer or similar.
 
Last edited:

My Computer

System One

  • OS
    Vista/Win7/Win8/Win10 (x86/x64)
    System Manufacturer/Model Number
    ..all towers built from scratch
    CPU
    i7's
    Other Info
    ..including W98SE/WXP
    No VM's ..all OS's are live

endeavor

Power User
VIP Member
Power User
Posts
133
I see orgi posted the MAPI additional fixes for Windows10 v1709 today.
As he mentions he has some tech friends helping him with this.

I made all the changes and it worked just fine.
(remember though, the original Bug List is still the same, and may even have additional issues with this)

Now MAPI and SendTo Mail Recipient works fine, etc, and attaches files just fine, etc..
SendToAttachment.jpg

My Windows Mail is listed in the Default Apps section where it should be, with other settings we mentioned previously.
defaultapps.jpg

I transferred over my entire Win7 WinMail setup to Windows 10 this morning for testing, and here's a screenshot of that.
(I covered some of my tech news groups listings for privacy, and just show a random nntp; I don't show all the many accounts I have under Other, etc...)
(click screenshot if you want to open full size)

newsgroups+.jpg


Edit:
I have now updated the WinMail Tutorial to include the extra files necessary to get Windows10, v1703 / 1709 working.
I further simplified the process - See Post #2 here (of course you must do Post #1 first)




.
 
Last edited:

My Computer

System One

  • OS
    Vista/Win7/Win8/Win10 (x86/x64)
    System Manufacturer/Model Number
    ..all towers built from scratch
    CPU
    i7's
    Other Info
    ..including W98SE/WXP
    No VM's ..all OS's are live

endeavor

Power User
VIP Member
Power User
Posts
133
I have now updated the WinMail Tutorial to include the extra files necessary to get Windows10, v1703 / 1709 working.

I further simplified the process - See Post #2 here (of course you must run through Post #1 first)
 

My Computer

System One

  • OS
    Vista/Win7/Win8/Win10 (x86/x64)
    System Manufacturer/Model Number
    ..all towers built from scratch
    CPU
    i7's
    Other Info
    ..including W98SE/WXP
    No VM's ..all OS's are live