• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

How do I restore a PNY 128Gb flash drive - tried uninstall


New Member
My PNY 128Gb flash drive died while copying files for back up from a Windows 8.1 Dell PC.
I tried re-plugging it into the USB port, other USB ports, other computer USB ports (3 and lower) and nothing.
The drives on all the PCs have been renamed starting at drive L to avoid conflicts (not counting C:)
In Device Manager I can see it appear as I insert the device again, as a USB Mass Storage Device. But updating the driver, disable, and uninstall has not done anything. The PNY USB flash drive does not appear.
I then tried to reset the driver using:
set devmgr_show_nonpresent_devices=1 at the CMD prompt.
Then I did a devmgmt.msc
Then I uninstalled the faded devices under Universal Serial Bus controllers.
The drive finally does appear my other drives as a Removable Disk (D:) but I cannot do anything with it. I cannot format it and it says that it has 0 bytes used and 0 bytes free space. I cannot Error Check it.
Is there some way to reset this USB drive?

My Computer

System One

  • OS
    Windows 8.1

Users Who Are Viewing This Thread (Users: 0, Guests: 1)