• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

google.com not loading with https, Firefox and IE


Farmer

New Member
Posts
2
#1
Hi guys and gals,

New to this forum, so I hope it the right place for and way of explaining this problem.

I just bought my first PC, which is pretty awesome after having worked on laptops for years.
Here is the configuration:
- i7 4790K
- MSI Z97 Gaming 5
- MSI GTX 980
- Corsair Vengeance Pro Red 16GB 1600 MHz CL9
- Corsair RM750
- Samsung 850 Pro 256GB SSD

This is also my first system with Windows 8.

Now here is the problem:
After installing my favorite browser Firefox, for some reason it won't load google.com properly.
It automatically tries to load the https version of google, which makes sense.
But it gives my the "Untrusted connection error" (but then in Dutch, so I hope it is correctly translated).
When I delete the "s" and try http it loads fine, but then my search results are different from my laptop with Windows 7 and only the categories "Web" and "Images" are shown.
The same happens in Internet Explorer.

I have tried the solutions as described on the Mozilla support pages, but without any luck.

I hope someone on this forum can help me out.

Thanks in advance and best regards,

T
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    PC/Desktop
    CPU
    Intel i7 4790K
    Motherboard
    MSI Z97 Gaming 5
    Memory
    Corsair DDR3 Vengeance Red 16GB CL9 1600 MHz
    Graphics Card(s)
    MSI nVidia GTX 980
    Monitor(s) Displays
    Samsung 32" TV
    Screen Resolution
    1920x1080p
    PSU
    Corsair RM750
    Case
    be quiet! Silent Base Orange
    Cooling
    Cooler Master Hyper 212 Evo
    Internet Speed
    150 Mbps
    Browser
    Firefox 36.0.4
    Antivirus
    Microsoft Defender

Farmer

New Member
Posts
2
#2
Just found out that Internet Explorer has similar problem on my Windows 7 laptop.
Google Search results only show the categories "Web" and "Image".

Anyone that might have a solution?
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    PC/Desktop
    CPU
    Intel i7 4790K
    Motherboard
    MSI Z97 Gaming 5
    Memory
    Corsair DDR3 Vengeance Red 16GB CL9 1600 MHz
    Graphics Card(s)
    MSI nVidia GTX 980
    Monitor(s) Displays
    Samsung 32" TV
    Screen Resolution
    1920x1080p
    PSU
    Corsair RM750
    Case
    be quiet! Silent Base Orange
    Cooling
    Cooler Master Hyper 212 Evo
    Internet Speed
    150 Mbps
    Browser
    Firefox 36.0.4
    Antivirus
    Microsoft Defender

Users Who Are Viewing This Thread (Users: 0, Guests: 1)