• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

External LCD display won't fall into sleep (only blank)


Anakunda

Member
Member
Posts
71
#1
Hi, my external display lost ability to fall into sleep after inactivity timeout is reached. It just turns to black screen, apparent the display is active (I don't use the blank screen screensaver). The display only switches to standby if I unplug the signal cable. Withal it was able to switch into full standby earlier. So something had to change.

I did walk through monitor menu to find if there's some settings for power saving mode, there's none.
Connected via HDMI. Have searched a bit for this problem and found only this be closest to my problem: windows 7 - Monitor doesn't sleep on power off - Super User but the topic doesn't have a solution for me (I don't see any DPMS or power off options, probably for that BIOS is in UEFI mode).

powercfg /availablesleepstates gives this report

Code:
The following sleep states are available on this system:
    Standby (S3)
    Hibernate
    Hybrid Sleep
    Fast Startup

The following sleep states are not available on this system:
    Standby (S1)
        The system firmware does not support this standby state.

    Standby (S2)
        The system firmware does not support this standby state.

    Standby (Connected)
        The system firmware does not support this standby state.
Any resolution on this issue?
 

My Computer

System One

  • OS
    Windows 8.1 Enterprise 64bit
    Computer type
    Laptop
Posts
620
#2
Do you have another monitor to try? It sounds like the graphics card realizes the computer is idle, and so it stops sending data to the monitor, but the monitor seems not to understand it needs to go into standby mode.

Swapping monitors with another computer will reveal if the problem is with your monitor, or your computer, depending on if the problems moves to the 2nd computer with your monitor, or stays with your computer with the 2nd monitor.
 

My Computer

System One

  • OS
    W10 Pro
    Computer type
    PC/Desktop

Anakunda

Member
Member
Posts
71
#3
I don't have another monitor at hand but this may give some clue:
The display connects over HDMI, in GPU control panel it's identified as Digital TV.
If I use DVI input on the display side, the display is identified as Digital Monitor in GPU CP and goes into sleep correctly.
Might be the problem source - Windows thinks that the connected display is a TV and for some reason won't power off the device.
Switching the input might be the solution but HDMI to DVI cable allows lower maximum refresh rate (41Hz vs. 60Hz over HDMI).

Then I need to either
- force Windows to identify the display as true monitor
or
- force the display to identify itself as true monitor via HDMI input
or
- force Windows to send DPMS despite it will recognize it as TV

Googled for "force DPMS over HDMI" but found mostly only Linux related answers.
Btw. if switching video output to internal display true standby works too.
 

My Computer

System One

  • OS
    Windows 8.1 Enterprise 64bit
    Computer type
    Laptop
Posts
620
#4
I don't have another monitor at hand
Most TVs in recent years have computer inputs.

Might be the problem source - Windows thinks that the connected display is a TV and for some reason won't power off the device.
Nope! Windows does not know or care what you are using for a monitor. Windows does not communicate with monitors. It communicates with the graphics cards, which, in turn, tell the monitor what to display. I cannot speak for all TVs, but the Samsung and Visio TVs I use here for monitors will go into standby properly when the source is switched to Computer and the computer goes to sleep.

Refresh rates for LCD monitors is not the same as in the old days with CRTs. This is because the pixels on a LCD stay lit until to told to turn off. On CRT monitors, the illuminated phosphorous coating on the inside of the cathode-ray tube rapid fades, thus needs to be refreshed.

The refresh rate on LCDs really has to due with how jerky-free fast moving animated objects are displayed.
 

My Computer

System One

  • OS
    W10 Pro
    Computer type
    PC/Desktop

Users Who Are Viewing This Thread (Users: 0, Guests: 1)