• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

External Hard Drive inaccessible, becomes "Local Disk"


cmluepke

New Member
Posts
1
#1
Hey all, I recently upgraded from Windows 7 to Windows 8 and I'm loving it, EXCEPT for this one problem I'm having.

Immediately after I upgraded, my external hard drive (WD Ext HDD 1021 3TB) was missing from "My Computer." I never had any problems with this HDD before I upgraded, and the file-system is NTFS.

The external drive is visible in Disk Management, however there is no letter assigned. Right clicking on the drive's partitions in Disk Management shows every option grayed out except for "Delete Volume."

Upon seeing this, I attempted to use diskpart to assign a new letter, however in diskpart the partition type is listed as "unknown" and when I attempt to assign a letter, diskpart says "there is no volume specified." Listing volumes in diskpart only seems to list the volumes on my internal drive, not the external one.

After reading some articles on similar problems, I tried using the program "MiniTool Partition Wizard" to assign a new drive letter, and it seemed to work! The drive showed up in "My Computer" with the correct name and letter, with all my data intact. In Disk Management, all the drive options were still grayed out, but because I could access my drive, I figured the problem was solved.

However, after a short amount of time, the drive became inaccessible. In "My Computer" the drive's name changed from "cmluepke 3tb external (F:)" to "Local Disk (F:)." Clicking on "Local Disk" results in an error message. At this point in time, I can use "MiniTool Partition Wizard" to assign a new letter, but after a variable amount of time (5-30 minutes) the drive will become unavailable again.

Other things I have tried in order to solve this problem:
1. used many different USB ports.
2. plugged the external HDD's power cord directly into the wall rather than into power cord.
3. uninstalled and reinstalled the drivers for the HDD and for USB Mass Storage Device in Device Manager.
4. checked bios (couldn't find options pertaining to the external drive.)
5. ran chkdsk

I have read into similar cases and heard that "Delete Volume" should fix the problem, however I don't currently have a way to back up this much data (I simply don't have space for ~2tb of stuff anywhere else.) If that is really the only way to fix it, I understand. I just figured I'd check and make sure there wasn't anything else I could try before I delete and reformat.

Anyway, sorry for the long post. Let me know if you need any more information, or if you have any ideas of things I could try.
 

My Computer

System One

  • OS
    Windows 8

Wenda

Member
Power User
#2
I had this exact same problem with a 16GB Toshiba thumb-drive a few days ago.
I'd been having heat-related shutdowns, and believe this to be what caused the issue in the first place.
Deleting the volume, then re-creating it allowed me to format and assign a drive-letter.
But yes, I did lose the (non-critical - a recorded TV show) data.
I'm not aware of any other 'fixes'.
Wenda.
 

My Computer

System One

  • OS
    Windows 8.1 'Ultimate' RTM 64 bit (Pro/WMC).
    Computer type
    Laptop
    System Manufacturer/Model Number
    Acer AS8951G 'Desktop Replacement'.
    CPU
    [email protected]/3.1Ghz.
    Motherboard
    Acer
    Memory
    [email protected]
    Graphics Card(s)
    GeForce GT555M 2GB DDR3
    Sound Card
    Realtek HD w/Dolby 5.1 surround.
    Monitor(s) Displays
    Built-in. Non-touch.
    Screen Resolution
    18/4" 1920x1080 full-HD.
    Hard Drives
    Toshiba 750GBx2 internal. 1x2TB, 2x640GB, 1x500GB external.
    PSU
    Stock.
    Case
    Laptop.
    Cooling
    Stock.
    Keyboard
    Full 101-key
    Mouse
    USB cordless.
    Browser
    IE11, Firefox, Tor.
    Antivirus
    Windows Defender, MalwareBytes Pro.
    Other Info
    BD-ROM drive.