• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Ethernet port not detected in device manager


dreamer

Member
Member
Posts
53
#1
Hi Guys,

Using windows 8.1 and ubuntu in dual boot on my laptop.

When i thether my iphone in ubuntu and connect to internet using USB,the Ethernet connection works.

Now strangely in my windows setup,i cant find my Atheros Ethernet in device manager nor even in Network and Sharing center.

When i use iphone as personal hotspot in wifi,the connection drops intermittently and i have to re connect always.

I did reinstall my ethernet drivers but the problem persists.

Any help will be appreciated
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    Laptop
    System Manufacturer/Model Number
    DELL Inspiron 14R N4010
    CPU
    Intel i3 2.4 Ghz
    Memory
    6 GB
    Graphics Card(s)
    Intel Integrated HD
    Screen Resolution
    1366*768
    Hard Drives
    320 GB
    Browser
    Chrome
    Antivirus
    Kaspersky Internet security 2014

popeye

New Member
VIP Member
Guru
United States

Posts
3,090
#2
Not seeing the LAN adapter in Device Manager is strange. How about in Hidden Devices? I would start by running sfc /scannow.

If you run in Safe Mode with networking what happens?
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64-bit
    Computer type
    Laptop
    System Manufacturer/Model Number
    Acer V3 771G-6443
    CPU
    i5-3230m
    Motherboard
    Acer VA70_HC (U3E1)
    Memory
    8GB DDR3 PC3-12800 (800 MHz)
    Graphics Card(s)
    HD4000 + GeForce GT 730M
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    17" Generic PnP Display on Intel HD Graphics 4000
    Screen Resolution
    1600x900 pixels
    Hard Drives
    Samsung SSD 850 EVO 250 GB
    ADATA SSD SP900 128GB
    PSU
    90 watt brick
    Mouse
    Bluetooth
    Antivirus
    Comodo
    Other Info
    Asus RT-AC56R dual-band WRT router (Merlin firmware). Intel 7260.HMWWB.R dual-band ac wireless adapter.

dreamer

Member
Member
Posts
53
#3
Thanks Popeye.

Where can i find this "hidden devices" settings??

I did run sfc /scannow and rebooted but problem persists.Rebooting to safe mode didn't make a difference either.

I thought maybe its a hardware issue of my LAN adaptor but the same is working flawlessly in Ubuntu.In fact right now i am typing on Ubuntu using wired connection.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    Laptop
    System Manufacturer/Model Number
    DELL Inspiron 14R N4010
    CPU
    Intel i3 2.4 Ghz
    Memory
    6 GB
    Graphics Card(s)
    Intel Integrated HD
    Screen Resolution
    1366*768
    Hard Drives
    320 GB
    Browser
    Chrome
    Antivirus
    Kaspersky Internet security 2014

popeye

New Member
VIP Member
Guru
United States

Posts
3,090
#4
When you click View at the top of Device Manager there should be an option to show hidden devices.

What model of atheros adapter is it? Are your PCI/cipset drivers in System devices up to date also? I would re-install all chipset and network drivers listed on the Dell site for your laptop.
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64-bit
    Computer type
    Laptop
    System Manufacturer/Model Number
    Acer V3 771G-6443
    CPU
    i5-3230m
    Motherboard
    Acer VA70_HC (U3E1)
    Memory
    8GB DDR3 PC3-12800 (800 MHz)
    Graphics Card(s)
    HD4000 + GeForce GT 730M
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    17" Generic PnP Display on Intel HD Graphics 4000
    Screen Resolution
    1600x900 pixels
    Hard Drives
    Samsung SSD 850 EVO 250 GB
    ADATA SSD SP900 128GB
    PSU
    90 watt brick
    Mouse
    Bluetooth
    Antivirus
    Comodo
    Other Info
    Asus RT-AC56R dual-band WRT router (Merlin firmware). Intel 7260.HMWWB.R dual-band ac wireless adapter.

dreamer

Member
Member
Posts
53
#5
Hi Popeye,

I did find the Atheros AR8152 PCI-E Fast Ethernet Controller in hidden devices.i uninstalled the device and rebooted my system.
Downloaded the latest drivers from Dell site.Installing the driver gives me the error "Installer cant find the Atheros controller on your system".

obviously i still cant fine the adaptor in device manager.

What is the next step??
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    Laptop
    System Manufacturer/Model Number
    DELL Inspiron 14R N4010
    CPU
    Intel i3 2.4 Ghz
    Memory
    6 GB
    Graphics Card(s)
    Intel Integrated HD
    Screen Resolution
    1366*768
    Hard Drives
    320 GB
    Browser
    Chrome
    Antivirus
    Kaspersky Internet security 2014

popeye

New Member
VIP Member
Guru
United States

Posts
3,090
#6
Honestly a bit stumped since you say it is recognized in Ubuntu. Windows repair install maybe, perhaps someone else has some ideas.
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64-bit
    Computer type
    Laptop
    System Manufacturer/Model Number
    Acer V3 771G-6443
    CPU
    i5-3230m
    Motherboard
    Acer VA70_HC (U3E1)
    Memory
    8GB DDR3 PC3-12800 (800 MHz)
    Graphics Card(s)
    HD4000 + GeForce GT 730M
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    17" Generic PnP Display on Intel HD Graphics 4000
    Screen Resolution
    1600x900 pixels
    Hard Drives
    Samsung SSD 850 EVO 250 GB
    ADATA SSD SP900 128GB
    PSU
    90 watt brick
    Mouse
    Bluetooth
    Antivirus
    Comodo
    Other Info
    Asus RT-AC56R dual-band WRT router (Merlin firmware). Intel 7260.HMWWB.R dual-band ac wireless adapter.

dreamer

Member
Member
Posts
53
#7
Thanks for your help Popeye.I am stumped too as the ethernet controller is working perfectly fine in ubuntu.In fact i am typing this post on ubuntu with my iphone connected through the USB wire.:cry:
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    Laptop
    System Manufacturer/Model Number
    DELL Inspiron 14R N4010
    CPU
    Intel i3 2.4 Ghz
    Memory
    6 GB
    Graphics Card(s)
    Intel Integrated HD
    Screen Resolution
    1366*768
    Hard Drives
    320 GB
    Browser
    Chrome
    Antivirus
    Kaspersky Internet security 2014

Users Who Are Viewing This Thread (Users: 0, Guests: 1)