• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Dual drive, dual OS Boot, not GUI boot menu.


JoesMorgue

Insane Lunatic
Over there!

Posts
23
#1
My computer has Windows 8.1 Pro x64 on an SSD. It's that free Windows 8DL MS offered before Windows 8 was released. My son did the 8.1 upgrade. This is the boot drive.

The second OS is Windows 7 Ult. x64 on an HHD.

Until last week, the SSD had Windows 7, and 8 was on the HDD. The SSD is the primary boot drive, and the default OS.

RIGHT before I did the swap, The boot menu came up in GUI, thought it was nicer than the text one.

The boot drive followed Windows 8. [Was the HDD, now the SSD]

After the swap, I'm back to a text based menu.

After a search without results, I sent a message to Brink who very quickly pointed me to the link I wanted. [This one: http://www.eightforums.com/tutorials/5245-startup-options-enable-disable-windows-8-a.html ]

I was so happy to see that in the first picture of the command prompt, my "default" and my "identifier" was the same as in the picture, but the "description" was different. My logic told me that the desc was not as important, so I did a copy/paste of the command from Brink's post to turn on the GUI, and rebooted to find a text based boot manager.
 

My Computer

System One

  • OS
    Win8.1x84 [SSD] / Win7 Ult x64 [HD]
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom [Compaq Presario CASE]
    CPU
    AMD FX-8150
    Motherboard
    Asus
    Memory
    16 Gigs
    Graphics Card(s)
    Internal
    Sound Card
    Internal
    Monitor(s) Displays
    19" & 32"
    Screen Resolution
    1440 x 900, and ??? [1080p?]
    Hard Drives
    SSD, 2 Laptop HDs, Server with ~5TBs
    PSU
    Internal
    Case
    Compaq
    Cooling
    Air
    Keyboard
    Wireless/Wireless
    Mouse
    Wireless/Wireless
    Browser
    IE
    Antivirus
    Security Essentials

Superfly

Developer
VIP Member
Guru
Cape Town

Posts
1,098
#2
bcdboot %windir% should rebuild the GUI.

Edit: Run as admin (from system folder)
 

My Computer

System One

  • OS
    PC-DOS v1.0
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    IBM
    CPU
    Intel 8088, 4.77MHz
    Memory
    16K, 640K max
    Graphics Card(s)
    What's that?
    Sound Card
    Not quite
    Screen Resolution
    80 X 24 text
    Hard Drives
    dual 160KB 5.25-inch disk drives