What's new

Dual Boot Win7 & 8 problems - Windows 8 won't start

Brad P

Member
Member
Hoping someone can help me.

I have a ASUS P5Q Pro with the Intel raid chipset. I had Windows 7 on a RAID1 mirror (2 drives), Windows on a C partition and my files on another partition.

I bought the Win8 upgrade and put it on a USB stick. I installed a 250GB Samsung SSD and another 1TB to act as my D drive for my files. I would get the Windows 8 boot menu with the option to start either or. Note that when I installed 8, I still had my Windows 7 drive connected. So my Windows 8 drive does not have a System Reserve space (I only learned of this since my problem).

So I was ready to give up Windows 7 yesterday, and planned to take one of the two hard drives of the Win 7 mirror and use to mirror the new 1TB D drive. I figured I could still start Win 7 and hence the boot menu even on a degraded array. I've booted on a degraded array before, prior Win 8.

But when I booted, I didn't get the boot menu. Only Win8 trying to start diagnostics and auto repair but not getting anywhere. I put the removed hard drive back in to get the mirror back as it was before, and after much messing around booting off the USB stick and using bootrec commands under the recovery CMD to try and fix the boot loader, I finally got a Windows 7 style boot loader. I can boot to Win7 but can't boot Win8.

The current situation:
Disk 1 is the Win 7 mirror with the System reserve as the active partition.
Disk 2 is the Win8 SSD and that is also marked as active. It shows up in Win7 but says location is not available when I try to view files.

I have done the bootrec scanos to try and find Windows 8 but can't find any OSs.

I also did a chkdsk /r /f on the SSD and that fixed up some errors but still no luck.

I'm wondering if the boot menu I have now is a Windows 7 boot menu as I may have told it to copy boot files from my Win7 installation. If I select Windows 8 in the menu, and click F8, I can sign in with my Windows 8 password and get to the recovery console that way. I did not get a login prompt when booting off the USB stick. I may try to run the bootrec commands again from here and try to get it to copy files from the Win8 installation. Although I tried that earlier by entering bcdboot c:\windows, unable to load MUI file for BCD strings". I may not have used the correct drive letter.

It just seems to be the Win8 disk is locked, or inaccessible in some way. I am running out of options minus reinstalling everything. I finally had Win8 the way I wanted it and don't want to erase weeks of setting it up.

Thanks, I'm out of town for the night so I hope to try again tomorrow evening. Any suggestions is appreciated.
 
Last edited:

My Computer

System One

  • OS
    Windows 7 Ultimate

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top