• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Disabling Driver Signature Enforcement, permanently.


joealker

New Member
Posts
7
#1
I have an Xbox Controller S running on XBCD drivers for my Windows 8 computer. When I used these drivers on my Windows 7 laptop, I used DSEO to enable test mode, and it worked perfectly. Using the same method sends Windows 8 into a BSOD, so that's out of the question. The other solution is to reboot from the Settings menu and manually disable it at EVERY STARTUP. Not something I want to be doing, for it will probably wear out something in the computer before long. So, is there any other ways to disable DSE without rebooting every time I want to use the controller?

My computer is a 5-month old ASUS M11BB, 3.7GHz AMD A4, with Win8 64-bit installed, if that's any help.
 

My Computer

System One

  • OS
    Windows 8 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    ASUS M11BB
    CPU
    AMD A4 3.7 GHz
    Memory
    4GB
    Graphics Card(s)
    AMD RADEON w/ 768MB Memory
    Browser
    Mozilla Firefox
    Antivirus
    N/A

topgundcp

Well-Known Member
VIP Member
Guru
San Jose - California

Posts
2,847
#2
  1. Win+X then press A
  2. Type: shutdown /r /o /t 0 <==== system will reboot to Recovery Mode
  3. Trouble Shoot->Advanced->Startup Settings->Disable Driver Signature

Hope this helps !!!
 

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox

joealker

New Member
Posts
7
#3
That's a similar method to what I used to do, and has the same effect: only disabling DSE for that startup. When I reboot it returns to normal.
 

My Computer

System One

  • OS
    Windows 8 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    ASUS M11BB
    CPU
    AMD A4 3.7 GHz
    Memory
    4GB
    Graphics Card(s)
    AMD RADEON w/ 768MB Memory
    Browser
    Mozilla Firefox
    Antivirus
    N/A

topgundcp

Well-Known Member
VIP Member
Guru
San Jose - California

Posts
2,847
#4
OK. Then try:

  1. Win+R->GPEdit.msc
  2. User Configuration -> Administrative Templates -> System -> Driver Installation -> Code signing for drivers
  3. Click on "Disabled", then on "OK".
 

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox

joealker

New Member
Posts
7
#5
Slight problem:
gpeditkfsjo.png
 

My Computer

System One

  • OS
    Windows 8 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    ASUS M11BB
    CPU
    AMD A4 3.7 GHz
    Memory
    4GB
    Graphics Card(s)
    AMD RADEON w/ 768MB Memory
    Browser
    Mozilla Firefox
    Antivirus
    N/A

topgundcp

Well-Known Member
VIP Member
Guru
San Jose - California

Posts
2,847
#6

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox

topgundcp

Well-Known Member
VIP Member
Guru
San Jose - California

Posts
2,847
#7
OK. Try from Admin command prompt:
  1. bcdedit.exe -set loadoptions DDISABLE_INTEGRITY_CHECKS
  2. bcdedit.exe -set TESTSIGNING ON
 

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox

joealker

New Member
Posts
7
#8
That was the first thing I did. Didn't seem to work, but will retry tomorrow.
 

My Computer

System One

  • OS
    Windows 8 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    ASUS M11BB
    CPU
    AMD A4 3.7 GHz
    Memory
    4GB
    Graphics Card(s)
    AMD RADEON w/ 768MB Memory
    Browser
    Mozilla Firefox
    Antivirus
    N/A

joealker

New Member
Posts
7
#9
CMD claims "operation completed successfully". Fair enough, but after a full shutdown and reboot (not restart) it doesn't work again.

EDIT: Windows is in Test Mode, it says so. But it doesn't recognise the controller.
 
Last edited:

My Computer

System One

  • OS
    Windows 8 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    ASUS M11BB
    CPU
    AMD A4 3.7 GHz
    Memory
    4GB
    Graphics Card(s)
    AMD RADEON w/ 768MB Memory
    Browser
    Mozilla Firefox
    Antivirus
    N/A

joealker

New Member
Posts
7
#10
Right, after a week of trying different things, including updating to Windows 8.1, still the only way to disable DSE is the restart. Any more ideas?
 

My Computer

System One

  • OS
    Windows 8 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    ASUS M11BB
    CPU
    AMD A4 3.7 GHz
    Memory
    4GB
    Graphics Card(s)
    AMD RADEON w/ 768MB Memory
    Browser
    Mozilla Firefox
    Antivirus
    N/A

erpster4

Member
Member
Posts
104
#11
OK. Try from Admin command prompt:
  1. bcdedit.exe -set loadoptions DDISABLE_INTEGRITY_CHECKS
  2. bcdedit.exe -set TESTSIGNING ON
about this; the bcdedit DDISABLE_INTEGRITY_CHECKS command works, BUT the bcdedit.exe -set TESTSIGNING ON command WILL FAIL BIGTIME if the SECURE BOOT option is turned on! I got an error message when running that bcdedit TESTSIGNING command because the Secure Boot feature on a modern Toshiba laptop prevents that command from working correctly. Go inside UEFI firmware setup and look for the Secure Boot option (either under the Security menu or Boot menu) and set that to No, Off or Disabled. Then save changes and boot into Windows, run an elevated Command Window with Administrative rights and retry the bcdedit.exe -set TESTSIGNING ON command.

btw, here's the MS Technet page on disabling the Secure Boot option.

Since there's no reliable way to actually disable driver signature permanently in Win8, one could try the following in creating a separate boot entry that allows no signature driver checks. I haven't tried that one yet. Still requires the Secure Boot option to be turned off as well as disabling the User Account Control [UAC] feature completely (yes folks, if you want to ensure that non signed drivers get installed properly, UAC should be turned off completely). You can enable UAC after installing any unsigned drivers.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model Number
    Toshiba Satellite C55Dt-A5306
    CPU
    AMD Quad-Core A6-5200M Accelerated Processor
    Memory
    4 GB

csrepsol

New Member
Posts
2
#13
So i had the same problem, but i have an old camera, that could only work if i boot up my windows without DSE. This is what helped me:

STEP 1. I boot up my windows without DSE: Win+X then press A
Type: shutdown /r /o /t 0 <==== system will reboot to Recovery Mode
Trouble Shoot->Advanced->Startup Settings->Disable Driver Signature


STEP 2. I disable DS in gpedit:Win+R->GPEdit.msc
User Configuration -> Administrative Templates -> System -> Driver Installation -> Code signing for drivers
Click on "Disabled", then on "OK".


Now when i boot up my windows normaly, my driver is working thanks to topgundcp.
.
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center

erpster4

Member
Member
Posts
104
#14
STEP 2. I disable DS in gpedit:Win+R->GPEdit.msc
User Configuration -> Administrative Templates -> System -> Driver Installation -> Code signing for drivers
Click on "Disabled", then on "OK".


Now when i boot up my windows normaly, my driver is working thanks to topgundcp.
.
csrepsol: the problem is that some editions of Windows 8/8.1 (aka. Core or Home) do not include GPEdit.msc and that file won't work on those editions.
so your solution will only work with the Professional and Enterprise editions of Windows 8.x.

nice try though. :)
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model Number
    Toshiba Satellite C55Dt-A5306
    CPU
    AMD Quad-Core A6-5200M Accelerated Processor
    Memory
    4 GB

csrepsol

New Member
Posts
2
#15
Yes, you are right. I am using Windows 8.1 Pro.
But todays update, it does NOT work. I have to start windows with DSE disabled anyway.
Yesterday was working fine, but today it does not.
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center