What's new

Disable LCD speakers auto set as default output device

Anakunda

Member
Member
Hi
Each time I turn off and on my extarnal LCD with (crappy) built-in speakers, they're detected as new attached hardware and auto set themselves as default instead of my preferred speakers. Can this be somehow disabled (possibly without disabling the LCD driver from system), it's irritating.
 

My Computer

System One

  • OS
    Windows 8.1 Enterprise 64bit
    Computer type
    Laptop

Winuser

Power User
VIP Member
Power User
With the HP monitor I had; All I had to do was unplug the speakers.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    HP ENVY 700-074
    CPU
    Intel Core i5 4430 @ 3.00 GHz
    Motherboard
    MS-7826 (Kaili)
    Memory
    12 GB
    Graphics Card(s)
    Nvidia GeForce GT 740
    Sound Card
    Integrated IDT 92HD68E2 Audio
    Monitor(s) Displays
    Samsung S27C230B
    Screen Resolution
    1920 x 1080
    Hard Drives
    240 GB Kingston SSDNow V300 Series
    PSU
    stock
    Case
    stock
    Cooling
    stock
    Keyboard
    Logitech K520
    Mouse
    Logitech M310
    Browser
    Fire Fox
    Antivirus
    Eset Smart Security 7

Anakunda

Member
Member
How U mean unplug the speakers? I wrote, they're embedded itto the LCD body. I don't use separate cable, they're supplied along with HDMI cable.
 

My Computer

System One

  • OS
    Windows 8.1 Enterprise 64bit
    Computer type
    Laptop

Winuser

Power User
VIP Member
Power User
My HP monitor with built in speakers used a separate cable from the monitor to the sound card. If you had mentioned it was through a HDMI cable I wouldn't have answered.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    HP ENVY 700-074
    CPU
    Intel Core i5 4430 @ 3.00 GHz
    Motherboard
    MS-7826 (Kaili)
    Memory
    12 GB
    Graphics Card(s)
    Nvidia GeForce GT 740
    Sound Card
    Integrated IDT 92HD68E2 Audio
    Monitor(s) Displays
    Samsung S27C230B
    Screen Resolution
    1920 x 1080
    Hard Drives
    240 GB Kingston SSDNow V300 Series
    PSU
    stock
    Case
    stock
    Cooling
    stock
    Keyboard
    Logitech K520
    Mouse
    Logitech M310
    Browser
    Fire Fox
    Antivirus
    Eset Smart Security 7

Itaregid

Banned
This is happening because you are connecting your monitor via HDMI and during your graphics card installation, audio was directed through the graphics card. Since many users use computer speakers instead of speakers integrated with their monitors, there should be a setting in your graphics card's control panel to disable sound via HDMI.
 

My Computer

System One

  • OS
    W10 Pro
    Computer type
    PC/Desktop

Barman58

Super Moderator
Super Moderators
Easiest way is to right click on the Speaker icon in the Notifications area, select Playback devices and set the device you want use as the default device :)
 

My Computer

System One

  • OS
    Windows 10 Pro x64 x2 Windows 10 Enterprise x64, Ubuntu
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Real World Computing
    CPU
    AMD FX8350 8 Core @4GHz
    Motherboard
    Asus M5A78L-M USB3
    Memory
    32GB [4x8GB] DDR3 1600 MHz
    Graphics Card(s)
    Asus nVidia GTX750TI-OC-2GD5 (2GB DDR5)
    Sound Card
    ASUS Xoner DG + SPDIF to 5.1 System + HDMI
    Monitor(s) Displays
    Acer G276HL 27", (DVi) + Samsung 39" HDTV (HDMI)
    Screen Resolution
    1920 x 1080 @60Hz + 1920 x 1080 @60Hz
    Hard Drives
    Internal
    Crucial 256GB SSD,
    WDC WD30EZRX-00D8PB0 3TB,
    Toshiba HDWD130 3TB
    Seagate ST2000DM001-1CH1 2TB,

    External (USB3)
    Seagate Backup+ Hub BK SCSI Disk 8TB
    2.5/3.5 Hot Swap Cradle, USB3 + eSata (client HDDs)

    NAS
    Seagate ST4000DM000
    PSU
    Aerocool Templarius Imperator 750W 80+ Silver
    Case
    AeroCool X-Warrior Devil Red Tower
    Cooling
    Stock CPU, Rear 120mm, Front 2x120mm, Side 2x120mm
    Keyboard
    Logitech Wireless K710 & K270
    Mouse
    Logitech Wireless M710 M185 & M570 Trackball
    Internet Speed
    37Mb/s Down - 9.5Mb/s Up
    Browser
    Chrome
    Antivirus
    BitDefender Total Security 2017
    Other Info
    Also run...

    Desktop - 6Core 8GB - Windows 10 Enterprise x64,
    Laptop - Quad 8GB - Windows 10 Pro x64
    Netbook - Ubuntu
    2 x Nexus 7 Android tablets
    Samsung 10.2" tablet
    Sony Z3 Android Smartphone
    HTC One Android Smartphone

Anakunda

Member
Member
That's right but the selection is changed every time LCD is disconnected to favour of LCD speakers. (Not me ). Right click the LCD speakers and disable device prevents that but LCD speakers aren't then available.
 

My Computer

System One

  • OS
    Windows 8.1 Enterprise 64bit
    Computer type
    Laptop

Itaregid

Banned
I say again, this is due to audio being piped through the HDMI connection and needs to be disabled in the graphics control panel. If your card and monitor support it, you might try DVI and separate audio cables.

Also, just to avoid confusion over terminologies - there is no such thing as "LCD speakers". Please use monitor's speakers.
 

My Computer

System One

  • OS
    W10 Pro
    Computer type
    PC/Desktop

Anakunda

Member
Member
Alright, monitor speakers

DVI is no good, it degrades refresh rate so HDMI is only connection.

I look GPU control and see only audio setting in Display > Audio settings > Audio without picture - Enable / Disable

I try both settings and they don't make any difference.
At worst in Audio > Playback > Monitor speakers right click menu > Disable is workaround for this
 

My Computer

System One

  • OS
    Windows 8.1 Enterprise 64bit
    Computer type
    Laptop

Itaregid

Banned
DVI is no good, it degrades refresh rate so HDMI is only connection.
Not true at all. Got a link to where you read that incorrect information?

The video signal carried by HDMI and DVI is exactly the same. Remember, HDMI came out of the home theater universe to reduce the rats nests of cables interconnecting the various devices (DVD/Blu-ray, HT receivers, DVRs, and TVs). The only reason DVI support is dwindling is because (1) the video signal is exactly the same and (2) monitor makers (who just happen to be the same folks who make big screen TVs) don't want to deal with the logistics of supporting two types of connectors that carry the same video signal, and (3) DVI connectors are big.

DVI vs. HDMI vs. Component Video - Which is Better? - eCoustics.com
HDMI to DVI: Same Format, Different Uses | HDMI
 

My Computer

System One

  • OS
    W10 Pro
    Computer type
    PC/Desktop

strollin

Old Guys Rule!
VIP Member
Pro User
Another option might be to see if there is the ability to disable the speakers in the monitor's settings menu. Can you post the brand/model of the monitor you are using?
 

My Computer

System One

  • OS
    W10 Pro (desktop), W10 (laptop), W10 Pro (tablet)
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built i7-8700K, Hp Envy x360 EVO Laptop, MS Surface Pro 7
    CPU
    3.7Ghz Core i7-8700K, 11th Gen Core i7-1165G7 4.7Ghz, 10th Gen Core™ i5-1035G4 1.1Ghz
    Motherboard
    ASUS TUF Z370-Pro Gaming, HP, MS
    Memory
    16G, 8G, 8G
    Graphics Card(s)
    AMD Radeon RX580, Intel Iris X Graphics, Intel Iris Plus Graphics G4
    Sound Card
    ATI High Definition Audio (Built-in to mobo)
    Monitor(s) Displays
    Dual Samsung U32J59 32 inch monitors, 13.3" display, 12.3" display
    Screen Resolution
    3840x2160 (Desktop), 1920x1080 (laptop), 2736x1824 Pro 7
    Hard Drives
    500GB ssd boot drive with 2 & 10TB Data (Desktop), 512GB ssd (laptop), 128GB SSD (tablet)
    PSU
    Corsair CX 750M
    Case
    Antec 100
    Cooling
    Coolermaster CM 212+
    Keyboard
    IBM Model M - used continuously since 1986
    Mouse
    Microsoft IntelliMouse
    Internet Speed
    665Mbps/15Mbps down/up
    Browser
    FireFox, MS Edge
    Antivirus
    Defender on all
    Other Info
    Retired in 2015 after working in the tech industry for 41 years. First 10 years as a Technician, the rest as a programmer/software engineer. After 1 year of retirement, I was bored so went back to work as a Robotic Process Automation Consultant. Retired for 3rd (and final) time in 2019.

Anakunda

Member
Member
There's only limited settings

DSC_0267.JPG
 

My Computer

System One

  • OS
    Windows 8.1 Enterprise 64bit
    Computer type
    Laptop

strollin

Old Guys Rule!
VIP Member
Pro User
Yes, have you tried other options besides Auto Select for PC Audio?
 

My Computer

System One

  • OS
    W10 Pro (desktop), W10 (laptop), W10 Pro (tablet)
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built i7-8700K, Hp Envy x360 EVO Laptop, MS Surface Pro 7
    CPU
    3.7Ghz Core i7-8700K, 11th Gen Core i7-1165G7 4.7Ghz, 10th Gen Core™ i5-1035G4 1.1Ghz
    Motherboard
    ASUS TUF Z370-Pro Gaming, HP, MS
    Memory
    16G, 8G, 8G
    Graphics Card(s)
    AMD Radeon RX580, Intel Iris X Graphics, Intel Iris Plus Graphics G4
    Sound Card
    ATI High Definition Audio (Built-in to mobo)
    Monitor(s) Displays
    Dual Samsung U32J59 32 inch monitors, 13.3" display, 12.3" display
    Screen Resolution
    3840x2160 (Desktop), 1920x1080 (laptop), 2736x1824 Pro 7
    Hard Drives
    500GB ssd boot drive with 2 & 10TB Data (Desktop), 512GB ssd (laptop), 128GB SSD (tablet)
    PSU
    Corsair CX 750M
    Case
    Antec 100
    Cooling
    Coolermaster CM 212+
    Keyboard
    IBM Model M - used continuously since 1986
    Mouse
    Microsoft IntelliMouse
    Internet Speed
    665Mbps/15Mbps down/up
    Browser
    FireFox, MS Edge
    Antivirus
    Defender on all
    Other Info
    Retired in 2015 after working in the tech industry for 41 years. First 10 years as a Technician, the rest as a programmer/software engineer. After 1 year of retirement, I was bored so went back to work as a Robotic Process Automation Consultant. Retired for 3rd (and final) time in 2019.

Anakunda

Member
Member
I did try change from AutoDetect to PC Audio and only effect I observe is that the monitor speakers don't play if I use monitor speakers as output device. In AutoDetect mode they do play.
The manual is not descriptive on this option - >>Allow users to select the audio source or let the monitor detect it automatically.<<

But now system default playback device seems to keep on external speakers over several PC restarts without having disable the monitor audio. I'll see if he selection will persist.

I'm having yet another problem with the LCD not going into sleep after inactivity timeout but I'll rather ask this in new topic.
Meanwhile thanks for advices.
 

My Computer

System One

  • OS
    Windows 8.1 Enterprise 64bit
    Computer type
    Laptop
Top