• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Different Color on same video in different players


blueelvis

OMG Debugger!
VIP Member
Pro User
India

Posts
2,097
#1
Hello everyone ^_^,

So, since I installed Windows 8.1 , there has been this very strange problem with Windows Media Player where it displays every video which is highly saturated or we can say that it appears very odd. Whereas in the case of VLC, it displays the video appropriately. I have attached the screenshots below. I checked every setting of the Windows Media Player and it is at it's default setting. Please help me on how to solve this problem ^_^.
 

Attachments

My Computer

System One

  • OS
    Windows 8.1 Industry Pro B-)
    Computer type
    Laptop
    System Manufacturer/Model Number
    Toshiba
    CPU
    Core I5 2430M @ 2.4GHz
    Memory
    8 GB DDR3 @ 1600MHz Dual Channel ^_^
    Graphics Card(s)
    Intel HD 3000 B-)
    Screen Resolution
    1366x768
    Hard Drives
    Toshiba 500 GB
    Browser
    Google Chrome
    Antivirus
    Windows Defender & Common Sense!

CountMike

Well-Known Member
VIP Member
Guru
Belgrade , Serbia

Posts
4,664
#2
Could be codecs, VLC has it's own and WMP uses windows codecs .
Don't know about those Intel drivers but most other have setting for video to use Widows default settings or application settings. With AMD drivers it can make quite a difference.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home made
    CPU
    AMD Ryzen7 2700x
    Motherboard
    Asus Prime x470 Pro
    Memory
    16GB Kingston 3600
    Graphics Card(s)
    Asus strix 570 OC 4gb
    Hard Drives
    Samsung 960 evo 250GB
    Silicon Power V70 240GB SSD
    WD 1 TB Blue
    WD 2 TB Blue
    Bunch of backup HDDs.
    PSU
    Sharkoon, Silent Storm 660W
    Case
    Raidmax
    Cooling
    CCM Nepton 140xl
    Internet Speed
    40/2 Mbps
    Browser
    Firefox
    Antivirus
    WD

blueelvis

OMG Debugger!
VIP Member
Pro User
India

Posts
2,097
#3
Could be codecs, VLC has it's own and WMP uses windows codecs .
Don't know about those Intel drivers but most other have setting for video to use Widows default settings or application settings. With AMD drivers it can make quite a difference.
The same videos looked same in Windows 8. I wonder if they are caused due to the Intel's Graphics drivers. I will look around and see what I could find inside the settings of the driver.

Thanks!


EDIT :- THanks CountMike for the advice. I checked the Driver settings and found that it was set to Driver Settings(In The Media Tab). I set it to Application Defaults and the WMP is not working fine. Thanks for your help mate;). But, one thing which is not clear to me is that why the VLC not showing colors like WMP? o_O
 

My Computer

System One

  • OS
    Windows 8.1 Industry Pro B-)
    Computer type
    Laptop
    System Manufacturer/Model Number
    Toshiba
    CPU
    Core I5 2430M @ 2.4GHz
    Memory
    8 GB DDR3 @ 1600MHz Dual Channel ^_^
    Graphics Card(s)
    Intel HD 3000 B-)
    Screen Resolution
    1366x768
    Hard Drives
    Toshiba 500 GB
    Browser
    Google Chrome
    Antivirus
    Windows Defender & Common Sense!

CountMike

Well-Known Member
VIP Member
Guru
Belgrade , Serbia

Posts
4,664
#4
Codecs and filters applied to them mostly. I find some difference in color ( also sharpness etc.) even between VLC and POT player.
If you install different codec packs you can see which filters can be applied and choose ones you want to be default. i was never thrilled with WMP anyway as other were and are much more flexible. Haven't used WMP lately but it could not display subtitles and DVD menus so it was pretty useless to me. Pot Player can also display 3D video with option to display same in 2D too.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home made
    CPU
    AMD Ryzen7 2700x
    Motherboard
    Asus Prime x470 Pro
    Memory
    16GB Kingston 3600
    Graphics Card(s)
    Asus strix 570 OC 4gb
    Hard Drives
    Samsung 960 evo 250GB
    Silicon Power V70 240GB SSD
    WD 1 TB Blue
    WD 2 TB Blue
    Bunch of backup HDDs.
    PSU
    Sharkoon, Silent Storm 660W
    Case
    Raidmax
    Cooling
    CCM Nepton 140xl
    Internet Speed
    40/2 Mbps
    Browser
    Firefox
    Antivirus
    WD