• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Diamond VC500 USB Video Capture Device


Ctopkis

New Member
Posts
1
#1
I just installed Windows 8 pro. I have a VC500 USB video capture device. I get the yellow triangle with the exclamation point. The error is a code 10; device cannot be started. Tried all the things I could find; updating drivers; uninstalling / reinstalling; with no success. While I bought this some time ago, Diamonds web site for this device says "support for Windows 8" but they don't offer any windows 8 device driver. I'm really not sure what support for Windows 8 really means. This device ran in Windows 7 but the software had to run under XP SP3. Didn't have any problem with the device driver. Tried all the compatibility settings I could find but no luck. Any help would be appreciated.

System Model HP- h8-1000z
Processor AMD Phenom(tm) II 840T, 2.9 Mhz, 4 Cores
Bios American Megatrends 6.12 dated 5/4/2011 (Couldn't find anything newer)
Motherboard Foxconn H-RS880-uATX(ALOE)
Memory 8.00 GB

Problem Device VC500 Video
PNP Device ID USB\VID_07DE&PID_2820|USB_Device (Whatever that means)
Error Code Thsi device cannot start.

Again, appreciate any help.

Chas
 

My Computer

System One

  • OS
    Windows 8
    System Manufacturer/Model
    HP Pavilion HPE h8-1000z CTO Desktop
    CPU
    AMD Phenom(tm) II X4 840T Processor,2900 Mhz, 4 cores
    Motherboard
    Foxconn H-RD880-uATX (Aloe)
    Memory
    8.00 gb
    Graphics Card(s)
    Nvidia GeForce GT 530

Firepsych

New Member
Posts
1
#2
I tried installing the drivers from the Diamond web site as well as from the Diamond installation disk, but neither would install. this is what worked for me:
1. Open the Device Manager (right click on "Computer" & chose properties and then open Device Manager top left corner)
2. Under "Other Devices" you should see OTG102 with an exclamation mark in a yellow triangle, right click on this and choose "Update driver software"
3. Choose "Browse my computer" and navigate to the drive where the driver/software disk from Diamond is located and open the "Driver" folder.
4. Choose the x64 folder if you are running a 64bit system or x86 if you are running a 32bit system then choose the 64inf or 86inf folder again depending on your system.
5. The drivers should now load with no problems (at least they did for me).
Hope this works for you.
Firepsych
 

My Computer

System One

  • OS
    W8

Users Who Are Viewing This Thread (Users: 0, Guests: 1)