• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Dell Inspiron 15 with Windows 8 is not recognizing AMD Rad


Moish

New Member
Posts
6
#1
Hi.


Yesterday, I restored my Inspiron 15 to it's factory settings.
Post-reset, I installed all drivers for Windows 8 directly from the Dell website except for the AMD driver which I took from the AMD website (just wanting to get the latest directly from the source, I guess). I also used that "Dell Detect" thingy to make sure I have all the latest drivers for everything.


After installing, everything worked great, but I realized that when the display turns off / when I shut down the laptop / when I close the lid, it does not turn off the computer or hibernating it or making go to sleep - it just keep running but there is no display, total darkness. Trying to press the power button / F4-F5 / any other button-pressing related solution did not work, only hard-reset.


Googling this issue, I found that it is very common, and many people with almost brand new Dell laptops, just like me, have encountered the same problem. After much research, I found some suggested solutions. In most of the solutions offered it was said that doing so would cause the system to mainly use the Intel Graphics HD card and not the AMD, meaning that for games and graphics, the AMD won't matter, which doesn't seem to be fair after paying extra exactly so I can have a dedicated card.


Either way, I started with the first which was using Windows Update. After checking the Windows Update updates list, I saw 2-graphic card related items - something called Graphics Adapter WDDM, one for the AMD card and the other for the Intel Graphics HD. After installing this update, I realized I can successfully turn off the laptop.




Once I turned it back on this morning, I got a pop-message:





I then realized that it just simply doesn't see/use/detect the AMD card.
This is how my AMD Catalyst looks right now:








Looking at Everest, you can see it only sees the Intel Graphics HD:










However, device manager is still listing the AMD card as if it's properly working:







And if you look at the event log, you can see that initial driver was installed right after the Windows 8 fresh install I made a day and a half ago, and then there's other events, last night, around the time when I installed the Windows Update thingy:







Any suggestion or help you can provide will be great,
Thanks in advanced! :)
 

My Computer

System One

  • OS
    Win8

werty

Member
Member
Posts
187
#2
Hi, if I`m correct you have installed the Windows update without uninstalling the Catalyst Control Centre. You should first uninstall CCC and then install the driver from Windows Update. The sleep issue is very common - if the latest drivers from AMD didn't work for you, you should try those provided by your PC manufacturer.
Note: completely uninstall Catalyst software before installing different driver.

Good luck, werty
 

My Computer

System One

  • OS
    Windows 8.1 Pro/ Windows 8 Enterprise
    Computer type
    Laptop
    System Manufacturer/Model Number
    Dell Inspiron 1545/ Asus F5V

Users Who Are Viewing This Thread (Users: 0, Guests: 1)