What's new

Consistent temporary network error

JohnOfE

Member
Member
Does anyone experience a delay in being able to access a network share? Upon going to Network and clicking on the desired computer, I get a network error; it cannot find the destination machine.

After about 30 seconds of trying and trying again, it lets me in.

I go into Network:
Clipboard01.jpg

Then I try again after a minute or so:
Clipboard02.jpg

And it lets me in no problem.

I can get by but it's just a PAIN, like going over 100 speed bumps on a long road. You get there eventually but honestly; it should just let me in first time every time!

All my shares have their security set to allow full access to EVERYONE and are shared through your usual share and specify permission. I don't bother with Home group as this 30 second access denied routine makes the home group unusable.

I have a few other computers on the network and they all do the same thing to every other computer. Sometimes they let you in first time, but sometimes not.

Anyone got the same? Any suggestions?
 

My Computer

System One

  • OS
    Windows 8 Pro Pack x64
    System Manufacturer/Model
    JohnOfE Special
    Other Info
    Too many systems and combinations!

mrq2

New Member
Exact Same Problem

On our network (wired) there are 3 computers - 1 Windows 7 Ultimate, 2 Windows 8 Pro. The Windows 8's were fresh
clean installs - 1 BIOS and the other UEFI. The Windows 7 machine connects immediately to either Windows 8 machine. But through "Advanced Sharing" (no Homegroup) both Windows 8 machines trying to connect to any computer get the 0x80070035 error, when I try about 30 seconds later it connects no problem.
If I use "Homegroup" I don't get the delay. I just don't like Homegroup, I want to share data drives not libraries. But here's the funny thing, if I connect through Homegroup first then immediately try via network there is no delay, but if I try through network first (of course I'll get an error) and then immediately try via Homegroup, now I'll have about a 30 second delay there also. I tried static IP's (after using DHCP) on the Windows 8 machines - no difference. Local Security Policy settings are all the same as the Windows 7 machine (note there are a few more settings in Windows 8). If I try by IP adress (192.168.x.x), it connects instantly. I'm hoping someone has some ideas.

Windows 8
Private Network
Network Discovery=ON
File and Printing Sharing=ON
Allow Windows to manage Homgroup connections (recommended)=ON
Password protected sharing=OFF
Sharing 1 data drive per computer with both "Sharing" and "Security" set to 'Everyone" - "Full Control"
Network Adapter drivers = all up to date
Adapter Properties = Client for Microsoft networks - QoS Packet Scheduler - File and Printer Sharing for Microsoft
Networks - Microsoft LLDP Protocol Driver - Link-Layer topology Discovery Mapper I/O Driver - Link-Layer topology
Discovery Responder - Internet Protocol Version 6 (TCP/IPv6) - Internet Protocol Version 4 (TCP/IPv4)
 
Last edited:

My Computer

System One

  • OS
    Windows 8 Pro x64
    CPU
    Intel E4300
    Motherboard
    P5G41T-M LX Plus
    Memory
    4G

PenguinHurter

New Member
I am also having this problem, and am at wits end. :mad:

I went ALL IN with Windows 8. I have the Surface Pro and a desktop, htpc, and NAS server all running Windows 8. I set up the homegroup (mainly because the music app is a piece of poop that won't see my music on the NAS unless it's in a Library).

I have tried what little I could find on the internet that seemed related such as disabling IPv6, turning off the indexing services, and turning off generating emails. All of these did not seem to fix the problem.

My guess is it's something to do with File Explorer itself. I might try using an alternative file browser and see what happens.
 

My Computer

System One

  • OS
    Windows 8
    Computer type
    PC/Desktop

Cyberwaste

New Member
I made an account just to post and say I have the same problem with my new laptop (win8) when trying to access my desktop machine (win7).

I've gone through every step I can think of to resolve the issue but to no avail. I'm happy (not in a vindictive way) that I'm not the only one suffering from this problem.

Hopefully someone knows a fix or Microsoft are aware of the issue and we can network in peace.
 

My Computer

System One

  • OS
    Windows 7 Pro, Windows 8 Pro
    Computer type
    Laptop
    System Manufacturer/Model
    HP Envy
    CPU
    i7
    Memory
    8gb
    Graphics Card(s)
    Radeon 7670M
    Browser
    Chrome
    Antivirus
    AVG

Dr Gary

Member
Member
Greetings,

I too am seeing this issue and have been working on it for nearly a week. I have run a series of network traces, etc., but have not yet come up with anything concrete. I do believe it is related to an authentication challenge.

I do have one workaround which solves the issue. If you map a drive to a share, any share, on the computer(s) that you wish to access via the Network selection in File Explorer...you will no longer experience this annoying delay. This is not a fix, of course, but is a reliable workaround. I believe this persistent share mapping addresses the underlying authentication issue, but I am not sure just how yet.

I do hope that someone comes up with a fix for this. Having to map a drive to every Windows 8 system on my network in order to use File Explorer's network selection without this intermittent delay is very annoying.

Dr Gary
 

My Computer

System One

  • OS
    Windows 8 Pro, Windows 7, Windows Server 2012
    Computer type
    PC/Desktop

mick823

New Member
Member
Same problem here. You can try disabling the power management features on your network adapters. Device Manager > Network Adapters > Right click on your NIC or WIFI card > Select "properties" > Click on Power Management Tab > Untick "Allow computer to turn off this device to save power". Repeat on ALL adapters (wired and wireless) of ALL of your shared computers.

This is not a sure-fire fix by any means. Sometimes it takes 30 seconds for the initial hook up but after that the shares remain visible and accessible.


Dr. Gary's fix of mapping any share on the computer you are trying to access and having it to connect at start-up is a good work around also. I was using that before turning off the power management of my network cards to see if I get a consistent hookup. So far so good except for the slow initial share connect time.
 

My Computer

System One

  • OS
    Windows 7 Pro and Windows 8.1 Pro 32 bit and 64 bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Lenovo and Dell
    CPU
    Intel i3

Dr Gary

Member
Member
Greetings Mick,

I also disabled the power management on all the network adapters, but it had no effect in my case. I don't see how this could be the cause of this issue in any event, since, at exactly the same time that I am unable to connect to a Windows 8 computer using another Windows 8 system, I am able to consistently connect to that same Windows 8 system with a Window 7 Ultimate system.

On my network I have 12 systems. Windows XP, Windows 7, Windows 8, Windows Server 2008 R2 and Windows Server 2012.

From a Windows 8 Pro system I can consistently connect via File Explorer to Windows XP, Windows Server 2008 R2 and Windows Server 2012. The symptom only occurs when I attempt to connect from a Windows 8 Pro or Enterprise system to another Windows 8 system and occasionally to a Windows 7 Professional system. After a annoying delay displaying "Network Path is not found", connectivity returns.

I never have any issues connecting to any of the other various "flavors" from Windows 7. I have used WireShark to log network activity, but am still looking at the results. The drive mapping workaround still works for me 100% of the time.
 

My Computer

System One

  • OS
    Windows 8 Pro, Windows 7, Windows Server 2012
    Computer type
    PC/Desktop

mick823

New Member
Member
Thanks Gary,

The power management idea was something I tried out of desperation and it appeared to work at first. After a couple of days I started having issues again. I know it is aggravating as hell. The problem also affects my shared printers. No shared files = no shared printers either. I am going back to the mapped drive fix until this all gets sorted out. You would think that with some 3900+ posts here that somebody would have hit upon the answer by now.
 

My Computer

System One

  • OS
    Windows 7 Pro and Windows 8.1 Pro 32 bit and 64 bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Lenovo and Dell
    CPU
    Intel i3

Dr Gary

Member
Member
Mick,

Thanks for the update. I agree, this issue is very frustrating because of just what you mentioned, i.e.., at times, it will simply disappear, then just as quickly, reappear.

I have ruled-out a firewall bug on the non-local networked machine...simply because a Windows 7 system will always display the shares without issue. I believe this almost certainly must be an issue on the local Windows 8 client machine....i.e., the one attempting to display the shares with File Explorer.

I do see some distinct differences in network activity between a Windows 7 client and a Windows 8 client during a failed attempt. This would seem to me to be a good lead to follow. When the symptom is not occurring ...the packets look the same between a Windows 7 and a Windows 8 machine...but when the symptom appears, the Windows 8 network packets are different.

I think the share mapping workaround simply eliminates the need to re-authenticate each time you double click on a machine in File Explorer...it is in one of these re-authentication attempts that the failure occurs...at least from what I can see so far.

I did not observe this is the Windows 8 preview..although I cannot say for certain it was not present. I too am somewhat mystified that there is not a bigger outcry on the technology blogs. This is a fairly glaring issue...

Dr Gary
 

My Computer

System One

  • OS
    Windows 8 Pro, Windows 7, Windows Server 2012
    Computer type
    PC/Desktop

Dr Gary

Member
Member
One Other Observation...

Actually, after some further testing...connecting first with Remote Desktop does not prevent the issue.:mad:

The share mapping remains the only reliable workaround...sorry for the confusion...
 

My Computer

System One

  • OS
    Windows 8 Pro, Windows 7, Windows Server 2012
    Computer type
    PC/Desktop

chev65

Closed

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

Dr Gary

Member
Member
Found the Answer...

Ok...after lots of NetMon/WireShark network traces, etc., I have finally discovered the root cause of this odd issue, at least within my network. If one of the other posters to this thread could also try my "fix" to confirm these findings, it would be greatly appreciated.

The issue here is the Windows Computer Browser service. If you stop and disable this service on your client systems, this quirky network issue is completely eliminated. This finding actually fits the facts that I observed while researching this issue perfectly. For example, I mentioned in one of my prior posts that the problem did not affect access to a Windows Server 2008R2 or Windows Server 2012 machine....this is because the Computer Browser service is disabled by default on these Windows server editions.

I know that in many of the Windows shops that I have worked in over the years, the Computer Browser service is often disabled by Group Policy on all systems by the administrator. In my case, after stopping and disabling this service on all of my systems where it was running, the symptom has now completely disappeared. I also see no real negative impact to disabling this service.

This must be a bug in Windows 8 and its dealing with the remote system's Computer Browser service. What exactly this bug is, I'm not sure. Since it seems that disabling this service, even in a non-domain environment, causes no real negative ramifications, I think it is a reasonable solution. No more need to map a drive to each system.

Hopefully, Microsoft will get a fix for this..I,for one, however, will continue to simply run without this service being active on my network.

If anyone get a chance to test this in their environment, please update this thread with your findings.

Thanks,


Dr G
 

My Computer

System One

  • OS
    Windows 8 Pro, Windows 7, Windows Server 2012
    Computer type
    PC/Desktop

mrq2

New Member
I'll let you Know

I hope this solves the problem for all of us. But I can only check later, I'm at work. But no matter what, thanks for all your efforts and feedback. I'll definitely respond with my results in about 4 to 6 hours.
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    CPU
    Intel E4300
    Motherboard
    P5G41T-M LX Plus
    Memory
    4G

mrq2

New Member
Re: Found the Answer...

Ok...after lots of NetMon/WireShark network traces, etc., I have finally discovered the root cause of this odd issue, at least within my network. If one of the other posters to this thread could also try my "fix" to confirm these findings, it would be greatly appreciated.

The issue here is the Windows Computer Browser service. If you stop and disable this service on your client systems, this quirky network issue is completely eliminated. This finding actually fits the facts that I observed while researching this issue perfectly. For example, I mentioned in one of my prior posts that the problem did not affect access to a Windows Server 2008R2 or Windows Server 2012 machine....this is because the Computer Browser service is disabled by default on these Windows server editions.

I know that in many of the Windows shops that I have worked in over the years, the Computer Browser service is often disabled by Group Policy on all systems by the administrator. In my case, after stopping and disabling this service on all of my systems where it was running, the symptom has now completely disappeared. I also see no real negative impact to disabling this service.

This must be a bug in Windows 8 and its dealing with the remote system's Computer Browser service. What exactly this bug is, I'm not sure. Since it seems that disabling this service, even in a non-domain environment, causes no real negative ramifications, I think it is a reasonable solution. No more need to map a drive to each system.

Hopefully, Microsoft will get a fix for this..I,for one, however, will continue to simply run without this service being active on my network.

If anyone get a chance to test this in their environment, please update this thread with your findings.

Thanks,


Dr G

YES IT WORKS!!!!!!!!!!!!

I disabled the "Computer Browser Service" on the 3 computers on my network (1-Win7 and 2-Win8) restarted them and "How Sweet it is" no delay, works the way it should. Just to be sure I restarted all the computers (and some total shutdowns and startups) multiple times, and so far so good. I'll post back in few days to confirm my status.

Good Work Dr G, No I'm sorry - GREAT WORK Dr G
Jacques
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    CPU
    Intel E4300
    Motherboard
    P5G41T-M LX Plus
    Memory
    4G

Dr Gary

Member
Member
Great...

Jacques,

Thanks for the update. I'm glad I was able to assist you.

I now believe this change will also solve the problem for the other posters as well.

If you do see any issues, please post back to the thread.

Thanks,

Dr G
 

My Computer

System One

  • OS
    Windows 8 Pro, Windows 7, Windows Server 2012
    Computer type
    PC/Desktop

mick823

New Member
Member
Ok...after lots of NetMon/WireShark network traces, etc., I have finally discovered the root cause of this odd issue, at least within my network. If one of the other posters to this thread could also try my "fix" to confirm these findings, it would be greatly appreciated.

My windows 7 desktop was the culprit. The Computer Browser service was set to manual but was "started." I disabled and re-booted and PROBLEM SOLVED! My two WIN8 laptops were set to manual but the service was not running on either one. Just to be safe I disabled both of them anyway. It looks like Dr. Gary figured it out. Thank you, Thank you. Thank you. It was driving me nuts.
 

My Computer

System One

  • OS
    Windows 7 Pro and Windows 8.1 Pro 32 bit and 64 bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Lenovo and Dell
    CPU
    Intel i3

Dr Gary

Member
Member
Great...

Hey Mick,

Thanks for the update. I'm glad this change has solved the problem for you as well.:D

I hope the OP of this thread gives it a try and then can mark this thread solved.

Dr G
 

My Computer

System One

  • OS
    Windows 8 Pro, Windows 7, Windows Server 2012
    Computer type
    PC/Desktop

mick823

New Member
Member
Just to verify I joined my network with a seldom used older desktop that has Windows 7 Pro installed. The Computer Browser service on that computer was set to "Manual" but was "started" just like my other Win 7 Pro computer. I have never altered any services on either Win 7 computer so this must be the default condition. After starting the computer and joining the Homegroup I tried to access the shares on this older computer from a Windows 8 laptop and had trouble with sharing right away. I disable the Computer Browser service on the Windows 7 machine and got in right away without even rebooting.
 

My Computer

System One

  • OS
    Windows 7 Pro and Windows 8.1 Pro 32 bit and 64 bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Lenovo and Dell
    CPU
    Intel i3

Dr Gary

Member
Member
You are Correct...

The Computer Browser service has the following default start options:

Windows XP == Automatic
Windows 7 & 8 == Manual
Windows Server Editions 2008R2 & 2012 == Disabled

In my environment, which includes Macs, Windows XP, Windows 7, Windows 8, Server 2008R2 and Server 2012, I have disabled it on all systems and have not seen any sign of the original network error in 3 days.

I also never saw the issue when accessing any of my mac systems since they obviously don't have a Windows Computer Browser service at all.
 

My Computer

System One

  • OS
    Windows 8 Pro, Windows 7, Windows Server 2012
    Computer type
    PC/Desktop

mick823

New Member
Member

My Computer

System One

  • OS
    Windows 7 Pro and Windows 8.1 Pro 32 bit and 64 bit
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Lenovo and Dell
    CPU
    Intel i3
Top