• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Connecting to Mapped Network Drives at Boot


Mike8

New Member
Posts
16
#1
This is a boot up timing issue, does anyone know the registry fix for network comming up. I am on a wired LAN which works ok. However, recently when booting I am getting the message cannot connect to network drives - these are mapped drives to NAS boxes. However, when I access the drives the 'red X's' change to the network symbol and access is working. Its seems the computer wants to connect before the network is up. It is not a credential issue, but boot order. Is there anyway to make the network come up before the computer wants to map to it. Not a problem but a nag.
 

My Computer

System One

  • OS
    Windows 7

Wullail

Active Member
Pro User
Posts
467
#2
Not really it's been a known issue since...windows 95 and MS have never really admitted it's a problem....

you can tell your system to run a simple batch file with a delay of 10 seconds or more (depending on your system boot times) on logon using the scheduler

Logon_Network_Drives.bat (should look something like)
net use Y: \\storage\share /persistent:no
net use Z: \\storage\share /USER:username [password] /persistent:no



Disconnect your network drives before you log off/reboot after setting this batch file up to avoid the error message appearing...

There are more complicated ways to do this using vbscript to avoid the batch file box flashing up as well..

This is copied from windows forums , not sure if it'll work...but says he just put the .vbs script into the startup folder..

' Map network drive script - 10000 = 10 seconds
WScript.Sleep(10000)
Set objNetwork = CreateObject("WScript.Network")
objNetwork.MapNetworkDrive "F:" , "\\server\files"
objNetwork.MapNetworkDrive "M:" , "\\server\music"
objNetwork.MapNetworkDrive "P:" , "\\server\Pictures"
objNetwork.MapNetworkDrive "S:" , "\\server\disks"
objNetwork.MapNetworkDrive "V:" , "\\server\videos"


and some people swear that by editing the registry it's fixed

"To configure the EnableLinkedConnections registry value, follow these steps:


  1. Click Start , type regedit in the Start Search box, and then press ENTER.
  2. Locate and then right-click the following registry subkey:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
  3. Point to New , and then click DWORD Value .
  4. Type EnableLinkedConnections , and then press ENTER.
  5. Right-click EnableLinkedConnections , and then click Modify .
  6. In the Value data box, type 1 , and then click OK .
  7. Exit Registry Editor, and then restart the computer."

 

My Computer

System One

  • OS
    Windows 8 Pro
    Computer type
    PC/Desktop
    Memory
    6 GB
    Screen Resolution
    1280 x 1024
    Hard Drives
    12 TB in 6 disks
    PSU
    TX650
    Keyboard
    G15
    Mouse
    Intellimouse 3.0
    Internet Speed
    100 Mbits
    Browser
    Chrome
    Antivirus
    Trend Micro

Mike8

New Member
Posts
16
#4
I spoke too soon. I dont really want to start running batch files or vb script. I am assuming the reason is because its looking for the mapped drives before the network is up. If that is the case is there any registry hack to either start the network earlier or delaying the search for mapped drives. It used to be OK and I dont have a load of stuff in my start up just AVG, Malwarebytes and Zone Alarm free, all of which co-exist. Trying the delay option in mwb doesnt seem to help. M
 

My Computer

System One

  • OS
    Windows 7

Mike8

New Member
Posts
16
#5
I will answer this myself. Forget batch files, vb scripts and registry hacks. My new win 8.1 machine is too fast to boot for its own good - 18 secs to a desktop. My solution to get my mapped drives without the red 'X' s and system tray balloon is to go into power settings, and decheck the box which recommends a fast boot! I cannot really detect anything different when I start up, it works for my case anyway.

Thanks to GoodBytes, Montreal Canada for this solution (22 Nov 2012), for the suggestion to try.
http://forums.bit-tech.net/showthread.php?t=250528
 

My Computer

System One

  • OS
    Windows 7