• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Computer not auto-switching to G930 headset.


Posts
4
#1
I have a Windows 8.1 machine with a Sound Blaster ZX sound card. I also have a G930 headset that needed to be replaced. I just got my new G930 and was able to set it up fine. The software is installed and both it and the sound card have the latest drivers and Windows is completely up to date. When I plug in the dongle and turn on my headset, though, it doesn't automatically switch to output sound from the headphones. The only way I can get it to do this is by opening the sound options in the control panel and making the headset the default audio output device. This wasn't necessary before the headset malfunctioned and I needed to send it back for repairs, which was also before I upgraded from 8 to 8.1, it would switch to the headset as the primary output device as soon as I plugged the dongle in and switched the headset on.


Any ideas why it isn't doing this any more and how to get that behavior back. Does 8.1 have some issue with support of USB headsets that 8 didn't? Right now I have to constantly switch my default output device between my speakers and headphones depending on what I'm using and this shouldn't be necessary. I've also tried completely uninstalling my Logitech software and drivers and reinstalling them. No luck so far.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
#2
You should be able to just leave the headset set at default and save/apply settings. Then when finished with the headset, unplug and your PC should set itself to speakers settings as default once headset is unplug. My headset is setup the same way, works perfectly for me.

To answer your question; it could be the difference between 8/8.1 as to why it's happening with your headset. Same for my 8.1 setup.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom build
    CPU
    AMD Phenom II X 4 965 BE
    Motherboard
    Gigabyte GA-MA790X-DS4
    Memory
    G-Skill 8 GB PC 8500
    Graphics Card(s)
    AMD XFX HD Radeon 6790D
    Sound Card
    Realtek HD onboard
    Monitor(s) Displays
    2l Samsung SyncMaster S20B300
    Screen Resolution
    1600 X 900
    Hard Drives
    Seagate Barracuda 320 GB w/OS
    Seagate Barracuda 1 TB data storage
    PSU
    Ultra X4 750 watt fully modular
    Case
    Thermaltake OverSeer RX 1 fulltower
    Cooling
    Cooler Master Hyper212 120mm
    Keyboard
    Logitech G510
    Mouse
    Razor DeathAdder 3.5
#4
That's not setting your default device...that's strictly for sound. Right click your sound icon, select playback devices then select your headset as default (you can only have one selected at a time)...make sure headset plugged in when doing this.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom build
    CPU
    AMD Phenom II X 4 965 BE
    Motherboard
    Gigabyte GA-MA790X-DS4
    Memory
    G-Skill 8 GB PC 8500
    Graphics Card(s)
    AMD XFX HD Radeon 6790D
    Sound Card
    Realtek HD onboard
    Monitor(s) Displays
    2l Samsung SyncMaster S20B300
    Screen Resolution
    1600 X 900
    Hard Drives
    Seagate Barracuda 320 GB w/OS
    Seagate Barracuda 1 TB data storage
    PSU
    Ultra X4 750 watt fully modular
    Case
    Thermaltake OverSeer RX 1 fulltower
    Cooling
    Cooler Master Hyper212 120mm
    Keyboard
    Logitech G510
    Mouse
    Razor DeathAdder 3.5
Posts
4
#5
Thanks bassfisher, marking the headphones as the default device does give me the functionality I want like you said. It still seems strange that it isn't auto-switching like before but if it ain't broke...
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop