• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Changed RDP listening port, not 3389 wont work


DOYAM

New Member
Posts
7
#1
Changed RDP listening port, now no ports work

I just built a new HTPC, put Windows 8.1 on it, had RDP working fine for days. Even out of my house with port forwarding. Once I got everything where I wanted it, the last step was to change the port for security. I changed the registry Port Number (at HKEY_LOCAL_MACHINE, SYSTEM, CurrentControlSet, Control, Terminal Server, WinStations and RDP-Tcp), to a 5 digit number starting with 13 so its within the limits (also, I used to use the same port previously with Windows 7). Restarted and I could not connect. It did not work. So I tried putting it back to 3389 and its broken now too. I have a laptop on 8.1 also and changed it at the same time, now I have the same issues. I have tried everything I can think of. Check and even turned off the Firewall, used netstat -a and it seems to be listening on the correct port.
It seems to me there is something else at play here. Can anyone help me? This is at a bad time since I have leaving town for a few days and need access, I have to use VNC.
Help please.

FYI, I posted this exact same question here and have gone through some diagnostic steps to no avail: https://social.technet.microsoft.co...tworking#45858022-e0f2-442d-80cc-c24c20f3b2e7
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1

amir77a

Member
Member
Posts
27
#4
Did you configured your router and your Windows firewall ?
 

My Computer

System One

  • OS
    Win 8.1 Prof.
    Computer type
    Laptop
    System Manufacturer/Model Number
    Asus N55-JV
    CPU
    Core i7 (4700HQ)
    Memory
    8 Gigs
    Graphics Card(s)
    nVidia GT750M

DOYAM

New Member
Posts
7
#5
Sorry for the late reply. As I mentioned I had it working great before and I have configured my firewall and router. The router does not matter as I am only trying to get it working inside my network right now.
 

My Computer

System One

  • OS
    Windows 8.1

play2mefish

New Member
Member
Posts
162
#7
Did you remember to use the correct port when requesting a remote desktop connection: 192.168.1.10:3391 ???
Make sure the firewall is configured to listen and accept connections via the new port.
 

My Computer

System One

  • OS
    Windows 8 Pro
    System Manufacturer/Model Number
    ASRock 990FX Killer
    CPU
    AMD FX 8320
    Motherboard
    ASRock 990 FX Killer
    Memory
    32gb
    Graphics Card(s)
    Gigabyte GTX 750i
    Sound Card
    Realtek (Stock on MB)
    Monitor(s) Displays
    ASUS 27 HD Monitor & a 37" LCD HD TV Screen (For movies)
    Screen Resolution
    1920 x 1080
    Hard Drives
    1 250 GB SS hard drive for OS
    1 1TB hard drive for data / mirrored to a second 1 TB hd.
    PSU
    650W
    Case
    No name tower
    Cooling
    Enermax Liqtech 240
    Keyboard
    Logitech
    Mouse
    Logitech
    Internet Speed
    Dnload 10.48 Upload .48
    Browser
    IE 11 and Chrome when IE doesn't work
    Antivirus
    F-PROT

Ztruker

Well-Known Member
VIP Member
Guru
#8
The default RDP port is 3390, not 3389. Try that.
 

My Computer

System One

  • OS
    Windows 10 Pro X64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Lenovo IdeaCenter K450
    CPU
    Intel Quad Core i7-4770 @ 3.4Ghz
    Motherboard
    Lenovo
    Memory
    16.0GB PC3-12800 DDR3 SDRAM 1600 MHz
    Graphics Card(s)
    Intel Integrated HD Graphics
    Sound Card
    Realtek HD Audio
    Monitor(s) Displays
    HP h2207
    Screen Resolution
    [email protected]
    Hard Drives
    250GB Samsung EVO SATA-3 SSD;
    2TB Seagate ST2000DM001 SATA-2;
    1.5TB Seagate ST3150041AS SATA
    PSU
    500W
    Keyboard
    Wired USB
    Mouse
    Wired USB
    Internet Speed
    3GB Up, 30GB Down
    Browser
    SeaMonkey
    Antivirus
    Windows Defender; MBAM Pro
    Other Info
    UEFI/GPT
    PLDS DVD-RW DH16AERSH

DOYAM

New Member
Posts
7
#9
Thank you for all your input. I just tried to change it using 3389, 3390 and 3391. I am pretty sure the default RDP port is 3389 but it doesnt really matter. I changed it in regedit as I described above, I changed it in the router's settings as well and I turned off the firewall to make sure that wasnt it. I am doing all this remotely via TightVNC so I know how to configure these things. It like when I changed that listening port, it broke some other setting and I cannot put it back.
 

My Computer

System One

  • OS
    Windows 8.1

Ztruker

Well-Known Member
VIP Member
Guru
#10

My Computer

System One

  • OS
    Windows 10 Pro X64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Lenovo IdeaCenter K450
    CPU
    Intel Quad Core i7-4770 @ 3.4Ghz
    Motherboard
    Lenovo
    Memory
    16.0GB PC3-12800 DDR3 SDRAM 1600 MHz
    Graphics Card(s)
    Intel Integrated HD Graphics
    Sound Card
    Realtek HD Audio
    Monitor(s) Displays
    HP h2207
    Screen Resolution
    [email protected]
    Hard Drives
    250GB Samsung EVO SATA-3 SSD;
    2TB Seagate ST2000DM001 SATA-2;
    1.5TB Seagate ST3150041AS SATA
    PSU
    500W
    Keyboard
    Wired USB
    Mouse
    Wired USB
    Internet Speed
    3GB Up, 30GB Down
    Browser
    SeaMonkey
    Antivirus
    Windows Defender; MBAM Pro
    Other Info
    UEFI/GPT
    PLDS DVD-RW DH16AERSH

DOYAM

New Member
Posts
7
#11
Thank you guys for your help again. I think this was my mistake and I was not clicking "decimal" when I changed the port. It was on "hexidecimal". It works now.
 

My Computer

System One

  • OS
    Windows 8.1

Ztruker

Well-Known Member
VIP Member
Guru
#12
Yeah! Glad you have it working.
 

My Computer

System One

  • OS
    Windows 10 Pro X64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Lenovo IdeaCenter K450
    CPU
    Intel Quad Core i7-4770 @ 3.4Ghz
    Motherboard
    Lenovo
    Memory
    16.0GB PC3-12800 DDR3 SDRAM 1600 MHz
    Graphics Card(s)
    Intel Integrated HD Graphics
    Sound Card
    Realtek HD Audio
    Monitor(s) Displays
    HP h2207
    Screen Resolution
    [email protected]
    Hard Drives
    250GB Samsung EVO SATA-3 SSD;
    2TB Seagate ST2000DM001 SATA-2;
    1.5TB Seagate ST3150041AS SATA
    PSU
    500W
    Keyboard
    Wired USB
    Mouse
    Wired USB
    Internet Speed
    3GB Up, 30GB Down
    Browser
    SeaMonkey
    Antivirus
    Windows Defender; MBAM Pro
    Other Info
    UEFI/GPT
    PLDS DVD-RW DH16AERSH