• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Catalyst and Win 8 and 126 openGL errors


thatmanbrian

New Member
Member
Spain

Posts
150
#1
Update:

As discussed, AMD/ATI graphics cards using the Catalyst driver can cause problems related to OpenGL. For example, in LR4 edititng a file in CS6 results in Photoshop disabling the graphics GL accelleration and some plugins report a 126 error. I found that AMD's Catalyst 4.2 Beta Support Win7 Vista driver solved the issue.

Then AMD introduced the Catalyst Win8 Consumer Preview driver and the 126 error returned! I reverted to the Beta and all was well again.

Adobe Photoshop doesn't recognise the OpenGL acceleration on my ATI/AMD HD 5700 card unless this driver is installed.
 

My Computer

System One

  • OS
    Win 8 64bit
    System Manufacturer/Model
    self built
    CPU
    i5-2500K
    Motherboard
    Asus P8Z77
    Memory
    16Gb
    Graphics Card(s)
    AMD HD5700
    Monitor(s) Displays
    HPLP2475w, AOC
    Hard Drives
    SATA 3 SSD, SATA 2 5 drives total 6Tb
Posts
1,851
#2
I edited the .inf for the Consumer Preview driver so it installs well for my AGP card. All is well here in CS6:

Capture.JPG
 

My Computer

System One

  • OS
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86
    CPU
    P4 3.4 GHz HT
    Motherboard
    MSI-7211
    Memory
    OCZ 2 GB DDR @ 400 MHz
    Graphics Card(s)
    HIS AGP HD 3850 Turbo Ice-Q
    Sound Card
    MOTU Traveler firewire interface
    Monitor(s) Displays
    Acer x223w
    Screen Resolution
    1680x1050
    Hard Drives
    WD Caviar Black 1 TB Sata II, WD 400 GB Sata I, WD 120 GB Sata I
    PSU
    300W generic
    Case
    Cybertron
    Keyboard
    Logitech Classic Keyboard 200, Dell RT7D20
    Mouse
    Logitech M510
    Internet Speed
    2 MByte/sec Down, 250 KByte/sec Up

thatmanbrian

New Member
Member
Spain

Posts
150
#3
Thanks. I'll stick to the beta for now though. Posted my findings in case anyone else was caught out.
 

My Computer

System One

  • OS
    Win 8 64bit
    System Manufacturer/Model
    self built
    CPU
    i5-2500K
    Motherboard
    Asus P8Z77
    Memory
    16Gb
    Graphics Card(s)
    AMD HD5700
    Monitor(s) Displays
    HPLP2475w, AOC
    Hard Drives
    SATA 3 SSD, SATA 2 5 drives total 6Tb

Users Who Are Viewing This Thread (Users: 0, Guests: 1)